Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Login Batch beim booten in einer Endlosschleife.

Frage Microsoft Windows Netzwerk

Mitglied: nexutron

nexutron (Level 1) - Jetzt verbinden

25.11.2008, aktualisiert 27.11.2008, 7565 Aufrufe, 2 Kommentare

Hallo zusammmen,

in dem dem Ordner "C:\WINDOWS\SYSVOL\sysvol\domäne\scripts" des Windows 2003 Server`s liegen die Loginscripte der Mitarbeiter.
In dem Profilen der Mitarbeiter werden diese Scripte aufgerufen. (Karteikarte Profile unter "Anmeldescript" mit "Mitarbeiterlogin.bat"

Führt der Mitarbeiter die Batch direkt aus, werden alle Laufwerke ohne Fehler verbunden.

Wird die Batch im Anmeldevorgang selbständig aufgerufen, "hängt" die batch beim mappen des 1.Laufwerkes.
Dabei läuft in der Box der Mappingversuch endlos oft durch. Es sieht so aus als ob die Batch versucht dies hunderte mal nach einander auszuführen.

Zuerst dachte ich, das ich die falsche Batch gestartet hätte oder der Anmeldevorgang noch nicht so weit war (z.B. Rechte usw.) das die Batch nicht ordentlich abgearbeitet werden konnte.
Um es zu testen hatte ich eine Zeitschleife nachträglich eingebaut die das mappen der Laufwerke um 20 Sekunden verzögert.
Nach dem Login sieht man das auch im Anmeldescript. Sobald die Schleife um ist, hängt bzw. läuft ununterbrochen der Mappingversuch des 1. Laufwerkes.
Breche ich den Vorgang ab, kan ich genau die selbe Batch fehlerfrei durchlaufen lassen.

????? hat da jemand eine Idee ????
Ich würde ungern die Mitarbeiter bitten morgen`s die Batch von Hand zu starten.


Die Batch läuft fehlerfrei.
Da steht ja auch nix drin.


rem Echo off

net use L: \\192.168.0.1\Daten0

net use M: \\192.168.0.1\Daten1

net use N: \\192.168.0.1\Daten2



Gruß Nex
Mitglied: 60730
25.11.2008 um 20:39 Uhr
Zitat von nexutron:
Hallo zusammmen,

hallo zurück,

in dem dem Ordner
"C:\WINDOWS\SYSVOL\sysvol\domäne\scripts" des Windows
2003 Server`s liegen die Loginscripte der Mitarbeiter.
...und die dazugehörige Freigabe findest du unter %logonserver%\netlogon

Wird die Batch im Anmeldevorgang selbständig aufgerufen,
"hängt" die batch beim mappen des 1.Laufwerkes.
?
Dabei läuft in der Box der Mappingversuch endlos oft durch. Es
sieht so aus als ob die Batch versucht dies hunderte mal nach einander
auszuführen.
Woher weißt du das? Da du offensichtlich keine Schleife geschrieben hast - wäre das Verhalten sehr "merk"würdig.

????? hat da jemand eine Idee ????
Ich würde ungern die Mitarbeiter bitten morgen`s die Batch von
Hand zu starten.


Die Batch läuft fehlerfrei.
Da steht ja auch nix drin.
*puh* - wenn du schonm 20 sekunden Zeitschleife "probiert" hast - kann es eigentlich nicht das sein, was mein erster Gedanke war (Warten auf das netzwerk in der GPO nicht aktiv)
"Versuche es mal so - obwohl deine "Schleife" sehr unlogisch ist....
>code>
rem Echo off
net use L: /delete
net use m: /delete
net use n: /delete
ping 192.168.0.1
if exist 192.168.0.1\Daten0>nul net use L: \\192.168.0.1\Daten0
if exist \\192.168.0.1\Daten1>nul net use M: \\192.168.0.1\Daten1
if exist \\192.168.0.1\Daten2>nul net use N: \\192.168.0.1\Daten2
if not exist l:\>nul echo Fehler
</code>
Gruß Nex

zurück
Bitte warten ..
Mitglied: nexutron
27.11.2008 um 02:03 Uhr
Hallo,
danke erst mal für die Antwort.

Die Login Batch wird ja (bei mir) in Profile(die Karteikarte im ADS) des User`s aufgerufen.

Nach dem Login schliest sich das Fenster nicht, es bleibt "offen".
Da kann man die eingebaute Schleife sehen und das er den Mappinversuch (schon beim 1. Laufwerk) nicht zuende führen kann.
Die Batch versucht in bruchteilen von Sekunden zig mal das 1. Netzlaufwerk zu verbinden, kann es nicht und wiederholt den Vorgang endlos oft und sehr schnell.
Zu dem Zeitpunkt sind die Server und auch das NAS Laufwerk definitiv da.
Das minimierte Fenster des Scripts beendet sich ja nicht, daher kann /konnte ich parallel testen.
Öffne ich eine 2. CMD Box kann ich den Server anpingen und auch über die Netzwerkumgebung zugreifen.

Breche ich den Vorgang der Login Batch ab (STRG C) kann ich danach die selbe Batch fehlerfrei ausführen.
Einen anderen Befehl vor dem Mapping aufruf "net use */d"(elete) führt er aus.

Wie schon erwähnt, die Batch wird ordentlich abgearbeitet, wenn ich sie ein 2. mal starte.

Als Fehlerquelle kommt mir noch in den Sinn .. .. .. .. .. .. ..


FEHLER GEFUNDEN

Der Fehler ist so doof das er mir schon wieder gefällt.

Alle Loginscripte tragen die Namenskürzel der Mitarbeiter.

z.B. Paul Müller pam.bat usw. usw.
Bei einem Mitarbeiter ergab sich das Namenskürzel net.bat

und bei jedem Aufruf der Mitarbeiter mit dem Befehl net use X: usw. wurde das Script ausgeführt statt der Net.bat aus dem Systemordner.
Deshalb klappte es auch bei dem 2. Versuch vom Client aus. Da nutze das OS die Lokale net.bat nicht wie der Server die "nächste" im selben Ordner.


Gruß Nex
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Batch Login
gelöst Frage von ValeriBatch & Shell3 Kommentare

Hi ich habe folgende Problem mit batch/cmd ich habe folgende Code set zeile1=WILKOMMEN set zeile2=Installation-CD set zeile3%=Bitte geben Sie ...

Batch & Shell
Batch: Login überprüfen
gelöst Frage von SpyeerBatch & Shell3 Kommentare

Hallo @ all, Ich habe mir eine Batch Datei geschrieben mit diversen Tools. Die Batch Datei fungiert als eine ...

Microsoft Office
Endlosschleife im PowerPoint-Viewer 2010
gelöst Frage von SarekHLMicrosoft Office2 Kommentare

Hallo zusammen, wie kann ich mit dem PowerPoint-Viewer 2010 eine Präsentation in Endlosschleife immer wieder durchlaufen lassen? Danke im ...

CPU, RAM, Mainboards
Rechner startet und geht aus - Endlosschleife
Frage von grinserCPU, RAM, Mainboards17 Kommentare

Guten Tag! Mein eigener Rechner hat vor einiger Zeit den Geist aufgegeben. Schon zum zweiten mal ist mir das ...

Neue Wissensbeiträge
Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 18 StundenViren und Trojaner1 Kommentar

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 21 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Heiß diskutierte Inhalte
Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Vmware
DOS 6.22 in VMWare mit CD-ROM
gelöst Frage von hesperVmware10 Kommentare

Hallo zusammen! Ich hab ein saublödes Problem. Es ist eine VMWare mit DOS 6.22 zu erstellen auf dem ein ...

Cloud-Dienste
PIM als SaaS Nutzungsgebühr
Frage von vanTastCloud-Dienste8 Kommentare

Moin, wir haben uns ein PIM (Product Information Management) nach unseren Ansprüchen für viel Geld als SaaS-Lösung bauen lassen. ...