Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft Windows Netzwerk

Login Scripts werden von XP-Rechnern nicht abgearbeitet

Mitglied: Steinruck

Steinruck (Level 1) - Jetzt verbinden

01.02.2006, aktualisiert 09.12.2008, 14619 Aufrufe, 10 Kommentare

In Domäne mit Win2003 Server werden von XP-Clients die Loginscripte beim Anmelden nicht abgearbeitet.

Habe folgendes Problem:
In meiner Domäne starten alle Rechner mit automatischem Logon also ohne Benutzeranmeldung. Dabei müssen von den Clients Login Scripts zur Zuweisung von Netzlaufwerken abgearbeitet werden. Dies funktioniert bei allen Win2000 Clients und den meisten XP-Clients fehlerfrei.
Einige meiner XP-Clients - und zwar die, auf denen das Microsoft Shared Computer Toolkit installiert ist - arbeiten die Login Scripts jedoch nicht mehr ab.
Melde ich den User ab und wieder an, funktioniert es.
Schalte ich das automatische Login ab und verlange eine Passworteingabe funktioniert es auch.
Setze ich in der Registry den CachedLogonsCount auf 0 und verlange eine manuelle Anmeldung, meldet der Client manchmal, es sei keine Domäne verfügbar und ich könne mich nicht anmelden.

Nach allen Überprüfungen scheint es ein Timingproblem zu geben: Die automatische Anmeldung ist so schnell, dass die Login Scripts nicht abgearbeitet werden können, weil das Netzwerk noch nicht bereit steht. Solange der CachedLogonsCount auf 10 stand, fiel dies nicht auf, weil die lokalen Einstellungen benutzt wurden. Es wurden dann nur die Login Scripts nicht abgearbeitet.
Trotzdem ist es erstaunlich, dass die anderen XP-Clients korrekt arbeiten.
Versuche, am Server für die XP-Clients das "Warten auf das Netzwerk" in der GPO zu aktivieren, zeigten keine Wirkung!
Danke, Andreas
Mitglied: gijoe
01.02.2006 um 21:49 Uhr
Es gibt doch die Funktion das der PC erst nach abarbeiten der Loginscripte mit dem booten weiterfährt, findest du sicher in den GPO's
Grüsse GI
Bitte warten ..
Mitglied: Steinruck
02.02.2006 um 06:58 Uhr
Vielen Dank für die Antwort,
aber diese Funktion kenne ich nicht und habe sie beim Durchforsten der GPOs in den letzten Tagen auch nicht gefunden. Hast du einen Tipp, wo das stehen soll?
Danke, Andreas
Bitte warten ..
Mitglied: Goonie
03.02.2006 um 21:26 Uhr
Hallo Andreas,

ich glaube, gijoe meint in der Gruppenrichtlinie der Clients unter
->Computerkonfiguration->Administrative Vorlagen->System->Anmeldung
dort "Beim Neustart des Computers und der Anmeldung immer auf das Netzwerk warten"
den Status aktiv setzen.
Hoffe, daß hilft Dir vielleicht weiter!

Gruß
Aiko
Bitte warten ..
Mitglied: Steinruck
04.02.2006 um 08:36 Uhr
Hallo Aiko,

den Wert habe ich schon aktiviert, nutzt aber nichts. Im Moment funktioniert es nur, wenn ich das automatische Login abschalte und den User zwinge, ein möglichst langes Passwort einzugeben, damit der Rechner in der Zwischenzeit Zeit hat, das Netzwerk zu aktivieren. Dann wird das login-Script abgearbeitet. ...aber das kann es ja wohl nicht sein.
Vielen Dank, Andreas
Bitte warten ..
Mitglied: gijoe
07.02.2006 um 18:15 Uhr
hi, auch schon das ganze ins autostart gepappt? Kann mir nicht vorstellen das das verbinden von Netzlaufwerken Probleme macht, das sollte doch immer und überall gehen?
GI
Bitte warten ..
Mitglied: Goonie
07.02.2006 um 19:02 Uhr
Hi GI,

ich sag mal, beim NetLogon per Serverscript ist es ja grade der Vorteil, als dieses Script am Server konfiguriert werden kann. Die Autostart-Nummer mußt Du in einem z.B. 300-Clients-Netz erstmal abarbeiten.
Also an der Domäne anmelden und geht!! So sollte es sein. Is aber nicht, wenn XP, nur um schneller hochzufahren als seine Vorgänger, das Netzwerk ignoriert und evtl. schonmal Software startet, die eigentlich auch aufs Netzwerk zugreift.
Nicht im Sinne des Erfinders!

Gruß
Aiko
Bitte warten ..
Mitglied: gijoe
07.02.2006 um 19:04 Uhr
ok, das mit der sw leuchtet ein;) also wenn das mit der GPO nicht mehr geht...kannst es höchsten noch direkt via registry lösen...zB mit einem RegProgramm oder auf winfaq.de nachgucken
grüsse GI
Bitte warten ..
Mitglied: Steinruck
08.02.2006 um 07:32 Uhr
Hallo,
vielen Dank für die rege Beteiligung - aber hat von euch denn schon mal jemand von einem ähnlichen Fall gehört, dass die Cleints (XP) zu schnell für das Netzwerk hochfahren und man sie nicht (auch nur mal kurz) stoppen kann. Meine Einstellung mit dem automatischen Login ist zwar in Firmen so nicht üblich - aber es müsste doch schon mal aufgefallen sein!?

Ich meine, es ist klar: wenn der Client zu schnell ist, wartet er auch nicht auf die GPO-Aufforderung auf das Netzwerk zu warten. Es müsste also auf dem Client eine Einstellung geben, die ihn auffordert auf die GPO des Servers zu warten. Deshalb habe ich auch in der lokalen GPO versucht einzustellen, dass der Rechner aufs Netz warten soll - ändert aber nichts.
Viele Grüße, Andreas
Bitte warten ..
Mitglied: Goonie
08.02.2006 um 23:43 Uhr
Hi Andreas,
ja gehört schon öfter, sogar selbst erlebt. Der Rechner startet 3 mal korrekt, und beim 4.Mal crasht die Application weil der Netzzugang noch nicht steht. Bis jetzt war so etwas immer mit einer 5-10 Sekunden Warteschleife über Batch im Autostart (imho unschön) gelöst. Das Ganze allerdings mit lokaler Anmeldung und eben ohne NetLogonScript vom Server.

aber hier vielleicht noch ein Versuch (am Client)
HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows NT\ CurrentVersion\ Winlogon
"RunLogonScriptSync" auf 1 setzen

Gruß
Aiko
Bitte warten ..
Mitglied: InterDenis
09.12.2008 um 09:49 Uhr
Hallo,

falls hierzu immer noch keine genaue problemlösung vorhanden ist, habe ich hier eine für alle.

Hier die Script-Vorlage:

@echo off
echo Willkommen bei der *** !
echo ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

rem !!! Zur Umstellung erst mal alle Laufwerke löschen.

if %computername%==WSWXP3 goto wswxp3-no-delete

net use * /DELETE /Y

if %computername%==WSWXP13 goto sleep
if %computername%==WSWXP45 goto sleep
if %computername%==WXP010406 goto sleep
if %computername%==WSWXP4 goto sleep

:sleep
sleep 15


net use G: \\*server*\groups
net use T: \\*server*\Transfer-VMR
net use s: \\*server*\user
net use Q: \\*server*\qs
net use V: \\*server*\verwaltung
net use Z: \\*server*\Zentrale-Datenbank


rem --- Userverzeichis unter Transfer anlegen

if not exist t:\%username% mkdir t:\%username%


exit



Die Lösung des problems ergibt sich mit dem Befehl "sleep"
Bitte warten ..
Ähnliche Inhalte
PHP
MYSQL und PHP Login Script
gelöst Frage von GoldencreeperPHP17 Kommentare

Hallo liebe Administrator Community. Ich habe Arbeite grade an einer Status Seite für einen Hoster. Die Seite ist auch ...

Windows Server
Login Script verzögert ausführen
Frage von Intruder0001Windows Server6 Kommentare

Hallo gibt es die Möglichkeit das login Script verzögert nach der Anmeldung ca. 10-20sek auszuführen ?? Gerade bei schnellen ...

Windows Server
Pdf per login script
gelöst Frage von ToggleWindows Server4 Kommentare

Hallo zusammen, ich habe hier intern eine Fragestellung bekommen. Wir haben hier im 3 Stunden-Takt Personen, die sich an ...

Windows Server
Login Powershell Script Fehler
Frage von agnostikerWindows Server3 Kommentare

Hi, eigentlich wollte ich nur ein simples Script verfassen welches nach einem Erfolgreichen Anmelden eines Users dessen Workstation und ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 2 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 2 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 2 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 2 TagenSicherheit10 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
E-Mail
Erfahrungen mit hMailServer gesucht
Frage von it-fraggleE-Mail10 Kommentare

Hallo, meine neue Stelle möchte einen eigenen Mailserver. Ich als Linuxkind war direkt geistig mit Postfix dabei. Leider wollen ...

Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall9 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

Entwicklung
VBS: alle PDF-Dateien in einem Ordner gleichzeitig öffnen
gelöst Frage von JuweeeEntwicklung9 Kommentare

Hallo, ich habe in deiner Ordnerstruktur (.\Tagesberichte\xx.18\) mehrere dynamische PDF-Formulare (mit LCD erstellt). Die Berichtsformulare sind im Layout alle ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen8 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...