Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Logon Script Problem bezüglich Startmenü

Frage Microsoft Windows Server

Mitglied: wolficool

wolficool (Level 1) - Jetzt verbinden

20.08.2008, aktualisiert 21.08.2008, 3720 Aufrufe, 7 Kommentare

Hallo Leute,

hab da ein Logonscript Problem

Es soll in den Logonscript beim Startmenü die Accessoires ausgeblendet werden.

Wenn sich der User anmeldet, dann sieht er zwar was in den Accessoires enthalten ist kann aber eh nichts ausführen (GPO)

Was ist bei dem Script falsch gelaufen??

hier ein Auszug von den Befehtl bezüglich dem Startmenü:



'Delete Programs in Startmenu
wscript.sleep 5000
DeletePrograms sStartmenu
DeletePrograms sStartmenu & "Accessories\"
DeleteFolder sStartmenu & "Accessories"
DeleteFolder sStartmenu & "Startup"



Warum funktioniert dies nicht??

Besten Dank für eure Hilfe!!!

lg
Wolficool
Mitglied: 61801
20.08.2008 um 13:50 Uhr
zeig mal deine Subs her, mitdenen die die Ordner löscht
Bitte warten ..
Mitglied: wolficool
20.08.2008 um 14:30 Uhr
Hier die Subs dazu:



Sub DeletePrograms(sFolder)
'--------------------------------------------------------------------------------------

On Error Resume Next

Dim fso, f, f1, fc, s, i

Set fso = CreateObject("Scripting.FileSystemObject")
Set f = fso.GetFolder(sFolder)
Set fc = f.Files

i = 0

For Each f1 in fc

sFilename = f1.name

DeleteFile sfolder & sFilename

i = i + 1

Next

End Sub

'-----------------------------------------------------------------
Sub DeleteFolder(sfolder)
'-----------------------------------------------------------------

On Error Resume Next

Dim fso
Set fso = CreateObject("Scripting.FileSystemObject")
fso.DeleteFolder(sfolder),true

End Sub
Bitte warten ..
Mitglied: 61801
20.08.2008 um 14:35 Uhr
naja "Fehler" gefunden
du verwendest
On Error Resume Next

is klar dass dann nix passiert.
Vielleicht haben die Ordner die du löschen willst einen Sonderstatus.

BTW: wiso hast du eine Laufvariable i, welche du nirgends ausliest, sondern nur setzt? (Überbleibsel löschen)
Bitte warten ..
Mitglied: wolficool
20.08.2008 um 15:29 Uhr
hmm ich bin jetzan ned der Spezi leider.


Ich kann dir nur sagen was derzeit im Script steht.

Was sollte ich denn ändern??
Bitte warten ..
Mitglied: 61801
20.08.2008 um 15:32 Uhr
lass mal das On Error resume next weg
dann sollte hoffentlich ne Fehlermeldung kommen ca. so :"Konnte nich löschn,m weil----"
Wenn nix kommt liegt der fehler wo anders.
Bitte warten ..
Mitglied: wolficool
20.08.2008 um 16:01 Uhr
So habs gelöscht den Eintrag On Error Resume next

Es bleibt alles beim alten.

Es erscheint auch keine FM leider.
Bitte warten ..
Mitglied: Logan000
21.08.2008 um 10:07 Uhr
Moin Moin

Las die mal per msgbox die jeweiligen Pfade ausgeben
z.B.:
01.
'------------------------------- 
02.
Sub DeleteFolder(sfolder) 
03.
'------------------------------- 
04.
Dim fso 
05.
   Set fso = CreateObject("Scripting.FileSystemObject") 
06.
   msgbox sfolder         ' nur zum debuggen 
07.
   fso.DeleteFolder(sfolder),true 
08.
End Sub
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Microsoft
Windows 10 logon script: alle Apps löschen (3)

Frage von thomasreischer zum Thema Microsoft ...

Windows Netzwerk
Problem mit PSexec64 von Sysinternals (2)

Frage von MaxMoritz6 zum Thema Windows Netzwerk ...

Batch & Shell
gelöst PowerShell Script Move-Item nach x Tagen (5)

Frage von lupolo zum Thema Batch & Shell ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...