Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Logon Script wird nicht richtig ausgeführt!

Frage Microsoft

Mitglied: Itfreak

Itfreak (Level 1) - Jetzt verbinden

26.05.2009, aktualisiert 09:02 Uhr, 5074 Aufrufe, 4 Kommentare

MOin MOin

Ich habe da mal eine Frage bei meinem Script werden die Netzlaufwerke der Gruppe glo-admins nicht gemappt!

Leider kann ich den Fehler nicht genau herausfiltern. Das hier ist alles !!

Danke im Voraus für die Hilfe!

NET USE
[devicename | *] [\\computername\shar
[/USER:[domainname\]username]
[/USER:[dotted domain name\]u
[/USER:[username@dotted domai
[/SMARTCARD]
[/SAVECRED]
[[/DELETE] | [/PERSISTENT:{YE

NET USE {devicename | *} [password |

NET USE [/PERSISTENT:{YES | NO}]

01.
@ECHO OFF 
02.
 
03.
REM Zeitsynchronisieren mit dem Server 
04.
NET TIME \\svr01 /SET /YES 
05.
 
06.
REM Gruppenabfrage mit dem DSGET-Befehl und EXPAND Option - rekursiv 
07.
%LOGONSERVER%\NETLOGON\DSQUERY USER -SAMID %USERNAME% | %LOGONSERVER%\NETLOGON\DSGET USER -MEMBEROF -EXPAND | FINDSTR /I "glo-user" > NUL 
08.
IF %ERRORLEVEL% EQU 0 NET USE N: \\svr01\Dokumente$ /PERSISTENT:NO > NUL 
09.
 
10.
REM Gruppenabfrage mit dem DSGET-Befehl und EXPAND Option - rekursiv 
11.
%LOGONSERVER%\NETLOGON\DSQUERY USER -SAMID %USERNAME% | %LOGONSERVER%\NETLOGON\DSGET USER -MEMBEROF -EXPAND | FINDSTR /I "glo-admins" > NUL 
12.
IF %ERRORLEVEL% EQU 0 NET USE Z: \\svr01\5.0 IT Network$ /PERSISTENT:<NO> NUL 
13.
 
14.
 
15.
REM Drucker verbinden mit rundll32 
16.
rundll32 printui.dll,PrintUIEntry /in /n \\svr01\Brother-MFC-9840CDW 
17.
 
18.
 
19.
REM Drucker als Standard definieren mit con2prt 
20.
%LOGONSERVER%\NETLOGON\CON2PRT /CD \\svr01\Brother-MFC-9840CDW 
21.
 
Mitglied: bstefan82
26.05.2009 um 09:11 Uhr
Hi,

was für eine Umgebung hast du laufen?(AD?)
Sofern du ein AD hast und XP Sp2 Clients oder höher, solltest du dir mal Group Policy Preferences anschauen, damit kannst du Drucker und Laufwerke über GPO's erstellen.
Falls nicht, solltest du dir mal KIX32 anschauen .. ist bequemer als Batch Dateien.


Grüße,

Stefan
Bitte warten ..
Mitglied: Biber
26.05.2009 um 09:20 Uhr
Moin itfreak,

falls Du noch nicht alles alles auf Kix umgestellt hast
Streiche: IF %ERRORLEVEL% EQU 0 NET USE Z: \\svr01\5.0 IT Network$ /PERSISTENT:<NO> NUL
Setze: IF %ERRORLEVEL% EQU 0 NET USE Z: "\\svr01\5.0 IT Network$" /PERSISTENT:NO >NUL

Grüße
Biber

[Edit] Slainthes Bugfix nachgezogen. Thx. [/Edit]
Bitte warten ..
Mitglied: SlainteMhath
26.05.2009 um 09:40 Uhr
Moin,

zusätzlich noch

01.
<NO>
durch
01.
NO
ersetzen, dann klappts

Darf ich fragen warum Du die umständliche DSGET Konstrukte benutzt, und nicht etwa ifmember.exe?

lg,
Slainte
Bitte warten ..
Mitglied: Itfreak
26.05.2009 um 10:06 Uhr
Salü

Ja habe es mit der Ifmember versucht das wollte aber irgendwie nicht so richtig!
Darum habe ich es mit der DSGET gemacht!

Danke für die vielen Antworten


Itfreak
Bitte warten ..
Ähnliche Inhalte
Exchange Server
GPO - Logon-Skript wird nicht ausgeführt (4)

Frage von Der-Phil zum Thema Exchange Server ...

Windows 10
Windows 10 Powershell Logon Script (9)

Frage von derhoeppi zum Thema Windows 10 ...

Windows Userverwaltung
gelöst Logon Script mit einer .reg Datei (7)

Frage von Kathaki zum Thema Windows Userverwaltung ...

Windows Server
Anzeige bei "run logon scripts synchronously" möglich?

Frage von ahstax zum Thema Windows Server ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Monitoring
Netzwerk-Monitoring Software (18)

Frage von Ghost108 zum Thema Monitoring ...

Windows 10
Seekrank bei Windows 10 (17)

Frage von zauberer123 zum Thema Windows 10 ...

Windows Server
gelöst Kopiervorgang schlägt fehl, weil Datei- und Ordnername zu lang sind (14)

Frage von Schroedi zum Thema Windows Server ...

Windows 10
Windows 10 Fall Creators Update Fehler (13)

Frage von ZeroCool23 zum Thema Windows 10 ...