Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Logonscript: Net use /Delete funktioniert nicht (**erledigt**)

Frage Entwicklung Batch & Shell

Mitglied: Arcanus

Arcanus (Level 1) - Jetzt verbinden

18.01.2006, aktualisiert 22:12 Uhr, 59791 Aufrufe, 3 Kommentare

Guten Tag

In folgendem Logonscript Funktioniert der Befehl, welcher das Laufwerk y löscht nicht. Die anderen Befehle funktionieren jedoch alle.

01.
@echo off 
02.
color 09 
03.
title Anmeldung am Server © by F. Grossman ^& P. Zenhaeusern 
04.
echo ************************************ 
05.
echo *                                  * 
06.
echo *         Anmelden am Server       * 
07.
echo *                                  * 
08.
echo ************************************ 
09.
echo. 
10.
echo. 
11.
echo Alte Netzlaufwerke werden geloescht und neue werden erstellt... 
12.
ping 192.168.123.25 -n 2 -w 1000 > NUL 
13.
echo. 
14.
if exist G: net use G: /DELETE > NUL 
15.
if exist y: net use y: /DELETE > NUL 
16.
if exist i: net use i: /DELETE > NUL 
17.
 
18.
net use y: \\Server2000\Sekretariat > NUL 
19.
 
20.
if exist x: net use x: /delete > NUL 
21.
 
22.
net use x: \\server2000\www.BackThisUp.ch > NUL 
23.
color 0c 
24.
echo Das Laufwerk Sekretariat (S:) wurde im Arbeitsplatz erfolgreich hinzugefuegt! 
25.
 
26.
ping 192.168.123.25 -n 3 -w 1000 > NUL 
27.
 
28.
exit
Wo liegt hier der Hund begraben?
Mitglied: Metzger-MCP
18.01.2006 um 10:57 Uhr
Rem doch mal die 3 Zeilen mit

if exist g: net use g: /DELETE > NUL
if exist y: net use j: /DELETE > NUL
if exist i: net use i: /DELETE > NUL

aus und schreibe darunter

net use G: /DELETE
net use Y: /DELETE
net use I: /DELETE

if exist basiert eigentlich darauf, das überprüft wird, ob eine Datei xyz an der Stelle vorhanden ist.

richtiger wäre

if exist g:\abc.bat net use g: /DELETE > NUL

wenn nun bei g:\ die datei abc.bat gibt, führt er net use g: /DELETE aus, sonst nicht.

Mfg Metzger
Bitte warten ..
Mitglied: c-o-2
18.01.2006 um 11:51 Uhr
Probiers mal soooooooo
net use [laufwerk] /delete /yes > NUL

Damit bist du auf der sicheren Seite das alte Verbindungen weg sind
net use * /delete /yes >NUL
Bitte warten ..
Mitglied: 48u
18.01.2006 um 22:12 Uhr
ähm danke für eure hilfe
aber es hat shcon funktioniert, das netzlaufwerk konnte nich gelöscht werden, da wir (ich und aracuns) ausversehn dem administartor die Rechte wegenommen haben oO als wir rechte wieder verteilt haben gings^^

aber danke
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Netzlaufwerk wird nicht per Logonscript verbunden, manuell per net use funktioniert
Frage von rababar2014Batch & Shell1 Kommentar

Moin Leude, habe gerade ein komisches Problem. Ich habe einen Linux Samba Share, den ich in mein Netlogonscript integrieren ...

Windows Userverwaltung
Fehlermeldung Netzwerkkennwort falsch bei Net use, windows funktioniert
Frage von wescraven07Windows Userverwaltung5 Kommentare

Hallo Leude, ich habe ein Problem, mit einem Domainbenutzer von uns. Ich habe den Benutzer vor ein paar Tagen ...

Windows 7
Net use mit gui
Frage von Lebowski23Windows 71 Kommentar

Hallo, folgendes Problem: In einem Netzwerk existiert ein LDAP-Server mit Samba, der für einige Rechner auch als Domain-Server dient. ...

Windows Netzwerk
Printerumleitung mittels net use wollen nicht
Frage von orrybeachWindows Netzwerk6 Kommentare

Ich habe einige Arbeitsstationen von Windows XP auf Win 7 umgestellt. Leider läuft noch ein altes DOS-Programm, welches unter ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 21 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement16 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...