Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

m0n0wall 2 Subnetze Programmabbrüche

Frage Netzwerke

Mitglied: Eierbaer

Eierbaer (Level 1) - Jetzt verbinden

26.07.2009, aktualisiert 12:49 Uhr, 4593 Aufrufe, 7 Kommentare

Hallo,

ich habe ein Subnetz (192.168.178.0) das mit dem Internet verbunden ist und in dem ein Datenbankserver läuft. Nun habe ich ein 2. Subnetz (192.168.1.0) auf gebaut, das Zugriff auf das 1. Subnetz haben soll (Datenbankserver und Freigaben).

Dazu habe ich einen PC mit M0n0wall als Router aufgesetzt und es funktioniert auch alles wunderbar (Internet und Zugriff auf Freigaben).

Das Problem: In dem 2. Subnetz befinden sich mehrere PC, die per Freigabe eine Anwendung mit einer SQL-Datenbankanbindung starten sollen. Der Datenbankserver befindet sich im 1. Subnetz.Das Programm läßt sich auch starten, aber es bricht mitten in der Anwendung ohne Fehlermeldung ab (wenn die Anwendung auf einen weiteren Rechner gestartet wird). An der Programminstallation kann es nicht liegen. Die PC's laufen im 1. Subnetz ohne Probleme.

Es muß irgendwie am Router (m0n0wall) liegen. Die Firewall habe ich auch schon komplett geöffnet. Nichts half.

Hat jemand evtl. einen Tipp oder schon einmal ähnliches gehabt?

Gruß Rüdiger
Mitglied: Pjordorf
26.07.2009 um 13:05 Uhr
Hallo,

ich vermute mal du hast..... Egal was ich vermute. Du solltest uns genaueres mitteilen. Wieviele Router hast du? Wie sind die verbunden? Welcher Router routet wie? Das es icht am Programm liegt? naja. In subnetz 1 geht es, in Subnetz2 nicht, aber nur teilweise? Programmstart = Verbindungsaufbau zur SQL Datenbank? oder wird nur das Programm gestartet? und wenn der Verbingsaufbau stattfindet bricht die Anwendung einfach ab? (Schlechte Programmierung wenn Fehler nicht ausgewertet werden). Welche Firewall hast du komplett geöffnet? Warum?

Peter
Bitte warten ..
Mitglied: Eierbaer
26.07.2009 um 16:11 Uhr
Hallo Peter,

Aufbau:

Internet <=> Router(Fritzbox) <==> 1.Subnetz (192.168.178.0) <==> Router (m0n0wall) <==> 2.Subnetz (192.168.178.0).

Die m0n0wall routet vom 2. ins 1. Subnetz.

Folgendes Phänomen:
Programm wird im 2. Subnetz über eine Windows-Freigabe aus dem 1. Subnetz gestartet. Verbindungsaufbau zur Datenbank funktioniert über ein Login und das Programm kann ganz normal und mit allen Funktionen benutzt werden.

Startet ich dann das Programm zum 2.mal aus dem 2. Subnetz (anderer PC) und melde mich an also Datenbankverbindungsaufbau, dann brechen beide Programme ab.

Gruß Rüdiger
Bitte warten ..
Mitglied: Pjordorf
26.07.2009 um 16:56 Uhr
Hallo Peter,

Aufbau:

Internet <=> Router(Fritzbox) <==> 1.Subnetz
(192.168.178.0) <==> Router (m0n0wall) <==> 2.Subnetz
(192.168.178.0).

Die m0n0wall routet vom 2. ins 1. Subnetz.


Und das geht? Oder hast du eine Schreibfehler in den IP's?



Folgendes Phänomen:
Programm wird im 2. Subnetz über eine Windows-Freigabe aus dem
1. Subnetz gestartet. Verbindungsaufbau zur Datenbank funktioniert
über ein Login und das Programm kann ganz normal und mit allen
Funktionen benutzt werden.

Startet ich dann das Programm zum 2.mal aus dem 2. Subnetz (anderer
PC) und melde mich an also Datenbankverbindungsaufbau, dann brechen
beide Programme ab.

Dann hast du NAT? am laufen,oder? Dein Programm kann aber zwischen den beiden PC's nicht unterscheiden. Vermutlich unterscheidet deine anwendung nur nach IP, oder?

Peter
Bitte warten ..
Mitglied: Eierbaer
26.07.2009 um 19:52 Uhr
Sorry,

das 2. Subnetz muß natürlich 192.168.1.0 sein.

Die Anwendung ist eine Datenbankanwendung basierend auf einer MS-SQL-Datenbank und ist multiuserfähig und läuft auch im 1. Subnetz auf mehreren PC gleichzeitig ohne Probleme.

Mit Firewall-einstellungen bin ich nicht so der Experte, habe die m0n0wall in der Standard-Konfiguration installiert und gestartet.

P.S.: Im Erreignisprotokoll (Anwendung) der PC mit den Abstürzen gibt es Fehlereinträge (Application Error - 1000 und 1005) , die besagen, das Probleme mit der Netzwerkverbindung bestehen.

Rüdiger
Bitte warten ..
Mitglied: Eierbaer
31.07.2009 um 08:03 Uhr
Moin, Moin,

da das Szenario mit der m0n0wall nicht wirklich funktionierte, habe ich mich nun dazu entschlossen den Windowsserver im 2. Subnetz mit 2 Netzwerkkarten zu betreiben und ihn als Router zu konfigurieren.

Das funktioniert, obwohl es nicht die Optimallösung ist.

Gruß aus Kiel.
Bitte warten ..
Mitglied: Pjordorf
31.07.2009 um 11:18 Uhr
Hallo,

Das funktioniert, obwohl es nicht die Optimallösung ist.

Wo ist da dein Problem.

Peter
Bitte warten ..
Mitglied: Eierbaer
31.07.2009 um 12:32 Uhr
Hallo Peter,

Sinn und Zweck der Trennung in 2 Subnetze war es, das 2.Subnetz zu 'verstecken', vor Übergriffen jeglicher Art aus dem 1. Subnetz. Aus dem 2. Subnetz (192.168.1.0)soll aber auf das 1. Subnetz (192.168.0.0) zugegriffen werden können (dort steht der DC und ein Datenbankserver).

Der Server im 2. Subnetz seht den Rechner im 2. Subnetz als Fileserver (vertrauliche Daten) zur Verfügung, sprich es sind Freigaben darauf gestartet.

Dadurch, dass der Server nun 2 Netzwerkkarten hat, ist er über über die IP-Adresse aus dem 2. Subnetz (192.168.1.x) noch sichtbar. Auf der 1. Netzwerkkarte habe ich die 'Datei- und Druckerfreigabe-' aus den Eigenschaften entfernt. Dies kann ich auf der 2. Netzwerkkarte nicht machen, da ich sonst im 2. Subnetz keine Freigaben mehr sehe.

Ich hoffe, es ist verständlich beschrieben.

Rüdiger
Bitte warten ..
Ähnliche Inhalte
Netzwerke
Netzwerkaufbau mit 2 Subnetze und openWRT
Frage von kiritoNetzwerke6 Kommentare

Hallo, ich möchte mein Netzwerk ein einig aufpolieren, und habe schon fiel darüber gelesen auch hier im Forum. Bis ...

Switche und Hubs
2 Subnetze verbinden
gelöst Frage von 117109Switche und Hubs6 Kommentare

Hallo Leute, wie verläuft es, wenn ich 2 Subnetze via switch (reiner Layer 2 Switch) miteinander verbinden möchte. Funktioniert ...

Windows Server
1 DHCP 2 Subnetze
Frage von technikdealerWindows Server5 Kommentare

Hay Ihr. Ich habe ein Server 2008 R2 mit konfigurierter Bereichsgruppierung. Ein Bereich der Gruppe hat 192.168.100.0 und der ...

Netzwerkmanagement
24 Subnetz mit 2 VLANs
gelöst Frage von netscratNetzwerkmanagement4 Kommentare

Moin zusammen, folgendes Szenario ergibt sich grade für ein Schulprojekt: Firma mit 3 Stockwerken und in denen sind jeweils ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 1 TagWindows 106 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 2 TagenInternet5 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 2 TagenDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Batch & Shell
Kann man mit einer .txt Datei eine .bat Datei öffnen?
Frage von HelloWorldBatch & Shell16 Kommentare

Wie schon im Titel beschrieben würde ich gerne durch einfaches klicken auf eine Text oder Word Datei eine Batch ...

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...

Windows Server
Ping auf einen bestimmten Server nicht möglich
gelöst Frage von a.thierWindows Server7 Kommentare

Hallo, ich habe folgendes Problem. srv-dc1: Ping srv-nav > geht Ping srv-exchange > geht nicht srv-exchange: Ping srv-dc1 > ...

Hardware
Fujitsu Workstation mit K80 und Quadro P5000, Fehlermeldung: Connect Power Adapter
Frage von MachelloHardware7 Kommentare

Hallo Zusammen, ich benötige euren Rat da ich ratlos bin. Folgende Konfiguration im Büro: Fujitsu Workstation Celcius R940 Power ...