Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

M0n0wall ping von Subnetz zu Subnetz funktioniert nicht

Frage Netzwerke

Mitglied: reitzi

reitzi (Level 1) - Jetzt verbinden

26.02.2012, aktualisiert 18.10.2012, 5229 Aufrufe, 5 Kommentare

Hallo ich bin neu in der Welt der Netzwerktechnik. Vor kurzem habe ich mir ein Alix.2d13 mit m0n0wall besorgt.
Ich habe versucht nach der Anleitung von aqui mein Netzwerk aufzubauen.

Der grobe Netzwerkaufbau soll dabei wie folgt aussehen.
7f44bec8c84373144ff07f05a85814b4 - Klicke auf das Bild, um es zu vergrößern

mit den Änderungen:
vr0: LAN 10.14.7.1 /24
Subnet mask: 255.255.255.0
DHCP eingerichtet: 10.14.7.100-150

vr2: Gasthaus (=Opt1) 172.18.9.1 /24
Subnet mask: 255.255.255.0
DHCP eingerichtet: 172.18.9.100-150
Router als AP: 172.18.9.2

Das Netzwerk "LAN" ist für meinen privaten Gebrauch gedacht und "Gasthof" soll als CP dienen. Dabei möchte ich von LAN aus, Zugriff auf das Subnet Gasthof haben. Zu Test-Zwecken habe ich in beiden Netzwerken alles erlaubt.

d9385f1ba73b0522c8d847e809d7b997 - Klicke auf das Bild, um es zu vergrößern
1e370af7e0fbfab485f2a4d7232fee32 - Klicke auf das Bild, um es zu vergrößern

Nun zum Problem:
Ich habe an die Firewall einen Laptop (LAN) und einen als AP eingestellten Router (Gasthof) angehängt. Vom Laptop aus lässt sich das WebGUI über beide Interfaces aufrufen, aber ich komme nicht auf den Router.

Deshalb habe ich den Router gegen einen weiteren Laptop getauscht. DHCP funktioniert, beide Laptops haben eine IP-Adresse zugewiesen bekommen. Leider ergibt sich hier das gleiche Bild. Von beiden Laptops kann ich WebGUI über beide Interfaces öffnen, aber beim gegenseitigen pingen gibt es eine Zeitüberschreitung der Anforderung.

Danke für eure Hilfe,
Reitzi

Nachtrag 27.02.2012 12Uhr:
Ich hänge hier noch die zwei von mir beschriebenen Szenarien an, da ich nicht weiß wie ich die Bilder in eine Beitragsantwort hinein bekomm.

Szenario1:
cb5e3145865eef48ddb7596efac26b46 - Klicke auf das Bild, um es zu vergrößern

Szenario2:
74e08cf5f473de306cbf1cea59137cb7 - Klicke auf das Bild, um es zu vergrößern
Bei dem Router handelt es sich um TP-Link WR1043ND mit DD-WRT v24-sp2 Firmeware der als AP konfiguriert wurde.
Mitglied: HubertN
27.02.2012 um 09:12 Uhr
Moin

auch wenn ich durch dein Konstrukt gerade mal een nicht so ganz durchsteige (es ist doch immer wieder klasse, wenn Zecihnungen veröffentlicht werde, deren INhalt nicht zum text passt...): Dein Problem ist in 99 % der Fälle darauf zurückzuführen, dass im jeweiligen Subnetz die Riute zum anderen netz fehlt.

Gruß

Hubert
Bitte warten ..
Mitglied: reitzi
27.02.2012 um 09:34 Uhr
Guten Morgen Hubert,

ich hatte bereits verschiedene Static Routes eingerichtet, jedoch ohne Erfolg.

Brauche ich die Static Route damit ich vom einen ins andere Netzwerk komme.
Aus dem Handbuch der m0n0wall:

4.3.2. Static Routes
Static routes are necessary when you have a subnet behind another router on any of your internal networks. Static routes are never required for directly connected networks or if the network in question is reachable through your WAN interface's default gateway.

The Static Routes sub section allow the user to set up static routes in order to reach network that must use a gateway different from the default one. By pressing the + icon, the system allows the user to add new static routes.

Die Zeichnung die ich von aqui übernommen habe zeigt das Konstrukt wie es einmal aussehen soll. Momentan habe ich einfach nur zwei Laptops an der m0n0wall.

Grüße,
Reitzi
Bitte warten ..
Mitglied: aqui
27.02.2012, aktualisiert 18.10.2012
Nein, eine statische Route ist Unsinn, die benötigst du nicht ! Vergiss die und lösch sie gleich wieder !
Die Monowall macht NAT ( IP Adress Translation) am WAN Port, deshalb "sieht" der Internet Router die beiden IP Netze gar nicht, denn Pakete aus diesen netzen kommen am Internet Router durch das NAT immer mit der WAN IP Adresse der Monowall als Absender IP bei ihm an, logischerweise.
Nein, vermutlich hast du nur, wie fast immer in solchen Szenarien mit einem NET Router statt Modem vor der Firewall (WAN Port), schlicht und einfach vergessen den Haken beim Filtern der RFC 1918 ( private_IP_Netze ) im WAN Port Setup zu deaktivieren !!
Dein Verbindungsnetz (WAN Port Mono auf Internet Router) ist mit ziemlicher Sicherheit ein IP Netz aus diesem Bereich. (Leider teilst du uns das ja nicht mit )
Wenn dieser Default Filter also nicht deaktiviert ist werden alle eingehenden Pakete aus solchen Netzen gnadenlos geblockt !
Nimm das also raus und dann klappts auch mit dem Zugriff aus deinen beiden LAN Segmenten auf den Internet Router !
Achtung: Wenigstens vom Gastnetz solltest du das aber mit einer FW Regel später wieder verbieten !!
Hier der Screenshot bei pfSense. (Das ist bei Monowall identisch, ganz unten bei den Einstellungen des WAN Interfaces.)
e353eaea1abf54c7dd241cf90a77dae1 - Klicke auf das Bild, um es zu vergrößern
Wie du deinen Router richtig konfigurierst damit er als simpler AP funktioniert sagt dir dieses Tutorial:
http://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ...
Bitte warten ..
Mitglied: tikayevent
27.02.2012 um 10:19 Uhr
Statische Routen braucht man in diesem Fall nicht, weil ja die m0n0wall Router für beide Netzwerke ist.

Bei dir scheint einfach ne Firewall auf den Notebooks aktiv zu sein, die die Kommunikation verhindert. Denn so wie es eingestellt ist, ist es richtig.
Bitte warten ..
Mitglied: reitzi
27.02.2012 um 12:15 Uhr
Danke für eure Anworten!

Ich habe oben in meinem Beitrag zwei Bilder eingefügt, die die genannten Szenarien erklären sollen.

Szenario1:
tikayevent hatte recht, die Windowsfirewall hat den Ping verhindert. Ich dachte, da es sich hier um private IP-Adressen handelt, blockt die Win-Firewall den Ping nicht. Mit deaktivierter Win-Firewall funktioniert der Ping einwandfrei.

Szenario2:
Auch mit deaktivierter Win-Firewall komme ich vom LAN-Netzwerk (10.14.7.0/24) nicht auf den Router (172.18.9.2). Muss ich, da ich von einem anderem Netzwerk aus auf dem Router zugreife, den WebGUI-Fernzugriff aktivieren? Ich habe leider immer noch nicht verstanden wie die Wonowall die zwei Netzwerke miteinander verknüpft.
Bitte warten ..
Ähnliche Inhalte
DNS
DNS Auflösung aus Subnetz funktioniert nicht
Frage von SRandinDNS7 Kommentare

Hallo zusammen, wir haben einen Router (A) mit einem eigenen DHCP Server als Subnetz aufgebaut. An diesem Router A ...

Internet
Kein Internet, Ping funktioniert
gelöst Frage von crinaXInternet20 Kommentare

Guten Morgen liebe Community, ich habe ein kleines Problem was mich grade ein wenig zum verzweifeln bringt Ich bin ...

Netzwerkprotokolle
Router Ping funktioniert nicht
Frage von Barti20Netzwerkprotokolle4 Kommentare

Hallo Leute, ich habe ein Problem worauf ich mir kein Reim machen kann. Folgendes Problem: Ich komme von einem ...

Router & Routing
WOL über zwei Router - Ping funktioniert nicht
gelöst Frage von erdmeloneRouter & Routing3 Kommentare

Hallo zusammen, Ich habe vor meinen Rechner im Heimnetzwerk mit WOL so einzurichten, dass ich on überll her ihr ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 6 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 11 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 11 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 23 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Windows Server
Remotesteuerung der Sitzung (Kennung XX) fehlgeschlagen
gelöst Frage von Stefan91Windows Server14 Kommentare

Hallo Zusammen, seit kurzem bekomme ich oben genannte Fehlermeldung, wenn ich versuche eine Remotesitzung über den Taskmanager fernzusteuern (Rechtsklick ...