Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Mail-Befehl will nicht...

Frage Entwicklung PHP

Mitglied: 35801

35801 (Level 1)

14.03.2009, aktualisiert 15:47 Uhr, 2098 Aufrufe, 1 Kommentar

Ich habe ein (mir) unbegreifliches Problem...

Folgendes klappt einwandfrei:
01.
$betreff = "Antwort auf deine Anzeige"; 
02.
$mail = mail($email, $betreff, $_POST['nachricht'], "From: ".$_POST['name']." <".$_POST['absender'].">");
ABER auf dem GLEICHEN SERVER (in einem anderen Verz.) bekomme ich folgendes Skript nicht dazu Mails zu versenden...
01.
$subject = "Passwort vergessen"; 
02.
$mail_body = "Bla, Bla, Bla! PW: ".$pwd;  
03.
$header = "From: MeineSeite.com <noreplay@meineseite.com>\r\n"; 
04.
$mail_ok = mail($email, $subject, $mail_body, $header); 
05.
 
06.
Witziger Weise liefert mir folgendes eine Bestätigung! 
07.
if($mail_ok){ 
08.
   echo '<b>Deine Nachricht wurde versand...</b> <br /><br />'; 
09.
}
Was kann da falsch sein??
Mitglied: Dani
14.03.2009 um 15:49 Uhr
Hi,
hast du versucht, dein funktionierendes Script in diesem anderen Ornder mal auszuprobieren?! Ich glaube zwar nicht, dass der Provider unterscheidet, aber interessant wäre es.
Ansonsten kann ich keinen Fehler sehen.


Grüße,
Dani
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Erkennung und -Abwehr
Innenministerium will bei Cyberangriffen zurückschlagen (5)

Link von magicteddy zum Thema Erkennung und -Abwehr ...

E-Mail
gelöst Plesk 17 - E-Mail zurückgestellt in Warteschlange (7)

Frage von ZeldaFreak zum Thema E-Mail ...

E-Mail
gelöst Mail Spam fremde IP (10)

Frage von BerndP zum Thema E-Mail ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...