Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Mail Domain veraendert

Frage Microsoft Exchange Server

Mitglied: Killroy0815

Killroy0815 (Level 1) - Jetzt verbinden

24.06.2009, aktualisiert 00:13 Uhr, 3419 Aufrufe, 12 Kommentare

Hallo Experten,

ich habe ein Problem mit dem Mailversand mit Exchange, folgende
Systemvoraussetzungen:

SBS 2003 Server, statische IP, Emailempfang und versand direkt
ueber exchange.

Ich habe vor einiger Zeit zum Hautserver einen weiteren Server (Linux)
eingerichtet, der "nur" als Proxy fungieren soll. Dieser ist als Mitglied
in die Domaene eingebunden.

Nun ist mir dieser wohl irgndwie in die Quere gekommen. Seit neuestem
versendet exchange nicht mehr an bestimmte Email Adressen.
Eine Suche in den Log Files ergab das jetzt an der message ID nicht
mehr der zusatz des Hauptservers prangt (*@DC.local) sondern der
name des Proxy servers (
***@Proxy)

Dementsprechend wird mir klar warum die Mails beim empfangenden Server abgelehnt
werden. Gleichzeitig wird vom Connection Manager eine Event ID 4006 geloggt.

Wie bekomme ich die EIntrage des Proxy's wieder aus dem Server ???

thx

Killroy
Mitglied: elmich
24.06.2009 um 09:20 Uhr
Hi,

der Proxy arbeitet deiner Beschreibung nach als Relay. Somit gerneriert er auch beim versenden einer MAil eine neue ID. Wichtig für den erfolgreichen versand ist jedoch die Domain in der Absenderadresse. Die darf durch das Relay nicht verändert werden.

Der ExchangeServer hat da wohl eher wenig mit zu tun. Das Event sagt aus, dass er die Mail an den Empfängerserver nicht loswerden konnte. Sie sollte somit noch in der Queue des Proxys liegen. Wenn das so ist, ist es definitiv ein Problem des Proxys und da wirst Du wohl eher im Bereich Linux & Unix hilfe finden.

Viele Grüße
Elmar
Bitte warten ..
Mitglied: Killroy0815
24.06.2009 um 09:48 Uhr
Hallo, Danke erstmal für die Antwort,
der Proxy sollte eigentlich nicht als Relay arbeiten.
Es zeigt auch keine Einstellung vom DC auf den Proxy,
einzig das der DC weiß das der Proxy ein Mitglied der Domaene ist.

Aber den Tip mit der Unix/Linux Sektion werd ich mal in die Tat umsetzen.


Gruß

Frank
Bitte warten ..
Mitglied: elmich
24.06.2009 um 11:36 Uhr
Interessant!

Sendet der DC direkt per DNS an den Zielserver?

Ist vieleicht der MX Eintrag im DNS geändert worden?

In welchem Logfile hast Du die Änderung festgestellt?

Wenn der Proxy mit dem Mailverkehr nichts am Hut hat, bist Du schon richtig hier, aber es kann ja nicht schaden, noch woanders zu fragen.

Gruß
Elmar
Bitte warten ..
Mitglied: filippg
24.06.2009 um 21:03 Uhr
Hallo,

beschreib doch erstmal was Sache ist. Was ist ein Mail-Proxy? Wie sendest du Mails vom Client an... ja, an wen eigentlich, an den Proxy oder an den Exchange? Werden ausgehende Mails von Exchange über den "Proxy" geroutet oder umgekehrt? Welche Relevanz hat die Domänen-Mitgliedschaft des _Unix_-Rechners?
Die Message-ID ist für den Transport eher unrelevant. Wesentlich ist nur, dass eine vorhanden ist, und diese korrekt aufgebaut (zufallszahl@host, wobei host durchaus "gefällscht" sein darf). Eine Message-ID darf beim relay übrigens _nicht_ geändert werden.

Gruß

Filipp
Bitte warten ..
Mitglied: Killroy0815
24.06.2009 um 23:11 Uhr
Hallo,

Ja, der DC sendet direkt.

Hab ich nicht geprueft, kann ich mir aber kaum vorstellen, das waere doch
ein arger zufall...nichts desto trotz werd ich mir den nochmal anschauen.

EDIT hab geschaut, alles normal EDIT

Im Exchange Server Log


Gruss

Frank
Bitte warten ..
Mitglied: Killroy0815
24.06.2009 um 23:20 Uhr
Hallo,

Der Proxy ist nicht fuer die Mails gedacht der dient nur dem Webverkehr.
Ist auch tatsaechlich nur fuer diesen Port eingerichtet.
Mails werden direkt vom DC per DNS gesendet, sprich com Benutzer ueber den Exchange
Server, die Mail werden nicht ueber den Proxy geroutet !.

Die Relevanz der Domaenen Mitgliedschafft, tja das ist wahrscheinlich die Krux ...
in meinen Augen war das nur "normal" auch diesen Server in die Domaene mit aufzunehmen.
Mittlerweile hab ich Ihn auch wieder runtergenommen, um zu pruefen ob damit das Problem
behoben ist.

Das die Message ID gefaelscht sein darf, ist mir klar gworden, da nicht alle externen Empfaenger
adressen betroffen sind, anscheinend nur diese mit guten Filter und Anti Spam Methoden.

Gruss

Frank
Bitte warten ..
Mitglied: elmich
25.06.2009 um 09:22 Uhr
Hi,

also ist das Probölem jetzt behoben, oder nicht. Das alleinige Aufnehmen des Linux Servers in die Domäne kann so etwas nicht auslösen.

Wenn Du präzisere Hilfe möchtest, dann musst Du jetzt mal dein Gesamtsystem beschreiben und genau sagen was du gemacht hast und was dann passiert ist. Wenn in der ID der Name des Linux Servers vorkommt, sind die Mails eindeutig von diesem System gesendet worden (Wenn wir das Fälschen mal aussen vor lassen).

Welche Mails betrifft die Sache denn? Von wo nach wo gehen die? Ist es immer deselbe Empfänger? usw.

Das andere gute Filter besitzen ist nur gut. Du musst einfach die Regeln einhalten, dann kommen sie auch an.

Gruß
Elmar
Bitte warten ..
Mitglied: Killroy0815
25.06.2009 um 09:36 Uhr
Hallo,

nein das Problem ist noch nicht geloest, den Linux Server wieder von der Domaene zu schmeissen war ein erster Ansatz meinerseits.


Das System besteht aus einem DC (Windows SBS 2003 mit Exchange Server) und einem Linux Server.( 2 seperate systeme)

Der Linux Server wurde nachtraeglich angeschafft um den Webverkehr zu verbessern, sonst nichts. Zu diesem Zweck habe ich Ubuntu 8.04 und squid Proxy Server installiert.

Bis dato war der Proxy nur in der Arbeitsgruppe aufgenommen, und ich dachte es waere nur gut den Proxy auch in die Domaene mit aufzunehmen. Bis zu diesem moment war auch noch alles gut,
Nach einiger Zeit stellte ich fest das ich keine Mails mehr an meine eigene private Mail adresse schicken konnte. Weder von meinem Clientcomputer als von allen anderen. Dies betrifft auch einige andere Mailadressen, aber ohne das ich darin ein system sehen koennte ..(nur .org oder nur .com). Es betrifft immer die komplette Mail domaib beim Empfaenger.

Also nochmal Proxy (nur Webverkehr) und DC beides sind seperate Computer in einem Netzwerk. Der DC routet NICHT ueber den Proxyserver, sondern hat eine direkte Internetverbindung.

Das die anderen gute Filter haben ist tatsaechlich gut ... sonst waere es ja nichtmal aufgefallen

Ich hoffe ich konnte mehr Erleuchtung bringen

Gruss

Frank
Bitte warten ..
Mitglied: elmich
25.06.2009 um 10:53 Uhr
Hi,

Ok, noch einmal zurück zu den von Dir erwähnten Logfiles. Welches Logfile ist es. Wo liegt es. Kannst Du mal einen betreffenden Eintrag des Logfiles posten?

In der regel sagt ein empfangender Mailserver, was ihm nicht passt.

Gruß
Elmar
Bitte warten ..
Mitglied: Killroy0815
25.06.2009 um 12:05 Uhr
Hallo,


  1. Message Tracking Log File
  2. Exchange System Attendant Version 6.5.7638.1
  3. Date Time client-ip Client-hostname Partner-Name Server-hostname server-IP Recipient-Address Event-ID MSGID Priority Recipient-Report-Status total-bytes Number-Recipients Origination-Time Encryption service-Version Linked-MSGID Message-Subject Sender-Address
1020 DC86CA740F916A4AAFC49A4865F36EA51D3F5B@DCP-Proxy 0 0 111036 1 2009-6-22 19:20:45 GMT 0 - - - Frank.Jurczyk@maildomain -
2009-6-22 23:16:43 GMT - - - Name DC - frank@jurczyk.org 1031

Dies ist der LOG Auszug,
Ich bin auch immer davon augegangen das der empfangende Mailserver sagt warum nicht, aber in diesem Fall kann ich nichts finden bzw nur "A SMTP Error occured"

wie man am Log auszug sieht steht hinter der Msg id der Name des Proxy Servers, dort stand sonst der name des DC.

Gruss

Frank
Bitte warten ..
Mitglied: elmich
25.06.2009 um 12:39 Uhr
Hi,

das Message Tracking ist dazu nicht ausagekräftig genug. Versuch bitte mal die Protokollierung des Virtuellen SMTP Standarsserver zu aktivieren. Dort W3C-Erweitert auswählen und unter Einstellungen und Erweitert min. die Felder für den Protokollstatus aktivieren. Ein paar weitere wären auch interessant.

Nach einer angemessenen Wartezeit (5 Min.) mal eine Mail senden, die nicht ankommt und die Einträge im Protokoll untersuchen.

Gruß
Elmar

Edit: Das Feld cs-uri-query ist wichtig, da dort die Antwort vom SMTP Serevr steht.
Bitte warten ..
Mitglied: Killroy0815
25.06.2009 um 20:31 Uhr
Danke fuer den Tip werd ich mir gleich mal anschauen !!

So hab mir das Log angeschaut, und es stellte sich
sich heraus das ich von der RBL Sorbs geblockt werde.

...ich weiss jetzt zwar nicht ob die veraenderte Msg ID der
Ausloeser war ..... laut Sorbs nicht.

Ich hatte mir das Log vorher schon angeschaut, war aber nicht
ueber den Eitrag gestolpert.

Damit weiss ich das ich wieder erst mit meinem Provider
sprechen muss

Vielen Dank fuer Deine Muehe !!!

Gruss

Frank

*EDIT*

Hab mich jetzt mal durch die Problematik geaebeitet,

und bin auf Reverse DNS Check gestossen.
Unsere statische IP loest auf einen Hostnamen auf der nicht unsere
Maildomain entspricht.

Waere es eine Loesung im Virtuellen Standard Server als qualifizierte
Domaene diese anzugeben (Die von unsere IP aufgeloest wird) anstatt unserer Mail Domaene ???
Der Hostname der von der IP aufglesoest wird ist von unserem Provider, und ich denke nicht das der
diese anpassen wird.

Gruss

Frank
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange: Mail abfangen und verändert umleiten
gelöst Frage von KoschieExchange Server2 Kommentare

Hallo Admins, unsere neue Telefonanlage hat ein Mail2Fax-Feature. Dieses funktioniert wie folgt: Der Benutzer schickt eine E-Mail mit Anhang ...

Verschlüsselung & Zertifikate
TLS Verschlüsselung Mail-Domains
gelöst Frage von Raptor-XVerschlüsselung & Zertifikate1 Kommentar

Hallo Zusammen, folgende Mail Konstellation bei uns. Wir haben eine Mail Domain "mail.firma-gmbh.com" registriert bei der Telekom als MX-record. ...

Exchange Server
Senden mit Domain eines anderen Mail-Servers
Frage von JimPietExchange Server2 Kommentare

Moin, die User, die wir über Exchange 2010 mit Emails versorgen haben alle das Format "name@abteilung.domain.de". Es gibt aber ...

Internet Domänen
Mail Domain umzug
gelöst Frage von Basti09Internet Domänen8 Kommentare

Hallo zusammen, ich bin neu hier und habe leider nicht allzuviel Ahnung von Email Servern und Homepages. Vorweg meine ...

Neue Wissensbeiträge
Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 6 StundenInternet3 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registierunf von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 13 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 1 TagWindows 103 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 1 TagSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless17 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement16 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...