Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Makro löscht Formeln und ersetzt sie durch Berechnungs-Werte (darf aber nicht sein)

Frage Microsoft Microsoft Office

Mitglied: Unitet20

Unitet20 (Level 1) - Jetzt verbinden

27.12.2007, aktualisiert 01.02.2008, 4068 Aufrufe, 5 Kommentare

Guten Morgen liebe Kollegen! ;)

Ich stehe mal wieder vor einem Problem ganz merkwürdiger Natur...

Vorgeschichte:
Ein Mitarbeiter von uns hat ein Makro in einem Excel Dokument.
Das Makro sorgt dafür das bei den Tastenkombinationen STRG + C und STRG + V IMMER nur der Wert eines Feldes kopiert wird... niemals aber die Formel. Das funkrioniert soweit auch und JAHRE lang funktionierte das Makro in der Excel Datei ohne Probleme. Nun allerdings´ist ein Problem aufgetaucht.

Das Problem:
Seit der Kollege einen neuen Rechner hat, passiert folgendes:
Wenn eine Formel in dem Dokument einen Wert berechnet, wird die Formel durch den Wert überschrieben und ist somit weg. Ich kann mir das nicht erklären.
Der Mitarbeiter hat nichts an seinem Makro geändert.
Office habe ich auch schon 1x bei dem Mitarbeiter neuinstalliert.
Bei allen anderen Rechnern auf denen wir das gleiche Dokument gestet haben, ging das Makro allerdings normal.

Hat Jemand von euch auch nur eine Idee wodran das ganze liegen könnte?
Wäre echt super.
Schonmal vielen Dank im vorraus

Uni
Mitglied: miniversum
27.12.2007 um 10:39 Uhr
Füge mal einen Haltepunkt am anfang des Makros ein damit man dann genau verfolgen kann was pasiert. Vielleicht ist so das Problem dann schnell gefunden.
Benutzt der Mitarbeiten jetzt eine andere Office Version?
Bitte warten ..
Mitglied: Unitet20
27.12.2007 um 12:26 Uhr
Hmm wie mache ich das mit dem Haltepunkt?
Ich bin nun nicht so der VB experte

Nein, alles ist exakt gleich wie bei seinem alten Rechner.
Bis auf die Hardware.
Bitte warten ..
Mitglied: miniversum
27.12.2007 um 12:39 Uhr
Öffne das Fenster mit dem makro im vba-Editor und klicke mit der maus rechts vor der programmzeile andem es anhalten soll an den grauen rand. alternativ öber das menü. Dort gibt es den punkt "Haltepunkt einfügen"
wen du dann das makro ausführst bleibt es an dieser stelle stehen und kann schrittweise durchlaufen werden.
Bitte warten ..
Mitglied: Unitet20
27.12.2007 um 13:04 Uhr
Alles klar, vielen dank!
Werde ich nachher / spätestens morgen mal ausprobieren!
Dann werde ich die Ergebnisse der Untersuchung, inklusive dem Makro hier mal posten.
Bitte warten ..
Mitglied: Unitet20
01.02.2008 um 12:39 Uhr
Sorry das ich mich so lange nicht gemeldet habe.
Ein Kollege hat das Problem gefunden und behoben.
Es war eine .dll datei die durch eine ältere ersetzt wurde...

nun funktioniert es wieder.
Leider weiß der Kollege den namen der .dll Datei nicht mehr,
aber vielleicht hilft es Jemanden anders ein bisschen den richtigen Weg zu finden,
falls er das gleiche Problem hat.

Gruß
Uni
Bitte warten ..
Ähnliche Inhalte
Outlook & Mail
Outlook 2016 löscht Text aus E-Mail beim senden (4)

Frage von Peacer zum Thema Outlook & Mail ...

Windows Server
SQL Server löscht Daten von sich selbst aus ?! (20)

Frage von KevBarz zum Thema Windows Server ...

Datenbanken
gelöst MYSQL Abfrage Werte summieren (3)

Frage von Ghost108 zum Thema Datenbanken ...

Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(6)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(5)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Batch & Shell
gelöst Batch um Benutzer aus Sitzung abzumelden (15)

Frage von zeroblue2005 zum Thema Batch & Shell ...

LAN, WAN, Wireless
IP Sec Client legt Netzwerkkarte lahm (12)

Frage von mario87 zum Thema LAN, WAN, Wireless ...