Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

(manche) Xp-Clients führen plötzlich nt4-Domänen-Loginscript nicht mehr automatisch beim Userlogin aus

Frage Microsoft Windows Server

Mitglied: pete.dawgg

pete.dawgg (Level 1) - Jetzt verbinden

16.02.2010 um 15:43 Uhr, 3682 Aufrufe, 3 Kommentare

Wir verwenden eine nt4-Domäne mit 1 PDC und 3 BDCs. Fast alle Clients sind XP; ein paar 2K sind noch dabei. Allen Usern ist ein Loginskript zugeordnet. Vor ein paar Tagen habe ich ein paar Zeilen am Loginskript geändert (nichts gravierendes), seitdem führen es manche xp-Clients nicht mehr automatisch beim Login des jeweiligen Users aus. (Vorher ging es monate-/jahrelang problemlos.)

Der User kann sich problemlos anmelden und danach das Loginskript feherfrei von Hand vom PDC oder einem der BDCs ausführen.
Die Skripte sind in allen Netlogon-Shares identisch, die Rechte stimmen (sonst ginge es ja auch nicht "von Hand").
Es scheinen nur Clients in Standorten mit langsamer Netzanbindung betroffen zu sein; es scheinen nur solche zu sein, die das Loginskript vom PDC ausführen (%logonserver%=PDC).
Den betroffenen Rechner aus der Domäne zu entfernen und wieder aufzunehmen hat nichts geändert (Userkennung neu ist nicht nicht machbar), es sind alle User betroffen, die sich am entsprechenden Client anmelden.

Beim Bearbeiten des Skriptes auf dem PDC gab es ein paar komische Phänomene (Datei liess sich nicht speichern usw.), so dass dieser bereits neu gestartet ist.

Was könnte das Problem sein? Das Loginskript muss laufen und der Workaround, es den Usern in den Autostart zu stecken ist auf Dauer nicht vertretbar.

Vielen Dank fur Eure Hilfe.
Mitglied: DerWoWusste
16.02.2010 um 21:58 Uhr
Moin.
Teste aus, ob es einen Unterschied macht, die GPO "immer auf das Netzwerk warten" (-> Google) einzuschalten.
Bitte warten ..
Mitglied: pete.dawgg
22.02.2010 um 10:32 Uhr
Vielen Dank für die Antwort!
Leider bin ich noch nicht dazu gekommen, es so auszuprobieren, da es sich - wie gesagt - um entfernte Standorte handelt und ich die Admin nicht lokal delegieren kann. RDP ist hier verboten und per telnet als Notnagel lässt sich die Policy ja leider auch nicht bearbeiten.

Ich habe an einem Testrechner mal gekuckt; handelt es sich um dieses Objekt: Richtlinien f lokaler Computer -> Computerkonfiguration -> administrative Vorlagen -> System -> Anmeldung -> ... "Bei Neustart/Anm,eldung immer auf das Netzwerk warten" ist standardmässig nicht konfiguriert. Das hat bis jetzt auch nie zu Problemen geführt.
Ist es in einer "klassischen" NT-Domäne überhaupt möglich, das ohne zu grosse Verrenkungen systemweit vorzugeben? Zu jedem einzelnen Client zu laufen wäre keine praktikable Lösung.
Bitte warten ..
Mitglied: DerWoWusste
22.02.2010 um 11:14 Uhr
Du kannst den zugehörigen Registrywert per Domänenstartskript setzen lassen (nicht Loginskript, sondern Startskript).
http://www.kellys-korner-xp.com/regs_edits/enablesync.reg
Das Ding verteilen.
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(3)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (41)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Off Topic
gelöst Fachzeitschriften als E-Book oder hardcoded? (11)

Frage von KowaKowalski zum Thema Off Topic ...

Windows 10
Windows Store Apps ohne Windows Store installieren (10)

Frage von keefien zum Thema Windows 10 ...