Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kein Markieren in INPUT und TEXTAREA möglich

Frage Entwicklung Webentwicklung

Mitglied: Martinkoell

Martinkoell (Level 1) - Jetzt verbinden

07.04.2011 um 11:35 Uhr, 4196 Aufrufe, 13 Kommentare

Kann in keinem INPUT oder TEXTAREA-Feld auf meiner Homepage den Text mit der Maus markieren.

Hi Community!

Wenn ich mit der Maus reinklicke, dann ist der Cursos drin und zwar ganz am Ende.
Mit den Pfeiltasten der Tastatur kann ich dann links und rechts Buchstabenweise den Cursor bewegen.
In einem TEXTAREA bewirken die Pfeiltasten oben/unten einen Sprung zum Anfang und zum Ende des Feldes.
Bearbeiten der Zwischenzeilen nicht mehr möglich.
Markieren mit der Maus ist auch nicht möglich!! ((
Nicht mal mit der Maus in den Text rein klicken geht.
Der Cursor landet immer am Ende

HILLFE
Mitglied: Heru
07.04.2011 um 14:30 Uhr
Hi,

tritt der Fehler nur an einem PC auf oder sind auch andere betroffen ?
Hast du evtl Code von anderen Websiten/aus Foren/aehnlichem herauskopiert ?

mfg
Bitte warten ..
Mitglied: Martinkoell
07.04.2011 um 15:17 Uhr
ja, fehler ist auf allen betriebssystemen. (firefox)
nein, hab keine codes geklaut.
die quellcodes sind nur mittlerweile so umfangreich, dass ich keine ahnung habe wonach ich suchen soll.

Ondragstart hab ich schon gesucht, gibts nirgends..

Ich hab alles mit DOM-Manipulation verschachtelt, aber das keine Fehlerquelle sein..
Sollte..
lg
Bitte warten ..
Mitglied: Heru
07.04.2011 um 16:13 Uhr
Zitat von Martinkoell:
ja, fehler ist auf allen betriebssystemen. (firefox)

nun, das koenntest du noch versuchen. (iexplore, opera, safari)
andernfalls kann ich dir so ins blaue hinein keinen hinweis geben. da waere evtl etwas quellcode praktisch
Bitte warten ..
Mitglied: Arano
07.04.2011 um 16:14 Uhr
Guten Tag,

magst du uns einen Link zu deiner Seite Posten damit wir uns dann den umfangreichen Quelltext ansehen können !?

~Arano
Bitte warten ..
Mitglied: Martinkoell
07.04.2011 um 16:20 Uhr
is leider im intranet und wie gesagt, der quellcode erstreckt sich auf mehrere hundert MB.

hab gedacht das wär ein bekanntes problem..
Bitte warten ..
Mitglied: Heru
07.04.2011 um 16:38 Uhr
hast du es denn mit em internetexplorer versucht ?
Bitte warten ..
Mitglied: Martinkoell
07.04.2011 um 16:42 Uhr
genau :D

den hab ich mit $_SERVER kategorisch rausgeschmissen mit der freundlichen Fehlermeldung
"Diese Seite unterstützt nur standardisierte Browser" :DDD

Also Safari, Mozilla, sogar Chrome gehen.
Aber Fehler überall gleich
Bitte warten ..
Mitglied: Arano
07.04.2011 um 16:46 Uhr
Aber die Felder sind nicht als "readonly" oder "disabled" markiert !?
Bitte warten ..
Mitglied: Martinkoell
07.04.2011 um 16:52 Uhr
nein, das ist eben das witzige dran..
ich kann mit der maus reinklicken und sie bearbeiten.
nach einem mausklick erscheint der cursor aber nur am ende des bereits eingegebenen textes..
(ausser wenn das feld leer is, dann ist der cursor am anfang)
markieren mit der maus geht gleich wenig, wie gezielt zwischen zwei buchstaben oder zum anfang klicken..
Bitte warten ..
Mitglied: Martinkoell
07.04.2011 um 16:55 Uhr
ich werd mir jetzt mal das dom ansehen, vieleicht liegt ein layer darüber und ein click event leitet sie falsch durch die layers..
Bitte warten ..
Mitglied: bnutzinger
07.04.2011 um 16:55 Uhr
Zitat von Martinkoell:
is leider im intranet und wie gesagt, der quellcode erstreckt sich auf mehrere hundert MB.


Holla da war aber jemand Fleissig.
Hast du da ein Betriebssystem in HTML geschrieben, oder was?

Grüße
Bastian
Bitte warten ..
Mitglied: Martinkoell
07.04.2011 um 17:18 Uhr
jo :D

aber nicht in HTML sondern in PHP

:D lg
Bitte warten ..
Mitglied: Heru
08.04.2011 um 13:19 Uhr
haste was gefunden im DOM ?
haben die inputs und textareas irgend ne class oder sonstwas, wovon die vllt etwas erben koennten ?
Bitte warten ..
Ähnliche Inhalte
CMS
gelöst Kein Bilderupload unter Wordpress möglich (3)

Frage von achklein zum Thema CMS ...

Exchange Server
SBS 2011 Exchange Multidomain kein senden über Outlook möglich (1)

Frage von pla112 zum Thema Exchange Server ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Systemdateien
NTFS und die Defragmentierung (26)

Frage von WinLiCLI zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
Zwei Subnetze mit je eigenem Router und Internetzugang verbinden (18)

Frage von hannsgmaulwurf zum Thema LAN, WAN, Wireless ...

Windows Server
WIndows Server 2016 core auf dem Intel NUC NUC5i5RYK i5 5250U (17)

Frage von IxxZett zum Thema Windows Server ...