Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

MediaWiki installieren ... Keine Fehler aber doch Fehler?!

Frage Internet Server

Mitglied: MagicJojo

MagicJojo (Level 1) - Jetzt verbinden

22.12.2008, aktualisiert 12:02 Uhr, 6884 Aufrufe, 3 Kommentare

Hallo,

ich betreibe einen Debian Etch Server, auf dem alle aktuellen Updates zu Apache etc. eingespielt sind. Nun will ich mir ein MediaWiki installieren - doch leider klappt das noch nicht so ganz. Nachdem ich es hochgeladen, das Setup ausgeführt und alle Daten eingetragen habe (sicherlich die richtigen!), klicke ich auf den Submitbutton und es wird die Installation eingeleitet, in der ich so weit komme:


          • PHP 5.xxxxxxxx installed
          • Found database drivers for: MySQL
          • PHP server API is apache2handler; ok, using pretty URLs (index.php/Page_Title)
          • Have XML / Latin1-UTF-8 conversion support.
          • Session save path (/var/lib/php5) appears to be valid.
          • PHP's memory_limit is 16M. Attempting to raise limit to 20M... ok.
          • Couldn't find Turck MMCache, eAccelerator, APC or XCache; cannot use these for object caching.
          • Found GNU diff3: /usr/bin/diff3.
          • Found GD graphics library built-in, image thumbnailing will be enabled if you enable uploads.
          • Installation directory: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
          • Script URI path: /wiki
          • Installing MediaWiki with php file extensions
          • Environment checked. You can install MediaWiki.
          • Generating configuration file...
          • Database type: MySQL
          • Loading class: DatabaseMysql
          • Attempting to connect to database server as desart...success.
          • Connected to xxxxxxxxxxxxxxxxx-log; enabling MySQL 4.1/5.0 charset mode
          • Database desart_wiki exists
          • Creating tables...Query "CREATE TABLE `wiki_searchindex` ( si_page int unsigned NOT NULL, si_title varchar(255) NOT NULL default '', si_text mediumtext NOT NULL, UNIQUE KEY (si_page), FULLTEXT si_title (si_title), FULLTEXT si_text (si_text) ) ENGINE=MyISAM " failed with error code "Column 'si_title' cannot be part of FULLTEXT index (localhost)".


Beim Klick auf F5 für aktualisieren tut sich auf einmal mehr:


          • PHP xxxxxxxxxxxxx installed
          • Found database drivers for: MySQL
          • PHP server API is apache2handler; ok, using pretty URLs (index.php/Page_Title)
          • Have XML / Latin1-UTF-8 conversion support.
          • Session save path (/var/lib/php5) appears to be valid.
          • PHP's memory_limit is 16M. Attempting to raise limit to 20M... ok.
          • Couldn't find Turck MMCache, eAccelerator, APC or XCache; cannot use these for object caching.
          • Found GNU diff3: /usr/bin/diff3.
          • Found GD graphics library built-in, image thumbnailing will be enabled if you enable uploads.
          • Installation directory: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
          • Script URI path: /wiki
          • Installing MediaWiki with php file extensions
          • Environment checked. You can install MediaWiki.
          • Generating configuration file...
          • Database type: MySQL
          • Loading class: DatabaseMysql
          • Attempting to connect to database server as desart...success.
          • Connected to xxxxxxxxxxxxxxxxxx-log; enabling MySQL 4.1/5.0 charset mode
          • Database desart_wiki exists
          • There are already MediaWiki tables in this database. Checking if updates are needed...

...have ipb_id field in ipblocks table.
...have ipb_expiry field in ipblocks table.
Creating interwiki table: ok
Adding default interwiki definitions: ok
...indexes seem up to 20031107 standards
...hitcounter table already exists.
...have rc_type field in recentchanges table.
...have user_real_name field in user table.
Creating querycache table...ok
Creating objectcache table...ok
...categorylinks table already exists.
Already have pagelinks; skipping old links table updates.
...have rc_ip field in recentchanges table.
...image primary key already set.
...have rc_id field in recentchanges table.
...have rc_patrolled field in recentchanges table.
Creating logging table...Query "ALTER TABLE recentchanges
MODIFY rc_namespace tinyint(3) NOT NULL default '0'
" failed with error code "Table 'desart_wiki.recentchanges' doesn't exist (localhost)".


Und wenn ich wieder aktualisiere, dann kommt er noch weiter und zeigt auf einmal an, dass die Installation erfolgreich gewesen sei. Aber es wird vieles nicht erstellt, unter anderem nicht der Benutzer "WikiSysOp". Also kann ich die Installation komplett vergessen. Auch bei nachträglichem Anlegen des Benutzers lassen sich somanche Funktionen nicht verwenden (und es wird ja nicht nur nicht der User erstellt).

Kann mir wer helfen, an was es liegen könnte? Wäre sehr dankbar dafür.

Grüße
Johannes
Mitglied: priez
23.12.2008 um 13:39 Uhr
Hi,

Hast du evtl. die falsche MySQL Version?

mfg

René
Bitte warten ..
Mitglied: MagicJojo
23.12.2008 um 13:49 Uhr
Ne, vorrausgesetzt ist 4.*schlagmichtot* und ich habe 5.x. PHP ist auch vorrausgesetzt 5.x, welches ich installiert habe.
Bitte warten ..
Mitglied: priez
23.12.2008 um 13:56 Uhr
Hi,

ich habe mal nach "error code "Column 'si_title' cannot be part of FULLTEXT index" gegoogelt. Raus kam folgender Hinweis der mediawiki database:

"In some common configurations of MySQL 4.1 and later, mysqldump can corrupt MediaWiki's stored text. If your database's character set is set to "latin1" rather than "UTF-8", mysqldump in 4.1+ will apply a character set conversion step which can corrupt text containing non-English characters as well as punctuation like "smart quotes" and long dashes used in English text."

gefunden auf: http://www.mediawiki.org/wiki/Project:Support_desk/Archives/Database/00 ...

Du solltest dir den entsprechenden Abschnitt mal durchlesen und schauen ob da etwas auf dich zutrifft.

Viel Glück

René
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
SQL Fehler Beim Installieren von SQL 2008 R2 auf einem Windows 2012 Server (6)

Frage von Sv-Schneider zum Thema Windows Server ...

Router & Routing
Welche pfsense Version für Dual-Wan Router mit APU2C4 installieren (5)

Frage von Roland30 zum Thema Router & Routing ...

Windows Server
gelöst BackupExec 2016 Fehler beim Backup von Windows 2016 (1)

Frage von Looser27 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...

Peripheriegeräte
Wlan stört Funkmaus (11)

Frage von Falaffel zum Thema Peripheriegeräte ...

Windows Server
RODC über VPN - Verbindung weg (10)

Frage von stefan2k1 zum Thema Windows Server ...