Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Mehrer VLANs ein Server - Wie?

Frage Netzwerke

Mitglied: Karakan87

Karakan87 (Level 1) - Jetzt verbinden

20.05.2009, aktualisiert 18.10.2012, 9280 Aufrufe, 11 Kommentare, 2 Danke

Hallo @ all. Wollte noch ein bisschen mit Switches und Routern üben und stehe nun vor einem Problem.

Das Bild ist denk ich mal selbsterklärend.

Habe mehrer VLANs mit 2 Switches und Trunking. Möchte aber das alles verschiedenen Abteilungen auf einen Server zugreifen und hab leider keine gute Idee wie?

Vielleicht kann mir ja jemand ein paar Tipps geben!

83154d18540b92952e9fce41eaaabb93-testumgebung - Klicke auf das Bild, um es zu vergrößern
Mitglied: MASTEQ
20.05.2009 um 11:53 Uhr
Hallo Karakan87,

die Möglichkeit noch einen 3 Switch an die Spitze zu "Bauen" hast du nicht? Kennst du dich mit dem IP Routing aus? Wird kompliziert befürchte ich....aber du könntest den Server auch an einem der beiden Switche anschließen und den anderen Switch per IP Routing auf den Port von dem anderen zu lenken. - Ich würde jedoch bevorzugen einen weiteren Switch einzusetzen....wenn verfügbar, da einfacher!

Gruß

MASTEQ
Bitte warten ..
Mitglied: aqui
20.05.2009, aktualisiert 18.10.2012
Die Lösung ist viel einfacher und banaler...

Dieses Tutorial beschreibt dir genau wie es geht:

http://www.administrator.de/wissen/vlan-routing-%c3%bcber-802.1q-trunk- ...

Damit ist die Umsetzung kinderleicht im Handumdrehen gemacht !!
Bitte warten ..
Mitglied: chips1
20.05.2009 um 14:58 Uhr
Einfach den Port, an dem der Server hängt in beide V-Lans setzen oder irre ich mich da?

Gruss Chips
Bitte warten ..
Mitglied: dog
21.05.2009 um 02:17 Uhr
Und wenn der Server ein DC ist bitte auch noch

http://www.administrator.de/Probleme_mit_Multihomed_DCs_vermeiden.html

beachten.
Windows hat nämlich so seine Probleme DC in mehreren Subnets zu sein, wenn diese nicht gegeneinander geroutet sind.

Grüße

Max
Bitte warten ..
Mitglied: aqui
21.05.2009 um 11:35 Uhr
Nein, da irrst du dich nicht aber genau DAS beschreibt ja das o.a. Tutorial... oder etwa nicht ???!!
Bitte warten ..
Mitglied: chips1
21.05.2009 um 19:45 Uhr
Sorry jetzt kapier ich es erst:
Was hat denn der Server in dem Fall für Adressen?
Wofür hast Du V-Lans wenn Du die Zugriffsunterschiede IP-Mässig trennst?
Irgendwo ist da ein Denkfehler, von mir weil ich das Problem noch nicht ganz kapiert habe oder von Dir, weil Du eigentlich keines hast. Muss noch mal drüber nachdenken, ich meld mich spät. morgen früh noch mal.

Gruss
Bitte warten ..
Mitglied: aqui
21.05.2009, aktualisiert 18.10.2012
@chips1
Sein Problem ist doch ganz logisch und auch sauber oben beschrieben !
Er hat mehrere VLANs mit unterschiedlichen IP Segmenten pro VLAN wie es in segmentierten Netzen gemeinhin üblich ist !
Sein Problem ist aber nun das er keinen Layer 3 (Routing) Switch hat und zwischen den VLANs nicht routen kann.
Ein externer Router ist leider auch nicht vorhanden.

Wenn du jetzt den Server in VLAN 10 im Einkauf plazierst, können logischerweise die Kollegen vom Verkauf und Verarbeitung (VLAN 20 und 30) logischerweise nicht auf den Server arbeiten, da die VLANs, wie jeder Netzwerker weiss, untereinander vollkommen separiert sind !
Genau das will Karakan87 aber erreichen das alle (VLANs) auf dem Server arbeiten können.

Folglich nimmt er sich dann das Tutorial zur Hand....
http://www.administrator.de/wissen/vlan-routing-%c3%bcber-802.1q-trunk- ...
....generiert einen tagged Link für alle VLANs am Switch und hängt den Server gemäß Tutorial konfiguriert ebenfalls tagged mit einem 802.1q Link an diesen Port vom Switch.

Der Server hat dann 3 virtuelle IP Interfaces für jedes VLAN eines und ist somit für alle Kollegen in den VLANs erreichbar !
Wenn er will kann er sogar noch das Routing aktivieren auf dem Server und kann dann routen zwischen den VLANs.
Z.B. Damit die Kollegen aus dem Einkauf mal auf dem dicken Laserdrucker vom Verkauf drucken können oder alle den schönen Farbplotter von der Verarbeitung nutzen können !!
So einfach ist das und reicht hoffentlich für deinen Durchblick jetzt ???
Bitte warten ..
Mitglied: chips1
21.05.2009 um 21:10 Uhr
Ja jetzt steig ich durch, ich habe nur in meinem ersten Komment die unterschiedlichen IP übersehen, also hat er doch IP-Trennung und V-Lan trennung also fehlt mir genau der Zusammen hang mit den verschiedenen Ip (virtuell oder mit eigenen Karten ist auch schon Wurscht oder) Adressen.
Und Stimmt, das Tutorial hört sich absolut richtig an, da würde ich auf einen Test verzichten.

Gruss
Bitte warten ..
Mitglied: aqui
21.05.2009 um 21:32 Uhr
Das ist ein gängiges Szenario und damit Karakan87 nun auch keine Angst haben muss liefert administrator.de ihm alles frei Haus....

Sein Netzwerk, wenn er alles richtig zusammenbaut, sieht dann so aus:

668aacb33173d4a9fd31cca902f8d736-vlan_allg5 - Klicke auf das Bild, um es zu vergrößern

Da er 2 Cisco Catalyst 2960 einsetzt ist auch die Switchkonfig ein Kinderspiel:

Switch 1

2960_1#

clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
description Tagged Link zu Switch Cisco 2960_2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface FastEthernet0/10
description Enduser Port in VLAN 10 (Einkauf)
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/11
description Enduser Port in VLAN 20 (Verkauf)
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/12
description Enduser Port in VLAN 30 (Verarbeitung)
switchport access vlan 20
spanning-tree portfast
!
end

Switch 2 (i.d. Zeichnung unten)

2960_2#

clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
description Tagged Link zu Switch Cisco 2960_1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface FastEthernet0/1
description Tagged Link zum Server 0 (Server PT)
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface FastEthernet0/10
description Enduser Port in VLAN 10 (Einkauf)
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/11
description Enduser Port in VLAN 20 (Verkauf)
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet0/12
description Enduser Port in VLAN 30 (Verarbeitung)
switchport access vlan 20
spanning-tree portfast
!
end


Die Server Netzwerkkarte dann entsprechend dem Tutorial customizen und fertig ist das Netzwerk !!
Die Netzwerk Dummie Lösung für Laien gibts natürlich auch: dann steckt er 3 Netzwerkkarten in den Server und hängt die in jedes VLAN.
Der Trunk Port auf FA =/2 auf dem unteren Switch 2 kann dann natürlich entfallen....
Ein Feedback wär mal interessant. Hoffentlich reichts beim Karakan87 noch dazu... ??!!
Bitte warten ..
Mitglied: Karakan87
21.05.2009 um 22:11 Uhr
WOW!

Bin wirklich jedes mal beeindruckt von dem Forum, wie hilfsbereit alle sind.

Werd das was aqui beschrieben hat mal am Montag in die Tat umsetzen und berichten ob alles geklappt hat.

Vielen Dank euch allen!!!
Bitte warten ..
Mitglied: Karakan87
25.05.2009 um 08:28 Uhr
Habs gerade nach der Beschreibung von aqui gemacht, hätte nicht gedacht, dass die Lösung so einfach ist.

Vielen dank euch allen, besonders aqui!
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
VLAN mit pfSense Routing: Server als Mitglied in mehreren VLANs
Frage von RuuderLAN, WAN, Wireless1 Kommentar

Hallo Profis, ich möchte einen Server (PXE Boot Umgebung Client / Server) als Mitglied in mehreren VLANs einrichten. Am ...

LAN, WAN, Wireless
Virtuelle Server in mehrere VLANs hinzufügen
gelöst Frage von LordXearoLAN, WAN, Wireless8 Kommentare

Hallo Zusammen, wir haben hier eine Netzwerkstruktur über einige Switche, welche wir nun mit VLANs unterteilen wollen. (Ohne den ...

Vmware
VLAN über mehrere Host
gelöst Frage von joergVmware4 Kommentare

Hallo zusammen, ich habe zur Zeit 4 VMware Host Standard 6.0U1 im Einsatz. Auf jedem Host habe ich das ...

Netzwerkgrundlagen
Mehrere VLANs und ein NAS
gelöst Frage von pallingerNetzwerkgrundlagen12 Kommentare

Hallo zusammen, ich beschäftige mich seit ein paar Tagen mit VLANs und habe hier noch eine Frage. Zur einfacheren ...

Neue Wissensbeiträge
Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 StundeWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 2 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 13 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 20 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement17 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...