Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Mehrere DSL Leitungen in VLan Netzen verwenden

Frage Netzwerke

Mitglied: Coachi81

Coachi81 (Level 1) - Jetzt verbinden

12.03.2011 um 16:49 Uhr, 4774 Aufrufe, 10 Kommentare, 1 Danke

Hallo,

ich haben ein LAN mit 3 Netzen (Vlans mit Cisco 3750)

Netz A 192.168.100.0
Netz B 192.168.101.0
Netz C 192.168.102.0

Gateway für den Netzübergang Netz A 192.168.100.254
Gateway für den Netzübergang Netz B 192.168.101.254
Gateway für den Netzübergang Netz C 192.168.102.254


Das an sich funktioniert auch soweit aber mein Problem ist das jedes Netz den Zugang zum Inet über eine eigene DSL Leitung und Router haben soll.

DSL Router Netz A 192.168.100.1
DSL Router Netz B 192.168.101.1
DSL Router Netz C 192.168.102.1

Bei den DSL Routern habe ich keine Möglichkeit Standard Gateways oder Routen einzutragen!!!

Bei den Clients muss das Standard Gateway also 192.168.xxx. 254 sein sonst kann ich die anderen Netze nicht erreichen. Wie schaffe ich es nun das
trotzdem jeder Client seinen "eigenen" Router fürs Inet benutzt und trotzdem alle Netze erreichen kann? Oder ist das mit meinen Routern unmöglich? Ich denke mal
der Knackpunkt ist das man auf den DSL Routern kein Gateway oder Route eintragen kann oder seht ihr ne Möglichkeit???

mfg
Mitglied: StefanKittel
12.03.2011 um 19:35 Uhr
Hallo,

es geht, wenn Du die statischen Routen in allen PCs einträgst. Mittels Loginscript gar nicht so aufwendig, würde ich aber trotzdem nicht machen.

Bei so einem "komplexem" Netzwerk würde ich dringend empfehlen Router zu verwenden die sowohl Routen als auch VLANs können.
Das sollte doch drin sein.

Welche Geräte habt Ihr aktuell?

Stefan
Bitte warten ..
Mitglied: aqui
12.03.2011 um 22:00 Uhr
@Stefan
Hat er doch geschrieben.... Er hat einen Catalyst 3550. Der kann VLANs und routen, denn er ist ein L3 Switch.

@Goose81
Unter den gegebenen Umständen das keine statischen Routen auf den DSL Routern konfiguriert werden können hast du genau 2 Optionen:

1.) Du trägst in den VLANs bei allen Clients immer den jeweiligen DSL Router mit der .1 als Default Gateway ein.
Dann fügst du bei jedem Client eine statische permanente Route hinzu. Bei einem Windows Client im 192.168.100.0 /24 er Netz z.B.:
route add 192.168.101.0 mask 255.255.255.0 192.168.100.254 -p und
route add 192.168.102.0 mask 255.255.255.0 192.168.100.254 -p
Analog bei allen anderen Clients in den anderen Subnetzen.
Nachteil: Erheblicher manueller Aufwand und wenn Clients umziehen immerwährende manuelle Anpassungen. Bei Clients wie Drucker, NAS usw. die keine zusätzlichen statischen Routen supporten ist eine Connectivity nicht mehr möglich.

2.) Eleganter ist es das Default Gateway auf den Switch einzutragen wie du es derzeit hast. Der Switch kann aber nur eine default Route auf genau einen Router konfiguriert haben was dann für alle 3 VLAN Netze gilt und du ja aber nicht willst.
Da du einen Cisco hast gibt es eine sehr elegante Möglichkeit das über sog. Policy Based Routing zu lösen. D.h. du filterst den Traffic von 2 VLAN Netzen und setzt für die jeweils ein anderes Default Gateway nämlich ihr eigenes und nicht die statische Default Route auf dem Switch.
Folgende einfache Konfig auf dem 3550er Switch löst dein kleines Problem im Handumdrehen:

interface vlan 10
description Lokales LAN VLAN-10
ip address 192.168.100.254 255.255.255.0
!
interface vlan 20
description Lokales LAN VLAN-20
ip address 192.168.101.254 255.255.255.0
ip policy route-map vlan20
!
interface vlan 30
description Lokales LAN VLAN-30
ip address 192.168.102.254 255.255.255.0
ip policy route-map vlan30
!
ip route 0.0.0.0 0.0.0.0 192.168.100.1
!
access-list 101 deny ip 192.168.101.0 0.0.0.255 192.168.100.0 0.0.0.255
access-list 101 deny ip 192.168.101.0 0.0.0.255 192.168.102.0 0.0.0.255
access-list 101 permit ip 192.168.101.0 0.0.0.255 any
!
access-list 102 deny ip 192.168.102.0 0.0.0.255 192.168.100.0 0.0.0.255
access-list 102 deny ip 192.168.102.0 0.0.0.255 192.168.101.0 0.0.0.255
access-list 102 permit ip 192.168.102.0 0.0.0.255 any
!
route-map vlan20 permit 10
match ip address 101
set ip next-hop 192.168.101.1
!
route-map vlan30 permit 10
match ip address 102
set ip next-hop 192.168.102.1

Damit gehen nur Pakete aus dem .100.0er Netz über die Default Route an das Gateway 192.168.100.1
Pakete aus dem .101.0er Netz ins Internet werden über die ACL 101 abgefangen und auf den DSL Router 192.168.101.1 geschickt. Außer Paketen für die lokalen Netze die lokal geroutet werden über die .254
Analog das gleiche für das .102.0er VLAN.
Fertisch....
Aus Netzwerk Sicht ist die 2 Alternative die bessere da sich dich vollkommen von manuellen Eingriffen befreit.
Alternativ kannst du natürlich auch die schlimmen Billigheimer DSL Router entsorgen die du da hast und welche mit der Möglichkeit der Eingabe statischer Routen beschaffen. Die intelligente Cisco Konfig scheint da aber dann das kleinere Übel zu sein...
Bitte warten ..
Mitglied: StefanKittel
12.03.2011 um 22:15 Uhr
Zitat von aqui:
@Stefan
Hat er doch geschrieben.... Er hat einen Catalyst 3550. Der kann VLANs und routen, denn er ist ein L3 Switch.
Wer lesen kann war schon immer im Vorteil...
Bitte warten ..
Mitglied: Coachi81
13.03.2011 um 12:17 Uhr
Oh das hört sich sehr gut an. Hab echt schon gezweifelt das es überhaupt eine Möglichkeit gibt mein Problem zu lösen. Ich bevorzuge natürlich die 2. Möglichkeit von aqui und werds die Tage gleich mal versuchen. Das Ergebnis bekommt ihr natürlich mitgeteilt, dauert eben nur ein bisschen.

@ StefanKittel: Wir haben verschiedene DSL Router, z.B. einen Speedport W701V... Eigentlich sollten hochwertigere Geräte drin sein ja aber die haben wir nunmal und es ist langsam zu einer persönlichen Sache geworden das Ding trotzdem zum Laufen zu bringen Ach ja, und es ist ein Cisco 3750er *g
Bitte warten ..
Mitglied: Coachi81
15.03.2011 um 10:36 Uhr
Hallo nochmal,

wir sind gerade dabei die Access List einzurichten. Leider nimmt er mir den Befehl "ip policy route-map vlan20"
nicht. Ich komm bis "ip", das "policy" kennt er schon nicht mehr. Wenn ich nach "ip" ein Fragezeichen mach bietet er
mir "policy" auch gar nicht an. Zum absetzen des Befehls bin ich direkt im Interface aber der Befehl wird nicht erkannt.
Der Rest hat funktioniert, das Problem ist das halt ohne diesen Befehl das ganze nicht gültig ist.
Kann mir jemand sagen was wir falsch machen!

mfg
Bitte warten ..
Mitglied: Coachi81
20.03.2011 um 11:18 Uhr
Weiss denn keiner mehr was dazu? Es funktioniert nach wie vor nicht weil er den Befehl "ip policy route-map vlan..." verweigert

mfg
Bitte warten ..
Mitglied: aqui
20.03.2011 um 12:28 Uhr
Das liegt an deinem Image ! Lade dir das IP Plus Image vom Cisco Download Portal und flashe deinen Switch damit, dann funktioniert das im Handumdrehen !!
http://www.cisco.com/cisco/software/navigator.html?a=a&i=rch
Welches 3750er Modell hast du genau ? Leider teilst du uns das oben ja nicht mit
Bitte warten ..
Mitglied: Coachi81
21.03.2011 um 07:08 Uhr
Wir haben einen WS-C3750-24FS-S (LWL) mit der Software "ipbasek9-mz.122-53.SE"
Ist denn dieses IP Plus Image kosenlos?
Bitte warten ..
Mitglied: Coachi81
23.03.2011 um 21:56 Uhr
Hm, nachdem ich mir bei Cisco einen Account zugelegt haben kann ich jetzt auch eine Software "ipservices" runter laden. Ist das die Software die ich brauch und ist sie auch kostenfrei? Ich hoff das mir das jemand beantworten kann...
Bitte warten ..
Mitglied: Coachi81
26.03.2011 um 12:07 Uhr
Keiner eine Antwort?
Ich denk halt, wenn man sie runter laden kann is sie auch kostenfrei aber bei Cisco bin ich mir da nicht so sicher...
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Lancom mit 2 DSL Leitung (internet IP über eine feste DSL-Leitung schicken)
gelöst Frage von lord-iconLAN, WAN, Wireless2 Kommentare

Hi, ich hab den Lancom 1821n mit 2 DSL'er als Loadbalancing. Das klappt auch schon seit Jahren. Nun hab ...

Router & Routing
VLANs über verschiedene MPLS-Leitungen routen
Frage von Tomschaf91Router & Routing3 Kommentare

Guten Morgen zusammen, ich stehe gerade vor einem größeren Projekt und habe da ein kleines Problem: Um den Datenverkehr ...

Netzwerkgrundlagen
Backup-DSL-Leitung richtig konfigurieren
gelöst Frage von KLinnebankNetzwerkgrundlagen15 Kommentare

Hallo zusammen, ich habe da ein Verstädnisproblem, bei der mir sicher jemand von Euch die Augen öffnen kann. Ich ...

DSL, VDSL
DSL und ISDN über 20m Cat5 Leitung
gelöst Frage von mtaiitDSL, VDSL6 Kommentare

Guten morgen, ich möchte beim Kunden aus Verkabelungs- und WLAN Gründen eine FritzBox im 2. OG positionieren, das Amt ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement16 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...