Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

mehrere Wenn Formeln verbinden

Frage Microsoft Microsoft Office

Mitglied: -Firebird-

-Firebird- (Level 1) - Jetzt verbinden

17.06.2008, aktualisiert 21:54 Uhr, 10771 Aufrufe, 2 Kommentare

Hallo,
bin gerade dabei ein Tool für die Arbeit zu basteln nur leider habe ich nun 4 Wenn Formeln die ich gerne
zu einer verbinden würde.

Leider sind bisher alle Versuche fehlgeschlagen.
Folgende Formeln habe ich dafür:

=WENN(SUMME(D10:D16)>100;"Du hast über 100 % bei den Anteilen vergeben";"")
=WENN(SUMME(D10:D16)<100;"Du hast unter 100 % bei den Anteilen vergeben";"")
=WENN(SUMME(H10:H16)>100;"Du hast über 100 % bei den Zielen vergeben";"")
=WENN(SUMME(H10:H16)<100;"Du hast unter 100 % bei den Zielen vergeben";"")

Diese Funktionieren in jeweils einer Zeile, wurde aber gerne alles Verbinden so das ich für alles nur eine benötige.

THX
Mitglied: Biber
17.06.2008 um 21:31 Uhr
Moin -Feierbird-,

du kannst natürlich die Wenn-Bedingungen in eine Zeile schreiben:
01.
=WENN(SUMME(D10:D16)>100;"Du hast über 100 % bei den Anteilen vergeben"; WENN(SUMME(D10:D16)<100;"Du hast unter 100 % bei den Anteilen vergeben"; WENN(SUMME(H10:H16)>100;"Du hast über 100 % bei den Zielen vergeben"; WENN(SUMME(H10:H16)<100;"Du hast unter 100 % bei den Zielen vergeben";""))))
.... aber eigentlich sollte es bei WENN..DANN...SONST-Bedingungen schon so sein, dass entweder keine oder eine Bedingung erfüllt sein können.

In deinem Fall könnten auch gleichzeitig zwei Bedingungen erfüllt sein (Summe Anteile ungleich 100% UND Summe Ziele ungleich 100%).
Führt zwar "nur" dazu, dass erst die User-zu-doof-zum-Anteil-eingeben-Meldung angezeigt wird und nach der Korrektur nochmal die U-z-d-z-Z-e-Meldung...
Aber der geneigte User wird Dich anmaulen mit "boah... hättest Du mir das nich' gleich sagen können, ey".

Also mach doch lieber gleich:
01.
=WENN(SUMME(D10:D16)<>100;"Summe Anteile ist ungleich 100%!"; WENN(SUMME(H10:H16)<>100;"Summe Ziele ist ungleich 100%!";""))
-> Sind aber auch drei mögliche Zustände, von denen keiner, einer oder zwei gegeben sein können.
--> heißt: ich würde die Ausgabe der Meldung auf jeden Fall in zwei Fehlerzeilen platzieren, die "parallel" lesbar sind.

Grüße
Biber
Bitte warten ..
Mitglied: -Firebird-
17.06.2008 um 21:54 Uhr
THX Super Tip,
hab es auch auf zwei Zeilen aufgeteilt wie du vorgeschlagen hast, da man sonst alle Felder überprüfen muss.

BIG THX
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Excel - suchen und ersetzen für mehrere Formeln in verschiedenen Dateien
Frage von kilrathiMicrosoft Office

Hallo zusammen, ich weiß es gibt schon einige Fragen zu "suchen und ersetzen" in Excel, aber irgendwie passt Keine ...

Microsoft Office
Excel Formeln werden nicht übernommen
Frage von ForgottenRealmMicrosoft Office1 Kommentar

Moin, ich habe auf einem PC ein merkwürdiges Problem mit Office 365, Version 1707. Im Excel werden Formeln (A3 ...

Basic
Formeln in VBA Code einfügen
gelöst Frage von Dett18Basic6 Kommentare

Hallo liebe Excel VBA Gemeinde, ich habe hier eine Buchungsdatei, die mit Daten einer Rechnung gefüllt wird. Da ich ...

Microsoft Office
Microsoft Word 2010 "If formeln"
Frage von NexodusMicrosoft Office2 Kommentare

Guten Tag zusammen, Ich bin ein Neuling im Bereich IT, ich mache zurzeit ein Praktikum. Ich muss in Word ...

Neue Wissensbeiträge
DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 35 MinutenDSL, VDSL

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Windows 10

Microsoft bestätigt DMA-Policy-Problem in Win10 v1709

Information von DerWoWusste vor 46 MinutenWindows 10

Wer sein Gerät mit der DMA-Policy absichert, bekommt evtl. Hardwareprobleme in v1709 von Win10. Warum? Weil v1709 endlich "richtig" ...

Verschlüsselung & Zertifikate

Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows

Information von ticuta1 vor 4 StundenVerschlüsselung & Zertifikate

Interessant Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows SSH-Kommando in CMD.exe und PowerShell

Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server19 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement17 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...