Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Mehrere Netzwerke teilen sich einen Internetanschluss - Zugriff der Netzwerke untereinander herstellen - Nur wie?

Frage Netzwerke Netzwerkgrundlagen

Mitglied: Pommernschaf

Pommernschaf (Level 1) - Jetzt verbinden

25.04.2013, aktualisiert 18:24 Uhr, 2826 Aufrufe, 12 Kommentare, 3 Danke

Hallo Leute,

ich steige gerade neu in die Netzwerkmaterie ein und habe mich mal kurz selbst vor ein (bisher) unlösbares Problem gestellt. Ich hoffe, hier kann mir geholfen werden. Besser gesagt, ich bin mir sicher ...

Meine Netzwerkkonfiguration sieht derzeit wie auf dem Bild aus. Eingesetzt werden überall Linksys WRT54GL mit DD-WRT v24-sp2. Soweit so gut, alle Rechner kommen ins Internet .

cd89df383b37425cd15ee6b0b1e0958c - Klicke auf das Bild, um es zu vergrößern

Nun möchte ich aber gerne auch von allen PCs auf alle Router bzw. Netzwerke zugreifen können. Leider bekomme ich das nicht hin und auch eifriges Suchen hier bei Euch brachte nicht den erhofften Erfolg.

Ach ja... vielleicht wäre noch zu erwähnen, dass alle Router im Subnetz-Masken-Bereich 255.255.0.0 arbeiten. Die obere IP ist immer die WAN-IP des Router, die untere die jeweilige LAN-IP.

Würde mich freuen, wenn jemand von Euch eine zündende Idee hat.


Viele Grüße

Pommernschaf
Mitglied: aqui
25.04.2013, aktualisiert um 19:00 Uhr
Einfach mal die Suchfunktion benutzen hier...
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
und auch
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
und auch
http://www.administrator.de/wissen/mit-einem-wlan-zwei-ip-netzwerke-ver ...
Das sollte (fast) alle deine Fragen beantworten...
Dein Problem (geraten) sind die vermutlich fehlenden statischen Routen in alle diese IP Netze und / oder der falsche Modus (Router oder Gateway Modus) Letzterer macht NAT und dann bleibst du an der NAT Firewall kleben und kannst nicht transparent routen wie hier in der Alterntive 2 beschrieben:
http://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ...
Das WLAN Tutorial oben widmet dem Problem und der Lösung ein eigenes Kapitel !
Bitte warten ..
Mitglied: keine-ahnung
25.04.2013 um 18:35 Uhr
Allmählich glaube ich doch an dèjá-vu ... und täglich grüsst das Routertier

LG, Thomas
Bitte warten ..
Mitglied: aqui
25.04.2013 um 19:00 Uhr
Genau...! Ist alles schon fest verdrahtet auf "cut and paste"
Bitte warten ..
Mitglied: lenny4me
26.04.2013 um 07:33 Uhr
Hallo,

sollten das die richtigen IP Adressen sein die Du da oben in das Bild geschrieben hast (was echt gut gemacht ist). google mal nach privaten und öffentlichen IP Adressen.

Grüße
Bitte warten ..
Mitglied: brammer
26.04.2013 um 08:17 Uhr
Hallo,

sollten das die richtigen IP Adressen sein die Du da oben in das Bild geschrieben hast

LOL!

1.2.3.1
APNIC Australien = Asia-Pacific Network Information Centre, Australien

7.8.9.1
Department of Defense = Amerikanisches Verteidigungsministerium

Die Verbindung zwischen den beiden Gebäuden soltle übrigens unbedingt Funk oder Glasfaser sein!
Bei einer Kupferverbindung kannst du richtig Probleme mit dem Potentialausgleich bekommen, im Extremfall sollen dadurch schon Brände entstanden sein und Geräte geschrottet worden.

brammer
Bitte warten ..
Mitglied: Pommernschaf
26.04.2013 um 08:33 Uhr
Hallo,

Zitat von lenny4me:
sollten das die richtigen IP Adressen sein die Du da oben in das Bild geschrieben hast (was echt gut gemacht ist).

Nein, selbstverständlich nicht. Die stehen da nur sehr beispielhaft.


Zitat von brammer:
Die Verbindung zwischen den beiden Gebäuden soltle übrigens unbedingt Funk oder Glasfaser sein!

Ja, die Verbindung läuft über Wlan. Hier liegt ja auch mein Problem, ich habe zwar in beiden Gebäuden iNet, kann aber auf die Router und Rechner nicht gegenseitig zugreifen.


Viele grüße

Pommernschaf
Bitte warten ..
Mitglied: aqui
26.04.2013 um 08:50 Uhr
Bitte lies dir dieses Tutorial durch:
http://www.administrator.de/wissen/mit-einem-wlan-zwei-ip-netzwerke-ver ...
Da steht das doch haarklein und nur zum Abtippen drin wie man das funktionsfähig löst mit dd-wrt !!
Wo ist denn nun wirklich dein Problem ??
Bitte warten ..
Mitglied: lenny4me
26.04.2013 um 09:06 Uhr
Man kann ja nie wissen....
Bitte warten ..
Mitglied: Pommernschaf
26.04.2013 um 11:55 Uhr
Hallo,

meiner derzeitige Netzwerkkonfiguration sieht so aus:

9252748da6be3180f402fde57d6e388a - Klicke auf das Bild, um es zu vergrößern

Hier die einzelnen Einstellungen


1) Majestix (Internet-Router)

Basis-Setup:

be3930fcc22967b4801a6b9e5f6d3a2d - Klicke auf das Bild, um es zu vergrößern

Erweitertes Routing:

a5cd57573e9b411949a6f86c169ce57d - Klicke auf das Bild, um es zu vergrößern

Wlan-Basis-Setup:

55e463d3d4bbbe6983fbd5a16e210039 - Klicke auf das Bild, um es zu vergrößern


2) Asterix (Router 2)

Basis-Setup:

895d78e21ca6517c726f58dad67c7a30 - Klicke auf das Bild, um es zu vergrößern

Erweitertes Routing:

c3db92a0957ab6235da9f2a1dcb5acbe - Klicke auf das Bild, um es zu vergrößern

WLan-Basis-Setup:

789460deea88d605ab342d753e37a265 - Klicke auf das Bild, um es zu vergrößern


3) Obelix (Router 3)

Basis-Setup:

61702aa649574a3dcd0967075711cc56 - Klicke auf das Bild, um es zu vergrößern

Erweitertes Routing:

a8b87c95d90832b428f7b795d7ffe3ec - Klicke auf das Bild, um es zu vergrößern

WLan-Basis-Setup:

fe1eb4038287f93da2e4281c5c600d86 - Klicke auf das Bild, um es zu vergrößern

... ich find den Fehler nicht, aber irgendwas muss ich übersehen. :-S

Folgendes passiert:

Aus Haus 1 habe ich Zugriff auf Majestix und Asterix, kein Zugriff auf Obelix.

Aus Haus 2 habe ich Zugriff auf Obelix und Majestix, kein Zugriff auf Asterix.

Idefix habe ich jetzt erst mal außen vor gelassen...

Im Moment weiß ich nicht mehr weiter.

Viele Grüße

Peter
Bitte warten ..
Mitglied: aqui
26.04.2013, aktualisiert um 13:54 Uhr
Mehrere gravierende Kardinalsfehler bei der Einrichtung bzw. Konfiguration und IP Design:
  • Majestix: Vom SAT Modem kommen default Route und IP fürs WAN Interface. Hier darf nicht in der IP Adresse Gateway und DNS eingetragen werden. Abgesehen davon ist es auch Blödsinn das Majestix sich selber dort als Gateway einträgt. Beide Einträge leer lassen bzw. auf 0.0.0.0 !
  • Obelix: Alles richtig, allerdings fehlt hier die statische Route für das Netzwerk am LAN Port von Idefix. (IP: ??)
  • Asterix: Hier hast du so ziemlich alles falsch gemacht was du eigentlich bei Obelix richtig gemacht hast. Warum hast du nicht bei Obelix einfach mal abgeguckt ???
  • Asterix: WAN Port "abgeschaltet" ist natürlich Unsinn ! Hier muss "Static" rein wie bei Obelix, die 10.11.12.2 mit 24 Bit Maske und Gateway wieder auf Majestix' LAN IP ebenso DNS (analog zu Obelix). Diese IP am Asterix LAN Port zu konfigurieren ist natürlich Blödsinn, denn Asterix hängt ja am WAN Port an Majestix. Am Asterix LAN Port muss ein anderes IP Netz hin wie 10.13.12.0 /24
  • Asterix: Obendrauf fehlen die statischen Routen ins LAN Netzwerk Obelix (10.12.12.0 /24) und in das LAN an Idefix (IP ??) via WAN Port an die 10.11.12.3
  • Idefix: Vermutlich das gleiche Problem wie bei Asterix (geraten) ? WAN Port auf "Static" mit 10.12.12.2 und Gateway und DNS auf Obelix (10.12.12.1). Am LAN IP 10.14.12.0 /24

Aus Layer 3 Sicht sähe dein Netz so aus:
a149e960b599910f77f379a8d2e75ffb - Klicke auf das Bild, um es zu vergrößern

Tip: Du solltest dir dringenst einmal etwas über IP Routing anlesen wie z.B. eines der o.a. Tutorials in die du vermutlich keinen einzigen Blick geworfen hast
Bitte warten ..
Mitglied: Pommernschaf
26.04.2013 um 14:21 Uhr
Zitat von aqui:
Tip: Du solltest dir dringenst einmal etwas über IP Routing anlesen wie z.B. eines der o.a. Tutorials in die du vermutlich
keinen einzigen Blick geworfen hast

Im Gegenteil, gerade aufgrund der Links oben habe ich versucht das Ganze nachzuvollziehen. Und gerade der letzte Link schreibt ja, dass bei Asterix der WAN-Port ungenutzt bleiben soll. Zumindest hatte ich das so verstanden.

Habe ich das jetzt richtig verstanden, die einzelnen Router sollen erst einmal jeweils ein eigenes IP-Netz bekommen? Also WAN und LAN jeweils konfigurieren?

Trotzdem Danke, ich versuche heute Abend mal Deine Tipps umzusetzen und melde mich dann wieder.


Viele Grüße

Peter
Bitte warten ..
Mitglied: aqui
26.04.2013, aktualisiert um 14:58 Uhr
Dann hast du aber das Tutorial nicht wirklich verstanden, sorry Peter ! Oder wir haben hier nicht wirklich verstanden was du genau vorhast (siehe unten)
Die Alternative 3 (...dort wo geschrieben steht das der WAN Port nicht benutzt werden soll) beschreibt eindeutig ein Accesspoint ONLY Szenario !
Also wo man aus einem Router einfach nur einen einfachen Accesspoint macht.
Genau das hast du hier aber NICHT, denn anhand des obigen Schaubildes kannst du ja ganu sehen das Asterix zwischen seinem LAN Netz und den anderen lokalen IP Netzen und auch dem Internet via Majestix routen muß.
Logischerweise kann ein simpler WLAN Accesspoint sowas natürlich nicht...denn er ist ja kein Router wie der Name schon sagt
Wenn du alles so umsetz wie oben beschrieben klappt das auf Anhieb. Bei Obelix hast du ja schon genau die richtige Richtung eingeschlagen...?! Asterix und Idefix sind identisch.
ACHTUNG:
Das gilt NUR wenn du die lokalen Netzwerke von Asterix und Idefix auch wirklich abtrennen willst. Genau DAS ist nicht so wirklich ersichtlich aus deinem Vorhaben. Ist das nicht der Fall und sollen Asterix und Idefix wirklich nur als simple dumme Accesspoints laufen für die loaklen Netze an Majestix und Obelix und keine Netze dort als Router trennen, stimmt dein Konzept natürlich wieder.
Clients daran arbeiten dann direkt in den IP Netzen an Majestix und an Obelix und es gibt keine Trennung. Sorry wenn das hier in den falschen Hals gekommen sein sollte.
Dann sieht dein Netz natürlich so aus:

8f05de90d7fe51edf7172088bacf2cf9 - Klicke auf das Bild, um es zu vergrößern

Hier sind die Schritte wieder ganz einfach:
  • Genau vorgehen wie in diesem_Tutorial beschrieben was Majestix und Obelix anbetrifft und Szenario mit Pings checken
  • Asterix und Idefix wie hier in der Alternative 3 beschrieben als simple APs aufsetzen.
  • Bei den beiden zu APs gemachten Routern Asterix und Idefix ist dann folgendes zu beachten:
  • 1.) WAN Port bleibt unbelegt bzw. deaktiviert !
  • 2.) DHCP Server am LAN ausgeschaltet ! (IP Adressen vergibt Majestix bzw. Obelix lokal)
  • 3.) Jeweils LAN IP von Majestix (bei Asterix) und Obelix (bei Idefix) als Gateway und DNS IP am LAN Port eintragen.
  • 4.) Aufpassen das die WLAN Funkkanäle von Majestix, Asterix und Idefix 4 bis 5 Kanäle Abstand haben sofern sie sich überlappen sollten um Störungen zu vermeiden. Ggf. mit den kostenlosen inSSIDer messen !

Es bleibt aber bei dem Punkt von ganz oben, das bei Majestix KEIN Gateway auf dem LAN Port eingetragen werden darf !
Einzig eine statische Route ins 10.12.12.0 /24 Netz muss bei Majestix konfiguriert werden die als Gateway auf die 10.11.12.3 zeigt !
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Virtualisierung
gelöst Interne Netzwerke untereinander kommunizieren lassen (9)

Frage von chelewae zum Thema Virtualisierung ...

Windows Server
gelöst Mehrere User auf einem 2012-Server teilen sich eine MS-Office-Lizenz? (7)

Frage von Calvus zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...