Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Merkwürdiges Problem mit interner und externer Verbindung

Frage Microsoft Windows Server

Mitglied: darthi

darthi (Level 1) - Jetzt verbinden

28.12.2008, aktualisiert 16:22 Uhr, 4549 Aufrufe, 8 Kommentare

Verbindung von extern funktioniert nach kurzer Zeit nicht mehr.

Hallo zusammen,

ich habe ein sehr merkwürdiges Netzwerkproblem mit der Remote Desktop Connection und Windows Server 2003.
Intern funktioniert alles tadellos. Ich kann ohne Probleme über die interne IP Adresse auf den Windows Server zugreifen.
Extern funktioniert auch erst alles tadellos. Also ich kann über meine externe feste IP Adresse auf den Windows Server zugreifen (Port 3389 ist im Router geforwarded).
Nach kurzer Zeit (ich kann nicht nachvollziehen, was in dieser Zeit passiert ist, wenn überhaupt etwas passiert ist) ist eine Verbindung über die externe IP Adresse nicht mehr möglich. Also, auf der Windows Server spricht nicht mehr auf Verbindungen von außen an. Die internen funktionieren nach wie vor einwandfrei (ebenfalls über den 3389 Port). Es liegt kein Problem mit dem Router vor, da ein Neustart von diesem nichts bringt. Einzige Abhilfe bringt ein Neustart des Windows Servers. Dann funktioniert kurzfristig wieder alles einwandfrei.
Ich kann es beim besten Willen nicht nachvollziehen, wieso der Windows Server nach einiger Zeit keine Verbindungen mehr mit externen IP Adressen akzeptiert. Eigentlich merkt er ja auch gar nicht, dass diese Zugriffe aus dem Internet kommen. Auf dem Windows Server sind keine Desktop Firewalls oder Ähnliches installiert (Windows Firewall ist auch deaktiviert).

Jetzt meine Frage: Weiß jemand woran das liegt und wie ich dieses Problem beheben kann?

Vielen Dank für Eure Hilfe!
Mitglied: aqui
28.12.2008 um 16:37 Uhr
Hast du den Port in der Windows Firewall auch für externe IP Adressen freigegeben ?? Ohne das blockt die Firewall alle Requests von externen IP Adressen !

Man kann dir nur dringend raten eine Port Verschleierung zu machen wenn dein Router eine Port Translation supportet trägst du den Port 53389 ein extern auf intern 3389.

So landest du nicht gleich beim ersten Port Scan deines Routerports in den Listen der Hacker und Scanner, die immer Standardports scannen !!!

Kann dein Router keine Port Translation kannst du den Zielport des RDP Dienstes auf einen anderen Port umbiegen.
Das geschieht in der Registry mit Regedit des Werts:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\

Dort trägst du in den Wert PortNumber dann z.B. die 53389 ein und rebootest die Maschine.

Danach kannst du dann im Client mit <ip_adresse>:53389 den Remote Desktop wieder erreichen. Ansonsten Sniffern mit Wireshark oder MS-NetMonitor ob die RDP Pakete vom Router zum Server gehen.
Bitte warten ..
Mitglied: DerWoWusste
28.12.2008 um 16:38 Uhr
Sniff auf dem Server mit Wireshark mit, ob die Anfragen noch bei ihm ankommen.
Bitte warten ..
Mitglied: darthi
28.12.2008 um 16:51 Uhr
Zitat von aqui:
Hast du den Port in der Windows Firewall auch für externe IP
Adressen freigegeben ?? Ohne das blockt die Firewall alle Requests von
externen IP Adressen !

Ich habe doch gesagt, dass die Windows Firewall deaktiviert ist.


Man kann dir nur dringend raten eine Port Verschleierung zu machen
wenn dein Router eine Port Translation supportet trägst du den
Port 53389 ein extern auf intern 3389.

Das ist sowieso gemacht.

Danach kannst du dann im Client mit <ip_adresse>:53389 den
Remote Desktop wieder erreichen. Ansonsten Sniffern mit Wireshark oder
[http://www.microsoft.com/downloads/details.aspx?familyid=f4db40af-1e08-4a21-a26b-ec2f4dc4190d&displaylang=en&tm
MS-NetMonitor] ob die RDP Pakete vom Router zum Server gehen.


Dies werd ich nun machen wenn ich das nächste mal keine Verbindung mehr bekomme.
Bitte warten ..
Mitglied: darthi
29.12.2008 um 10:07 Uhr
So, also ich habe den Windows Server nun mit Wireshark gesnifft. Es kommen keine Anfragen bei ihm an.
Dies macht die ganze Sache noch merkwürdiger. Das ist schon fast so, als ob die Netzwerkkarte vom Windows Server die Anfragen einfach ignoriert und nicht einmal an das Betriebssystem weiterreicht.
Bitte warten ..
Mitglied: DerWoWusste
29.12.2008 um 11:13 Uhr
Wenn keine Anfragen bei ihm ankommen aber dennoch ein Neustart des Servers hilft, muss auf Netzwerkebene am Server etwas vom Feinsten spinnen. Firewalls sind aber aus. Hmm...kurios.Da solltest Du vielleicht erneut prüfen - sind wirklich keine FWs drauf? Nicht etwa eine Unterkomponente von Virenscanner xy, die da auch noch gerne mitreden möchte? Ich schätze nein. Was kann man noch tun? TCP/IP neu installieren?
Stell ganz sicher, dass die Symptome richtig beschrieben sind. Ich könnte mir 10 Mal eher vorstellen, dass es der Router ist, der spinnt.
Bitte warten ..
Mitglied: darthi
29.12.2008 um 11:39 Uhr
Zitat von DerWoWusste:
Wenn keine Anfragen bei ihm ankommen aber dennoch ein Neustart des
Servers hilft, muss auf Netzwerkebene am Server etwas vom Feinsten
spinnen. Firewalls sind aber aus. Hmm...kurios.

ich weiß...
Da solltest Du
vielleicht erneut prüfen - sind wirklich keine FWs drauf?
Wirklich gar nichts...
Nicht etwa eine Unterkomponente von Virenscanner xy, die da auch noch gerne
mitreden möchte?
Auch nicht...
Ich schätze nein. Was kann man noch tun?
TCP/IP neu installieren?
Stell ganz sicher, dass die Symptome richtig beschrieben sind. Ich
könnte mir 10 Mal eher vorstellen, dass es der Router ist, der
spinnt.

Symptome sind richtig beschrieben und du hast es auch richtig erkannt. Es ist kein Problem mit dem Router sondern anscheinend mit der Hardware des Servers...
Ansonsten wäre das Problem auch schon längst behoben.
Kann so etwas theoretisch ein Angriff von außen sein? Also, dass irgendwelche Pakete gesendet werden, bei denen dann der Server oder so aussteigt?
Weil ein Konkurrent von uns will uns seit einiger Zeit aus dem Geschäft werfen.
Bitte warten ..
Mitglied: aqui
29.12.2008 um 12:01 Uhr
"...Es ist kein Problem mit dem Router sondern anscheinend mit der Hardware des Servers..." ;

Das kannst du doch gar nicht sicher sagen !!! Du siehst lediglich mit einer Sniffer SW am Server das die Pakete nicht ankommen vom Router !!!

Um ganz sicher zu gehen solltest du den Sniffer mit einem kleinen Hub (kein Switch) in die Leitung zum Server einschleifen.
Wenn dann immer noch keine RDP Pakete ankommen ist es ganz klar das der Router diese Pakete NICHT forwardet !

Du schreibst oben das du eine Port Verschleierung
"sowieso"
gemacht hast aber beschreibst dein Szenario mit der Angabe der Standardports
Wenn du es denn wirklich umgesetzt hast achte daruf das hier keine Tippfehler entstanden sind.

Wenn der Zustand eintritt das du von remote keine Zugang bekommst und wirklich der Server das problem sein sollte (was ja fraglich ist...) dann MUSS auch vom lokalen Netz kein RDP Zugang möglich sein...logisch !
Das solltest du dann mal querchecken !

Einen Angriff auf den Server direkt würde man bemerken, denn das kann nur über den RDP Port bzw. den verschleierten Port geschehen sofern du nicht noch andere Ports auf den Server freigegeben hast. Andernfalls könnte man nur den Router angreifen, denn der stellt ja die Zugangs IP für die Außenwelt zum Server dar.
Das du hier natürlich alle Maßnahmen getroffen hast damit das nicht passiert sollte klar sein !!
Bitte warten ..
Mitglied: darthi
20.04.2009 um 11:59 Uhr
Das Problem ist mittlerweile gelöst. Es waren zwei Gateways (für jede Netzwerkkarte einer) auf dem Server eingetragen. Nach einiger Laufzeit hat er dann anscheinend automatisch auf den 2. Gateway (nur VPN) gewechselt und versucht darüber alle Anfragen zu bearbeiten. Nachdem man diesen rausgenommen hat und nur noch über Routen gearbeitet hat, funktioniert alles einwandfrei.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Virtualisierung
Problem mit VPN-Verbindung und Android-Emulatoren (2)

Frage von OS.Sammler zum Thema Virtualisierung ...

Windows Server
Verbindung zu bestimmter externer Adresse geht nicht (12)

Frage von sokraTonis zum Thema Windows Server ...

Microsoft Office
ODBC Verbindung Problem mit Excel (5)

Frage von 3jojojo zum Thema Microsoft Office ...

Cloud-Dienste
gelöst Nextcloud-Externer Zugriff nicht möglich "verbindung abgelehnt" (9)

Frage von R14943 zum Thema Cloud-Dienste ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...