Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Merkwuerdiges Formular Problem

Frage Entwicklung PHP

Mitglied: Closed

Closed (Level 1) - Jetzt verbinden

18.06.2008, aktualisiert 23.06.2008, 3887 Aufrufe, 5 Kommentare

hi,

habe folgendes problem: ich hab ein skript geschrieben, welches eine login möglichkeit bietet über eine passwortabfrage, wenn ich eine gewisse session variable nicht gesetzt habe. wird das passwort erfolgreich eingegeben, dann erfolgt die zuweisung der session variable und mittels header("loacation:... rufe ich das skript erneut auf. daraufhin erkennt das skript, dass die variable gesetzt ist und zeigt content an (anstelle der passwortabfrage).

dies funktioniert auch soweit wunderbar für den firefox. der internet explorer macht daei totale zicken. wenn ich mit enter die eingabe des passworts bestätige, so erfolgt ein reload der seite ohne jegliche passwortüberprüfung oder sonstigem. klicke ich statt dessen auf den login button direkt (sprich mit der maus), so funktioniert auch im ie der login (gilt sowohl für ie6, als auch für ie7)

keine ahnung was das sein kann, ich hoffe iener von euch weiß da mehr rat
Mitglied: LordGurke
18.06.2008 um 22:15 Uhr
Habe selbiges Problem ebenfalls in meinem Routermenü, da ist mir dann aufgefallen, dass der Button "Login" ein ganz normaler <input type="button"> ist und kein <input type="submit"> - vielleicht ist ja bei dir das gleiche Problem.
Bitte warten ..
Mitglied: Closed
18.06.2008 um 22:45 Uhr
leider nein. es handelt sich um einen submit-type
Bitte warten ..
Mitglied: Spackenbremse
19.06.2008 um 14:03 Uhr
Hallo!

Das ist ein reines Browser-Problem. Das hat mir deinem Script nichts zu tun, IE reloaded die Seite eben nur, anstelle des Submits. Wenn überhaubt, denk ich das dein Problem mit Javascript zu lösen ist..

mfg
Bitte warten ..
Mitglied: Closed
19.06.2008 um 21:26 Uhr
ja genauso ist es. ich überprüf jetzt ob das feld gesetzt ist und nciht der submit button. problem gilt als gelöst
Bitte warten ..
Mitglied: masterG
23.06.2008 um 09:26 Uhr
Und geschlossen

masterG(Moderator)
Bitte warten ..
Ähnliche Inhalte
Rechtliche Fragen
gelöst Microsoftkonto wurde gehackt - Liegt das Problem direkt bei Microsoft? (6)

Frage von Stefan007 zum Thema Rechtliche Fragen ...

Python
Problem mit Python und imaplib2

Frage von meinsm zum Thema Python ...

Windows 7
gelöst Windows 7 Umzug zum neuen PC (SATA-Problem) (7)

Frage von MaxMoritz6 zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...