Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Merkwuerdiges Formular Problem

Frage Entwicklung PHP

Mitglied: Closed

Closed (Level 1) - Jetzt verbinden

18.06.2008, aktualisiert 23.06.2008, 3893 Aufrufe, 5 Kommentare

hi,

habe folgendes problem: ich hab ein skript geschrieben, welches eine login möglichkeit bietet über eine passwortabfrage, wenn ich eine gewisse session variable nicht gesetzt habe. wird das passwort erfolgreich eingegeben, dann erfolgt die zuweisung der session variable und mittels header("loacation:... rufe ich das skript erneut auf. daraufhin erkennt das skript, dass die variable gesetzt ist und zeigt content an (anstelle der passwortabfrage).

dies funktioniert auch soweit wunderbar für den firefox. der internet explorer macht daei totale zicken. wenn ich mit enter die eingabe des passworts bestätige, so erfolgt ein reload der seite ohne jegliche passwortüberprüfung oder sonstigem. klicke ich statt dessen auf den login button direkt (sprich mit der maus), so funktioniert auch im ie der login (gilt sowohl für ie6, als auch für ie7)

keine ahnung was das sein kann, ich hoffe iener von euch weiß da mehr rat
Mitglied: LordGurke
18.06.2008 um 22:15 Uhr
Habe selbiges Problem ebenfalls in meinem Routermenü, da ist mir dann aufgefallen, dass der Button "Login" ein ganz normaler <input type="button"> ist und kein <input type="submit"> - vielleicht ist ja bei dir das gleiche Problem.
Bitte warten ..
Mitglied: Closed
18.06.2008 um 22:45 Uhr
leider nein. es handelt sich um einen submit-type
Bitte warten ..
Mitglied: Spackenbremse
19.06.2008 um 14:03 Uhr
Hallo!

Das ist ein reines Browser-Problem. Das hat mir deinem Script nichts zu tun, IE reloaded die Seite eben nur, anstelle des Submits. Wenn überhaubt, denk ich das dein Problem mit Javascript zu lösen ist..

mfg
Bitte warten ..
Mitglied: Closed
19.06.2008 um 21:26 Uhr
ja genauso ist es. ich überprüf jetzt ob das feld gesetzt ist und nciht der submit button. problem gilt als gelöst
Bitte warten ..
Mitglied: masterG
23.06.2008 um 09:26 Uhr
Und geschlossen

masterG(Moderator)
Bitte warten ..
Ähnliche Inhalte
Windows Server
Problem mit Webdav und Webserver IIS (3)

Frage von JUJUS31 zum Thema Windows Server ...

Netzwerkgrundlagen
Multi NAT Problem (9)

Frage von Gr33n93 zum Thema Netzwerkgrundlagen ...

Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (17)

Frage von montylein1981 zum Thema Windows Server ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(3)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (41)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Off Topic
gelöst Fachzeitschriften als E-Book oder hardcoded? (11)

Frage von KowaKowalski zum Thema Off Topic ...

Windows 10
Windows Store Apps ohne Windows Store installieren (10)

Frage von keefien zum Thema Windows 10 ...