Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Messung des Datendurchsatzes

Frage Netzwerke Netzwerkmanagement

Mitglied: flipflip

flipflip (Level 1) - Jetzt verbinden

10.10.2006, aktualisiert 13.10.2006, 5645 Aufrufe, 13 Kommentare

Hallo,

kennt jemand ein gutes Programm, mit dem man den effektiven Datendurchsatz eines Netzwerks messen kann? Freeware-Programme bevorzugt. =)

Danke und Grüße,
Flip
Mitglied: hatzing
10.10.2006 um 10:22 Uhr
Hallo,
wir benutzen QCheck um z.B. Durchsatzmessungen zwischen zwei Systemen durchzuführen. Die Messung kann auch von einem dritten System aus erfolgen.

Benötigt wird QCheck: http://www.wintotal.de/softw/index.php?rb=1052&id=2394 und eine Endpointsoftware: http://www.netiq.com/support/pe/pe.asp, die auf den beiden zu testenden Systemen ausgeführt wird!
Bitte warten ..
Mitglied: flipflip
10.10.2006 um 12:06 Uhr
Hallo,

Danke für die schnelle Hilfe. Werde die Tools direkt mal ausprobieren.

Grüße...
Bitte warten ..
Mitglied: Cassie
10.10.2006 um 13:09 Uhr
oki sag bescheid ob es geklappt hat!!!
Bitte warten ..
Mitglied: aqui
13.10.2006 um 20:56 Uhr
NetIO ist das Tool der Wahl, damit siehst du den Durchsatz ohne Overhead und auch bei unterschiedlichen Packetgrößen was sehr wichtig ist !

http://www.ars.de/ars/ars.nsf/docs/netio
Bitte warten ..
Mitglied: 43292
28.09.2011 um 16:16 Uhr
NetIO habe ich mal downgeloadet und getestet. Ist wirklich sehr gut zu bedienen und macht in meinen Augen auch Sinn so den Durchsatz zu testen. Danke für diese Empfehlung.

Eine Frage hätte ich jedoch dazu: ich habe mir als Test zwei Windows-Kisten ausgesucht in Standort B und Standort B, die eine ist Win7, die andere WinXP.

Auf dem XP-Rechner habe ich "win32-i386.exe -M -s" gestartet, damit es also Server fungiert.

Auf dem Win7-Client habe ich "win32-i386.exe -M -t <xp.ho.st.ip.> gestartet.

Der Datendurchsatz beträgt laut Ausgabe ~110 MByte/s Tx und ca. 52-85 MByte/s Rx.

Mir erscheint das irgendwie wenig, oder hab ich 'nen Denkfehler? Mir ist klar, dass 1 MByte/s = 8 Mbit/s entsprechend. Aber bei der 1GBit/s Verbindung sollte ich doch so um die 125MByte/s Raten hinkriegen, und wieso hab ich solch verschiedene Raten für TX und RX ? Die Verbindung zwischen den zwei Hosts ist eine LAN-Verbindung, von Switch zu Switch, mit 1GBit/s Anbindung. Was müsste ich denn theoretisch für Datendurchsätze erzielen können bei 1GBit/s ? Wieso hab ich nur so wenig Datendurchsatz??

EDIT: Hab nochmal nen zweiten Test an zwei anderen Hosts durchgeführt. Die zwei Clients sind über einen Switch verbunden, der Switch zeigt brav 1000MBit/s Verbindung an, Full-Duplex, ohne Autonegotiate. Der Datendurchsatz zwischen diesen zwei Clients beträgt bei 1k Blöcken 41 MByte/s RX und 51MByte/s TX und bei 32K-Blöcken sind es 85 Mbyte/s RX und 84 MByte/s TX. Wieso aber nur?
Bitte warten ..
Mitglied: aqui
29.09.2011 um 12:58 Uhr
Das große M gibt es in den Kommando Parametern bei NetIO gar nicht...die Frage ist also was du damit meinst.
Normalerweise ist die Messung ganz banal und sollte mit TCP Encapsulation erfolgen !

Server :
netio -s

Client:
netio -t <ip_adresse_server>
Danach die Pollen einmal umdrehen.
Fertig !
Den Output bzw. Ergebnisse siehst du in Mbyte/s und die grobe Umrechnung 1 Mbyte/s = 8 Mbit/s ist OK so !

Dein gemessenere Datendurchsatz ist katastrophal für eine GiG verbindung.
Sinnvoll wäre mal eine direkte messung OHNE Switch gewesen zwischen den beiden Geräten nur mit einem Crossover Kabel.
So bekommst du dann raus WO der böse Buhmann ist.
Das kann
  • Der Switch mit falscher Autonegotiation oder billiger schwachbrüstiger HW sein
  • Eine NIC die schwachbrüstig ist
  • Ein fehlerhafter oder schwachbrüstiger Treiber (z.B. Realtek)
Das gilt es nun rauszufinden !
Bitte warten ..
Mitglied: 43292
29.09.2011 um 14:16 Uhr
Ja, genau das mit dem Crossoverkabel hatte ich auch vor, hab grad bloss keins da *schäm* Das M gibt es sehr wohl. Einfach mal netio so ausführen, das steht dann auch in der Beschreibung dabei. Ich kann M, B, K oder G angeben. Je nachdem in welcher Einheit ich die Ausgabe hätte (Bytes, KiloBytes, MegaBytes, GigaBytes). Heute hast also auch du was dazugelernt ;)

Werd berichten, wenn ich direkt von Host<--->Host gemessen hab.

Danke und Grüße,
Michael.

EDIT:
Hab ein normales Kabel genommen und mal zwei Clients miteinander verbunden, mit der Hoffnung, dass die NICs automatisch erkennen was für ein Kabel dranhängt. Hab beiden eine IP aus dem Netz 192.168.100/24 zugewiesen und netio laufen lassen. Ergebnisse:

1K-Blöcke: 47MByte/s Tx und 60MByte/s Rx.
32K-Blöcke: 85 Tx und 81 Rx.

Dann hab ich mal auf beiden Hosts die Netzwerkeinstellungen der NIC überprüft, und von Autonegotiating auf 1GB FDX manuell geschaltet. Hat nicht viel Änderungen gebracht:

1K-Blöcke: 45 Tx und 42 Rx
32K-Blöcke: 107 Tx und 109 Rx

Dann hab ich mal auf beiden Hosts Kaspersky Internet Security 2011 ausgeschalten und es hat ein wenig was gebracht:

1K-Blöcke: 64 Tx und 73 Rx
32K-Blöcke: 110 Tx und 112 Rx

Dann hab ich zur Sicherheit nochmals Kaspersky bei beiden Hosts eingeschaltet, und wieder die Ergebnisse gekriegt:

1K-Blöcke: 44Tx und 42 Rx
32K-Blöcke: 85 Tx und 84 Rx


Also Kaspersky bremst doch ganz schön würd ich sagen, nicht wahr? Ist das normal (schluck!) ?! wie könnte ich dem entgegenwirken und verbessern? Ich wills ja nicht komplett ausgeschaltet habe, die Clients sollen ja schließlich noch ihren Schutz genießen.

Und vor allem --> Was müsste ich denn für Werte erhalten, wenn alles korrekt funktioniert in einem 1GBit/s Netzwerk? mir erscheint das immer noch etwas wenig, oder täuscht das?
Bitte warten ..
Mitglied: 43292
29.09.2011 um 16:00 Uhr
So, es gibt neue Erkenntnisse. Ich hab mal meine Eigenschaften der LAN-Verbindung gecheckt. Dabei habe ich Step-by-Step die Häkchen entfernt vor den verschiedenen Protokollen. Die größten Änderungen ergeben dabei die Dienste "Kaspersky Anti-Virus NDIS 6 Filter" und der "QoS-Paketplaner" der standardmäßig von Windows mitinstalliert und aktiviert wird.

Schalte ich diese zwei Dienste auf beiden Clientrechnern ab und führe Netio durch, dann komme ich bei so ziemlich bei jedem Block-Test auf 112MByte/sec. Das würde * 8 = ca. 900MBit/s ergeben. Fehlen zwar immer noch 100MBit/s Leistung, die ich eigentlich erwartet hätte, aber immerhin. Vielleicht liegt das ja an Steuersignalen, und internen Verarbeitungsmaßnahmen innerhalb des Protokolls/Stacks. Bitte ggf. berichtigen.

Schalte ich testweise den QoS-Paketplaner ein, dann schluckt er mir um die 13MByte/sec (entsprich also ca. 100MBit/s) Leistung. Der Kaspersky NDIS 6 Filter schluckt um einiges mehr, und zwar 70MByte/sec (!!!), das entspricht über 500MBit/s Leistung. Das ist ja wohl der Oberhammer, oder nicht?! Ist das denn normal? Ich hab Kaspersky gecheckt: netio.exe ist als vertrauenswürdig eingestuft, und ich hab extra in den Firewall-Einstellungen die Ausnahme hinzugefügt, dass die zu öffnende Datei nicht untersucht wird, die Programmaktivität nicht kontrolliert wird, keine Beschränkung für den parent process übernommen wird, keine child processes kontrolliert werden und der Netzwerkverkehr nicht untersucht wird.

Trotzdem krieg ich bei aktiviertem "Kaspersky Anti-Virus NDIS 6 Filter" nur um die 40-50MByte/sec von Netio angezeigt. Das ist wirklich traurig :/

EDIT: Unglaublich aber wahr! Der "Kaspersky Anti-Virus NDIS 6 Filter", der in meiner Netzwerkkarte als Dienst mitläuft schluckt wirklich die Hälfte meiner Leistung. Ich hab den jetzt ausgeschaltet, und ich komme ständig auf 112,5 MByte/s bei TCP-Verbindungen. Das entspricht ganz genau 900MBit/s. Jetzt würde ich nur noch gerne wissen, wo die restlichen 100MBit/s bleiben ?

Hat jemand eine Idee? Sind die Werte so ok? Was kriegt ihr denn so raus in einem Gigabit-Netzwerk, wenn ich fragen darf?
Bitte warten ..
Mitglied: aqui
29.09.2011 um 17:32 Uhr
OK, damit ist der böse Buhmann also gefunden. Es kann aber auch ein Nachteil deiner NIC Hardware sein, dazu müsste man aber mal wissen welchen Chipsatz du da benutzt.
Realtek ist da ein übler Vertreter denn dessen NIC Chipsätze sind sehr primitiv und sie lagen den Großteil des Paket Assembling und Dissassembling auf die Rechner CPU aus. Ist die so oder so schn durch Antivirus Gedöns belastet hat das natürlich fatale Folgen wie du sehen kannst.
900 Mbit wäre schon ein sehr, sehr guter Wert. Bei Billig NICs ist 600 bis 700 Mbit schon gut.
Am besten sind also immer NICs die alles im Chipset machen und nur die Rohdaten auf dem Bus transportieren. Intel, Marvell, Broadcom, Atheros sind solche Kandidaten besonders die ersten 3.
Mit diesen Chipsätzen fährt man meist erheblich besser in puncto Performance
Bitte warten ..
Mitglied: 43292
29.09.2011 um 17:57 Uhr
Sorry, ich vergaß in meinem vorherigen Post, dir meine NIC zu nennen. Es ist eine "Intel 82567LM-3 Gigabit Network Card". Sie ist Bestandteil des Desktop-Rechners "Dell Optiplex 960". Ich habe ausserdem das aktuellste BIOS und aktuellste Treiber für die Netzwerkkarte installiert, vorhin erst von Dell heruntergeladen und upgedatet. Momentan habe ich den QoS-Dienst und den Kaspersky NDIS-Filter einfach gelöscht. Kaspersky scheint -wie es aussieht- trotzdem noch normal weiterzulaufen. Ich weiß nicht was sich Kaspersky da gedacht hat, aber die Performanceeinbussen (50% ?!) sind ja eine Schweinerei (meine persönliche Meinung).
Bitte warten ..
Mitglied: aqui
30.09.2011 um 15:26 Uhr
OK, dann kannst du die NIC Hardware sicher ausschliessen. Dann ist Kaspersky eindeutig der böse Buhmann. Ggf. mal deren Hotline anrufen ob es da Tuning Möglichkeiten gibt.
Bitte warten ..
Mitglied: 43292
18.10.2011 um 23:59 Uhr
Kaspersky angerufen habe ich nicht. Aber ich hab in den Netzwerkkarten-Einstellungen den "Kaspersky NDIS 6 Filter" entfernt. Kaspersky läuft laut Beschreibung eines Dokuments (irgendwo in google gefunden) problemlos weiter. Seitdem gabs diese Bremse nicht mehr. Ausserdem habe ich auch den QoS-Dienst von MS deinstalliert, der ja standardmässig mitinstalliert und verwendet wird. Ich brauch keinen QoS-Dienst auf dem Client. Und zusätzlich noch IPv6 deaktiviert (Häkchen entfernt) da kein IPv6 verwendet wird im LAN.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
SAN, NAS, DAS
Tool zur Peformance Messung für VMDK (1)

Frage von ioioio zum Thema SAN, NAS, DAS ...

Batch & Shell
Batch-Script für die Messung der Netzwerkgeschwindigkeit (10)

Anleitung von Kraemer zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...