Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Migration NT4 Server nach SLES10 - Probleme mit den Profilen

Frage Linux Linux Userverwaltung

Mitglied: 47910

47910 (Level 1)

09.05.2007, aktualisiert 29.05.2007, 3705 Aufrufe, 1 Kommentar

Hallo,

ich habe hier dickes Problem beim Umzug von NT4-Server (Domäne) auf SLES10 (Samba-Domäne).
Im Grunde funktioniert bereits das Anmelden der WinXP-Clients an der Samba-Domäne und auch die auf dem Server gespeicherten Profile (welche ich zuvor vom NT4-Server kopiert habe) werden übertragen - allerdings nicht vollständig, wie mir schein.

Denn Desktop und Co. sind zwar da, aber es fehlen z.B. die Drucker. Auch im XP-Startmenü fehlen gewisse Icons (Dieser Schnellstarter mit dem Browser, Mailprogramm etc.) und auch beim Firefox wird zwar das Profil nach C:\Dokumente und Einstellungen\benutername\usw kopiert aber es scheinen andere Einstellungen genommen zu werden, denn die zuvor unter der NT4-Domänen eingestellte Startseite ist auf dem WinXP-Client unter der SLES-Domäne nicht mehr da. In der entsprechenden Datei im Home-Verzeichnis des Users auf dem SLES steht jedoch der richtige Eintrag.
Vorallem aber sind auch die Ländereinstellungen verstellt. Das Tastaturlayout entspricht der vom amerikanischen Windows.

Ich verstehe nicht, was Windows da wieder treibt. Habe ich gar etwas vergessen?

Entsprechende Werte der smb.conf (Die Profile vom NT4-Server wurden nach /home/username/.msprofiles kopiert).

Danke für jeden Hinweis.

logon path = \\%L\profiles\.msprofiles
logon home = \\%L\%u

...

[profiles]

path = %H
read only = no
...
Mitglied: 47910
29.05.2007 um 09:37 Uhr
Wie es scheint habe ich die Ursache gefunden bzw. die Lösung gefunden:

Man muss die lokale Registry aus dem Verzeichnis der Benutzer löschen, weil es damit Probleme gibt. Wenn man also die Registry auf dem Server löscht, kann sich der Benutzer anmelden und es wird ein neuer Eintrag erzeugt.

Ich vermute mal, dass es da irgendwelche Probleme mit der User-ID (diese große Zeichenkette) und den Lese/Schreibrechten auf die Registry gibt, denn als Domänen-Admin gibt es dieses Problem nicht. Damit sollte es dann gehen.

Das ganze kann man problemlos mittels eines Skriptes löschen, wenn man zu viele Benutzer hat. Dabei die ganzen ntuser.* und NTUSER.* löschen und es sollte funktionieren. Leider geht es nicht anders, aber das ist halt Windows mit seinem tollen Registry-System.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
DC Migration von Server 2008R2 auf Server 2016 (1)

Frage von m.reeger zum Thema Windows Server ...

Windows Server
Windows-File-Server - Macs - Probleme (5)

Frage von guenthergranate zum Thema Windows Server ...

Windows Server
gelöst Migration Windows Server 2003 auf 2012 "offline" möglich? (7)

Frage von Christtian zum Thema Windows Server ...

Windows 10
Probleme mit roaming Profilen mit Windows 10 (4)

Frage von fox14ch zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Microsoft
Ordner mit LW-Buchstaben versehen und benennen (19)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...