Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Migration Server 2003 - Server 2008

Frage Microsoft Windows Server

Mitglied: fluluk

fluluk (Level 1) - Jetzt verbinden

17.12.2012 um 10:58 Uhr, 2100 Aufrufe, 8 Kommentare

Hallo,
Zunächst einmal ist mir bekannt, dass die Fehlermeldung die ich erhalte auch bei Google zu finden ist, allerdings hat keines der dort genannten Lösungsvorschläge bei mir funktioniert, bzw. habe ich dort teilweise nicht ganz durchgeblickt.

Folgendes Szenario:

wir haben zwei Domaincontroller mit Windows Server 2003, welche im native Mode 2003 betrieben werden.
zusätzlich dazu haben wir Vertrauensstellungen zu zwei weiteren Domänen, eine NT-Domäne und eine 2000 Domäne, diese können allerdings nicht abgeschaltet werden.

nun sollen die zwei Server 2003 Domaincontroller auf zwei Server 2008 (nicht SBS) Domaincontroller Migriert werden.


Da wir VMWare im einsatz haben, habe ich die maschinen natürlich zuerst kopiert um keinen größeren Schaden anzurichten.

1st DC:
Name: Server03
IP: 10.0.1.3

2nd DC:
Name: Server05
IP: 10.0.1.5

2008_1:
Name: Server01
IP: 10.0.1.1

2008_2:
Name Server02
IP: 10.0.1.2

angefangen habe ich mit adprep /forestprep auf dem primary Domaincontroller.
dies wurde auch Fehlerfrei beendet.

Laut einer Anleitung die ich im Internet gefunden habe sollte man dann adprep /domainprep /gpprep ausführen, allerdings bekomme ich schon bei /gpprep einige Fehlermeldungen.

Wenn ich auf ersten Server 2008 dcpromo ausführe um diesen in die Domäne zu integrieren erhalte ich folgende Fehlermelung:

Active Directory Domain Services Installation Wizard
DNS was successfully queried for the service location (SRV) resource record used
to locate a domain controller for domain "test.de":

The query was for the SRV record for _ldap._tcp.dc._msdcs.test.de

The following domain controllers were indentified by the query:
server03.test.de
server05.test.de


However no domain controllers could be contacted.

Common causes of this error include:

- Host (A) or (AAAA) records that map the names of the domain controllers to their IP
addresses are missing or contain incorrect addresses.

- Domain controllers registered in DNS are not connected to the Network or are not running.

die Maschinen sind beide anpingbar und wenn ich test.de anping erhalte ich auch eine Antwort von einer der DC.
Mitglied: Ausserwoeger
17.12.2012 um 11:29 Uhr
Hi hast du auf deinem Server03 im DNS nachgeschaut ob der Eintag vorhanden ist ?

Welche DNS einstellungen sind den auf dem Server auf dem du dcpromo ausführst eingestellt ? Ist der Server03 auf dem Server Primärer DNS Server ???

LG Andy
Bitte warten ..
Mitglied: fluluk
17.12.2012 um 11:37 Uhr
Hallo,

Danke für die schnelle Antwort,

auf dem Server auf dem ich dcpromo ausführe ist der Server03 (1st DC) als primärer DNS eingestellt. Wenn ich nslookup auf diesem Server ausführe erhalte ich folgende rückmeldung:

Server: server03.test.de
Address: 10.0.1.3

Name: test.de
Addresses: 10.0.1.3
10.0.1.5

Sieht alles richtig aus, ich werde trotzdem das gefühl nicht los, dass irgendetwas am DNS nicht stimmt.
Bitte warten ..
Mitglied: fluluk
17.12.2012 um 11:40 Uhr
Auf dem Server03 ist auch ein WINS konfiguriert, kann es evtl daran liegen?
Bitte warten ..
Mitglied: Ausserwoeger
17.12.2012, aktualisiert um 11:51 Uhr
Zitat von fluluk:
Auf dem Server03 ist auch ein WINS konfiguriert, kann es evtl daran liegen?

Eigendlich sollte er nur DNS verwenden.
Du kannst ihn ja testweise deaktivieren.

PS: Du hast auf jeden fall ein DNS problem. Wenn du den Fehler nicht lokalisieren kannst würde ich einfach den DNS Server löschen und neu erstellen. Allerdings musst du aufpassen da du mehrere DCs hast nehme ich an auch mehrere DNS Server. Du musst also alle neu machen damit dir der Alte DNS nicht den Fehler wieder in den neuen Repliziert

LG
Bitte warten ..
Mitglied: fluluk
17.12.2012 um 11:54 Uhr
Hat leider nicht geholfen.
Bitte warten ..
Mitglied: Ausserwoeger
17.12.2012, aktualisiert um 12:02 Uhr
Dann würd ich nicht lange suchen sondern einfach den DNS auf allen Maschinen neu machen.

Einfach auf allen DCs den DNS dienst Deinstallieren oder die Zonen löschen.
Dann auf dem Primären DNS(DC) die Zone neu stellen. Am besten AD integriert mit Dynamischen Updates zugelassen.
Dann musst du nur noch folgendes machen:
NET STOP NETLOGON && NET START NETLOGON
IPCONFIG /REGISTERDNS
Der DC registriert alle relevanten Einträge neu (eventuell ein wenig warten).

Dann auf dem zweiten DC den DNS wieder aktivieren und die neue Zone replizieren lassen.

PS: Vorher natürlich eine DOKU machen welche einträge manuell hinzugefügt wurden etc. damit du den ordentlich wiederherstellen kannst.

PSS: Sollte dir das zu viel arbeit sein kannst du auch versuchen den Ordner MSDCS im DNS zu löschen und mit IPCONFIG /REGISTERDNS neu erstellen zu lassen.

LG Andy
Bitte warten ..
Mitglied: fluluk
17.12.2012 um 12:12 Uhr
mir ist gerade aufgefallen, dass sich in der Testumgebung allgemein keine Maschinen mehr zur Dömäne hinzufügen lassen, in der Produktiven Domäne allerdings schon. Ich gehe davon aus, dass es evtl ein Problem beim Rückspielen der Sicherung von veeam gab, da die Maschine zu dem Zeitpunkt eingeschaltet war, als sie gesichert wurde. ich versuche jetzt mal die Maschine im ausgeschaltetem Zustand zu kopieren und teste es dann nochmal.
Bitte warten ..
Mitglied: fluluk
17.12.2012 um 13:30 Uhr
Der Fehler wurde gefunden, es lag an dem Backup von Veeam, da muss wohl irgend etwas kaputt gegangen sein, ich habe die Maschine jetzt mal Live kopiert und jetzt funktioniert es.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Server-Hardware
Dual CPU unter Server 2003 oder Server 2008 (4)

Frage von Usogul zum Thema Server-Hardware ...

Windows Server
gelöst Migration Windows Server 2003 auf 2012 "offline" möglich? (7)

Frage von Christtian zum Thema Windows Server ...

Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Exchange Server
gelöst Microsoft Excange Server 2007 auf Windows Server 2003 Installieren? (9)

Frage von Herbrich19 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...