Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Mikrotik und FritzBox Gastzugang

Frage Netzwerke Router & Routing

Mitglied: Tobi_

Tobi_ (Level 1) - Jetzt verbinden

28.10.2012, aktualisiert 21:09 Uhr, 4011 Aufrufe, 7 Kommentare

Ich möchte gerne den Fritzbox Gastzugang als Gateway für ein separates Subnet nutzen.

Hallo,

ich experimentiere mal wieder mit MikroTik und meiner FritzBox die per Gastzugang einem anderen Subnet Internet bereitstellen soll. Es hakt noch an mehreren Stellen, aber ich möchte erst mal klein anfangen.


WWW-----FritzBox7390-|-------- LAN 1-3
...................................|
...................................|-------- LAN 4 mit aktiviertem Gastzugang --- MikroTik eth1

So sieht mein Aufbau aus. Wenn ich direkt an LAN 4 meine Laptop hänge komme ich damit ins Internet. Ok nun hänge ich an Port 4 meinen MikroTik, er bezieht per DHCP die IP (192.168.179.21, gateway 192.168.179.1). Für alle weiteren Experimente möchte ich als erstes diese Verbindung verifizieren und starte einen Ping vom Mikrotik aus.

01.
 /ping google.de interface=ether1_fritzbox src-address=192.168.179.21 
02.
 
03.
HOST                                     SIZE TTL TIME  STATUS                    
04.
173.194.35.152                                          timeout                   
05.
173.194.35.152                                          timeout                   
06.
173.194.35.152                                          timeout                   
07.
173.194.35.152                                          timeout                   
08.
173.194.35.152                                          timeout                   
09.
    sent=5 received=0 packet-loss=100%  
10.
 
Wieso scheitere ich denn bereits hier? IMHO sollte sich dieses Interface vom Mikrotik doch wie ein Client(Laptop) verhalten?

Danke für die Hilfe!


Grüße Tobi
Mitglied: exchange
28.10.2012 um 23:38 Uhr
Hallo,
manchmal hilfreich ist die Konfiguration zu sehen. Dabei hilft Dir seit neustem (glaube ab 5.16) "/export compact".

Achso, Standardroute eigentlich vergeben (sollte eigentlich über DHCP gesetzt worden sein)? Tracert mal machen

Ich verstehe den Sinn nur nicht. Der Mikrotik hat eine eigene Möglichkeit einen Gastzugang bereitzustellen.

Gruß
Heiko
Bitte warten ..
Mitglied: aqui
29.10.2012, aktualisiert um 08:31 Uhr
Leider schreibst du mit keinem Wort WIE dein Mikrotik konfiguriert ist !
Sind die Ports am LAN4 als Switchports definiert ???
Routest du über den Mikrotik ???
Routest du über den Mikrotik mit NAT zur FB ???
usw. Wie sollen wir dir da eine fundierte Antwort geben wenn wir das nicht wissen ???

Wichtig ist (sofern du am MT routest) das du dort die Default Konfig abschaltest (die macht NAT) und transparent routest.
Wie das geht und weitere Infos dazu findest du hier:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Es sei denn du willst dediziert NAT auf dem Mikrotik lassen, dann kann die Default Konfig natürlich bleiben.
Wenn du transparent routest (ohne NAT) musst du logischerweise eine statische Route auf dein IP Netz am Mikrotik einstellen (siehe Tutorial), denn sonst weiss die FB ja nicht wo sie mit diesen IPs hinsoll und würde sie gen Provider routen (default Route !) wo sie dann verschwinden. Das ist dein derzeitiger Scheiterungsgrund !
Wenn du allerdings NAT am Mikrotik aktiv lässt, wird das dortige LAN dann auf die Mikrotik Portadresse umgesetzt und die FB "denkt" das sie dann aus ihrem LAN 4 kommen.
In so einem Szenario entfällt natürlich dann die Route, da die FB keine fremden Netze mehr "sieht".
Deine Beschreibung ist recht oberflächlich diesbezüglich, deshalb ist eine zielführende Hilfe fast nicht möglich ohne große Teile frei raten zu müssen
Ggf. helfen dir diese Tutorials noch weiter für eine sinnvolle Lösung:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
http://www.administrator.de/wissen/wlan-oder-lan-gastnetz-einrichten-mi ...
Nochwas zum Schluss: Router im Netzwerk sollten niemals IP Adressen dynamisch per DHCP bekommen sondern immer statische ! Das solltest du beim Mikrotik und auch der FB beachten !
Bitte warten ..
Mitglied: Tobi_
30.10.2012 um 23:28 Uhr
Sorry für die späte Antwort. Weiter unten seht ihr die Config. Ein paar unwichtige Sachen wurden rausgelassen.

Zu den Fragen:
- Nein LAN 4 ist nicht als Switchport definiert (Master Port = none)
- kein Nat zwischen Mikrotik und FB, nur FB hat NAT in Richtung Internet
- Ja Routing erledigt der Mikrotik
- Klar sollten Router immer eine feste IP haben, es war ja auch nur vorerst zu Testzwecken gedacht.

Grundsätzlich sollte doch der oben genannten Ping Befehl funktionieren da als Absender das vom Fritzbox DHCP versorgte Mikrotik Interface als source angegeben wird?! Wenn ich schon von hier nicht über den Gastport der FB ins Internet komme wann denn dann? Dort ist doch kein Routing mehr dazwischen....

01.
 
02.
# oct/30/2012 19:52:24 by RouterOS 5.21 
03.
# software id = X3PR-9NS0 
04.
05.
/interface ethernet 
06.
set 0 name=ether1_fritzbox 
07.
set 1 name=ether2_homenet 
08.
set 2 name=ether3_telekom 
09.
set 3 speed=1Gbps 
10.
set 4 comment="::: VLAN Trunk :::" name=ether5_trunk speed=1Gbps 
11.
/interface vlan 
12.
add interface=ether5_trunk l2mtu=1594 name=vlan100_ether5 vlan-id=100 
13.
add interface=ether5_trunk l2mtu=1594 name=vlan200_ether5 vlan-id=200 
14.
add interface=ether5_trunk l2mtu=1594 name=vlan1_ether5 vlan-id=1 
15.
/ip hotspot user profile 
16.
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m 
17.
/ip pool 
18.
add name=dhcp_pool_subnet192.168.128.0/24 ranges=\ 
19.
    192.168.128.111-192.168.128.133 
20.
add name=dhcp_pool_subnet192.168.0.0/24 ranges=192.168.0.111-192.168.0.133 
21.
add name=dhcp_pool_subnet10.0.128.0/24 ranges=10.0.128.111-10.0.128.133 
22.
add name=dhcp_pool_subnet10.0.192.0/24 ranges=10.0.192.111-10.0.192.133 
23.
/ip dhcp-server 
24.
add address-pool=dhcp_pool_subnet192.168.128.0/24 authoritative=yes disabled=\ 
25.
    no interface=ether3_telekom name=DHCP_192.168.128.0/24_TelekomDSL 
26.
add address-pool=dhcp_pool_subnet192.168.0.0/24 authoritative=yes disabled=no \ 
27.
    interface=ether2_homenet name=DHCP_192.168.0.0/24_DEFHeimnetz 
28.
add address-pool=dhcp_pool_subnet10.0.128.0/24 authoritative=yes disabled=no \ 
29.
    interface=vlan100_ether5 name=DHCP_10.0.128.0/24_flyingDEFGuest 
30.
add address-pool=dhcp_pool_subnet10.0.192.0/24 authoritative=yes disabled=no \ 
31.
    interface=vlan200_ether5 name=DHCP_10.0.192.0/24_ABCPV 
32.
/user group 
33.
add name=auto-upgrade policy="local,ftp,read,write,winbox,api,!telnet,!ssh,!re\ 
34.
    boot,!policy,!test,!password,!web,!sniff,!sensitive" 
35.
/ip address 
36.
add address=192.168.0.254/24 comment="DEF Home - K-Systems DSL" \ 
37.
    interface=ether2_homenet 
38.
add address=192.168.128.254/24 comment="DEF Test - Telekom DSL" interface=\ 
39.
    ether3_telekom 
40.
add address=10.0.128.254/24 comment="DEF GuestWLAN VLAN100" interface=\ 
41.
    vlan100_ether5 
42.
add address=10.0.192.254/24 comment="ABC PV" interface=vlan200_ether5 
43.
/ip dhcp-client 
44.
add add-default-route=no disabled=no interface=ether1_fritzbox use-peer-dns=\ 
45.
    no use-peer-ntp=no 
46.
/ip dhcp-server network 
47.
add address=10.0.128.0/24 comment="DEF GuestWLAN Subnet" dns-server=\ 
48.
    10.0.128.254 gateway=10.0.128.254 netmask=24 ntp-server=\ 
49.
    192.53.103.108,131.188.3.220 
50.
add address=10.0.192.0/24 comment="ABC PV Subnet" dns-server=10.0.192.254 \ 
51.
    gateway=10.0.192.254 netmask=24 ntp-server=192.53.103.108,130.149.220.70 
52.
add address=192.168.0.0/24 comment="K-online DSL Subnet - DEF Main" \ 
53.
    dns-server=192.168.0.254 gateway=192.168.0.254 netmask=24 ntp-server=\ 
54.
    192.53.103.108,131.188.3.220 
55.
add address=192.168.128.0/24 comment="Telekom DSL Subnet" dns-server=\ 
56.
    192.168.128.254 gateway=192.168.128.254 netmask=24 ntp-server=\ 
57.
    192.53.103.108,131.188.3.220 
58.
/ip dns 
59.
set allow-remote-requests=yes servers=\ 
60.
    85.88.19.10,87.118.100.175,217.79.186.148,208.67.220.220 
61.
/ip firewall address-list 
62.
add address=192.168.128.0/24 list=local-addresses 
63.
add address=192.168.0.0/24 list=local-addresses 
64.
add address=10.0.192.0/24 list=local-addresses 
65.
add address=10.0.128.0/24 list=local-addresses 
66.
/ip firewall mangle 
67.
add chain=prerouting dst-address-list=local-addresses dst-address-type="" \ 
68.
    fragment=no 
69.
add action=mark-routing chain=prerouting new-routing-mark=WANTelekom \ 
70.
    src-address=192.168.128.0/24 
71.
add action=mark-routing chain=prerouting new-routing-mark=fromABCPV \ 
72.
    src-address=10.0.192.0/24 
73.
add action=mark-routing chain=prerouting disabled=yes new-routing-mark=\ 
74.
    fromflyingDEFGuest src-address=10.0.128.0/24 
75.
/ip neighbor discovery 
76.
set vlan100_ether5 disabled=yes 
77.
set vlan200_ether5 disabled=yes 
78.
set vlan1_ether5 disabled=yes 
79.
/ip route 
80.
add check-gateway=ping distance=1 gateway=192.168.128.240 routing-mark=\ 
81.
    WANTelekom 
82.
add comment="### \"ABC PV\" Internet over FritzBox \"Gastzugang\" ###" \ 
83.
    distance=1 gateway=192.168.179.1 routing-mark=fromABCPV 
84.
add check-gateway=ping comment=\ 
85.
    "### \"flyingDEFGuest\"Internet over FritzBox \"Gastzugang\" ###" \ 
86.
    disabled=yes distance=1 gateway=192.168.179.1 routing-mark=\ 
87.
    fromflyingDEFGuest 
88.
add check-gateway=ping comment="### DEFAULT: Internet over K-Online ###" \ 
89.
    distance=1 gateway=192.168.0.240 
90.
add check-gateway=ping comment=\ 
91.
    "### DEFAULT: Internet over Telekom FAILOVER ###" distance=5 gateway=\ 
92.
    192.168.128.240 
93.
add check-gateway=ping comment="### DEFAULT: Internet over FB Guest port ###" \ 
94.
    distance=10 gateway=192.168.179.1 
95.
 
96.
 
97.
 
Bitte warten ..
Mitglied: exchange
30.10.2012 um 23:41 Uhr
Hallo,
ich bin mir nicht sicher ob die Mangel Regel an dem Punkt greifen. Es geschieht ja bei deinem Ping kein routing über den Router ;) Wärend der Ping läuft, laufen die Zähler hoch?

Mach mal eine normale Standardroute rein, ping mal was an. Wenn es geht, löschen und einmal eine Route kopieren und bei der Chain output wählen. Dann gehen die Clients nicht mehr aber der Router müsste gehen.

Der Mikrotik Router müsste den oben abgesetzten ping von sich selbst aus unter output packen.


Ich hoffe, ich habe nichts übersehen ... Gute Nacht...
Bitte warten ..
Mitglied: aqui
31.10.2012 um 18:46 Uhr
Setze den Mikrotik auf die Factory Defaults und schalte die Default Konfig ab !! Damit macht der kein NAT und routet transparent ohne Filter.
Statische Route auf der FB nicht vergessen und dann funktioniert das auch auf Anhieb !
Bitte warten ..
Mitglied: Tobi_
03.11.2012 um 19:23 Uhr
Hallo,

es funktioniert mittlerweile. Factory defaults wurden bereits verwendet! Ich denke es lag an einer nich aktiven Route, anders kann ich mir das nicht erklären....
Rückrouten sind auch gesetzt per Telnet in der FB.

Danke nochmal. Sollten später Probleme auftreten werde ich den Thread wieder aktivieren.
Bitte warten ..
Mitglied: aqui
04.11.2012 um 15:40 Uhr
Das "Vergessen" der statischen Route bei Routing ohne NAT ist ein Klassiker des Vergessens hier
Gut wenn alles nun klappt !
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Router & Routing
gelöst Fritzbox AP: Gastzugang ohne Internet bei Nicht-AVM-Routern (17)

Frage von Uwoerl zum Thema Router & Routing ...

Router & Routing
gelöst Aus Gastzugang (Fritzbox) VPN Verbdindung nach Hause aufbaue (5)

Frage von duffy6 zum Thema Router & Routing ...

Voice over IP
gelöst FritzBox 7490 hinter Mikrotik Routerboard NAT, kein VoiIP (18)

Frage von toby97897 zum Thema Voice over IP ...

Router & Routing
FritzBox WLAN Gastzugang - Nutzungsbedingungen bearbeiten? (4)

Frage von tarek13 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...