Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

MIKROTIK-ROUTER- QOS-Optimierung für Spiele

Frage Netzwerke Netzwerkmanagement

Mitglied: cmoegele

cmoegele (Level 1) - Jetzt verbinden

03.07.2012, aktualisiert 04.07.2012, 4212 Aufrufe, 3 Kommentare

Hallo NetzwerkPros,

habe mir auf Empfehlung mal ein RB450G besorgt und versucht in unserem kleinen Vereinsnetzwerk (zur Zeit 15 Leute an einer 2Mb SDSL Standleitung ) ein QOS mittels PCQ ( laut Wiki/Foren/Tipps ) zu konfigurieren um vernünftig Online Spiele zocken zu können ( speziell FPS wie Quakelive, Warsow,... ).
Allerdings haben wir nach wie vor Probleme mit Ping / Latenzen bzw. verlorene Frames im Spiel sobald ein bisschen Traffic über das Routerboard geht.
Das Routerboard ist als Bridge konfiguriert ( ether1 -> SDSL; ether5 -> zum Accesspoint für die jeweiligen User ) Wobei jeder eine statische IP von der Telekom zugeordnet bekommen hat.

Das QOS im Mikrotik RB450G ist folgendermaßen konfiguriert:


/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s comment="zum Internet" \
disabled=no limit-at=2M max-limit=2M name=queue1 packet-mark=no-mark \
parent=ether1 priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s comment="zu ether5" \
disabled=no limit-at=2M max-limit=2M name=queue6 packet-mark=no-mark \
parent=ether5 priority=8

/queue type
set 0 kind=pfifo name=default pfifo-limit=50
set 1 kind=pfifo name=ethernet-default pfifo-limit=50
set 2 kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=5
set 3 kind=red name=synchronous-default red-avg-packet=1000 red-burst=20 \
red-limit=60 red-max-threshold=50 red-min-threshold=10
set 4 kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=5

add kind=pcq name=PCQ pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=\
10s pcq-classifier=src-address,dst-address pcq-dst-address-mask=32 \
pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 \
pcq-src-address6-mask=64 pcq-total-limit=2000
add kind=pcq name=pcq-upload-default pcq-burst-rate=0 pcq-burst-threshold=0 \
pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 \
pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 \
pcq-src-address6-mask=128 pcq-total-limit=2000
add kind=pcq name=pcq-download-default pcq-burst-rate=0 pcq-burst-threshold=0 \
pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 \
pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 \
pcq-src-address6-mask=128 pcq-total-limit=2000
set 8 kind=none name=only-hardware-queue
set 9 kind=mq-pfifo mq-pfifo-limit=50 name=multi-queue-ethernet-default
set 10 kind=pfifo name=default-small pfifo-limit=10

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name=queue2 packet-mark=icmp parent=queue1 priority=2 queue=\
default
add burst-limit=1900k burst-threshold=0 burst-time=10s disabled=no limit-at=\
1600k max-limit=1700k name=queue3 packet-mark=quakelive parent=queue1 \
priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M \
max-limit=1700k name=queue4 packet-mark=clients parent=queue1 priority=6 \
queue=pcq-upload-default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=256 name=queue5 packet-mark=p2p parent=queue1 priority=8 queue=\
default
add burst-limit=1900k burst-threshold=0 burst-time=10s disabled=no limit-at=\
1600k max-limit=1700k name=queue8 packet-mark=quakelive parent=queue6 \
priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M \
max-limit=1700k name=queue9 packet-mark=clients parent=queue6 priority=6 \
queue=pcq-download-default



/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
tcp-close-wait-timeout=10s tcp-established-timeout=1d \
tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s

/ip firewall filter
add action=passthrough chain=output disabled=yes packet-mark=icmp protocol=\
icmp

/ip firewall mangle
add action=mark-packet chain=prerouting comment=\
"Traffic alle Clients inbound" disabled=no dst-address=212.xxx.xxx.xxx/xx \
new-packet-mark=clients passthrough=yes src-address=0.0.0.0/0
add action=mark-packet chain=prerouting comment=\
"Traffic alle Clients outbound" disabled=no dst-address=0.0.0.0/0 \
new-packet-mark=clients passthrough=yes src-address=212.xxx.xxx.xxx/xx
add action=mark-packet chain=prerouting comment="ICMP markieren" disabled=no \
new-packet-mark=icmp passthrough=yes protocol=icmp
add action=mark-packet chain=prerouting comment=\
"Quakelive TCP markieren inbound" disabled=no dst-port=5222 \
new-packet-mark=quakelive passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting comment=\
"Quakelive TCP markieren outbound" disabled=no new-packet-mark=quakelive \
passthrough=yes protocol=tcp src-port=5222
add action=mark-packet chain=prerouting comment=\
"Quakelive UDP markieren inbound" disabled=no dst-port=27000-27100 \
new-packet-mark=quakelive passthrough=yes protocol=udp
add action=mark-packet chain=prerouting comment=\
"Quakelive UDP markieren outbound" disabled=no new-packet-mark=quakelive \
passthrough=yes protocol=udp src-port=27000-27100
add action=mark-packet chain=prerouting comment="P2P Traffic markieren" \
disabled=no new-packet-mark=p2p p2p=all-p2p passthrough=yes


Hauptsächlich dafür ausgelegt Quakelive ( Prio 1 TCP=5222 und UDP= 27000-27100 ) zu prioriseren.
PCQ-Upload und Download funktioniert sehr gut, es wird gleichmäßig die Bandbreite auf die IPs aufgeteilt und selbst bei voller Auslastung der verfügbaren Bandbreite hat man eine gute "Browsinggeschwindigkeit".
Aber trotzdem habe ich schon bei leichtem Traffic massive Pingschwankung und üble Frame drops. Das ist bei solchen Spielen natürlich tödlich,..´. Das Routerboard hat aber selbst bei hohem Traffic nur 10-12% Last.

Selber mache ich die ganze Administration für unseren Verein ja auch nur ehrenamtlich und hab eigentlich von Netzwerk nur ein gewisses Basiswissen ( leider auch der einzige in unserem Verwandschafts-/Freundschafts-/Bekanntschaftskreis ),..., was tut man nicht alles fürs zocken
Hat jemand Idee was man verbessern könnte? Vielleicht ist das RB450G auch nicht dafür geeignet, . Oder ist es gar der komplett verkehrte Ansatz.
Für jeden Tipp bzw. Hilfe wäre ich dankbar

Vg

Chris
Mitglied: Pjordorf
03.07.2012 um 19:51 Uhr
Hallo,

Zitat von cmoegele:
Findust du dein vorgehen hier richtig?
Kein hallo oder so
Haust hier 371 Zeilen ohne Formtierung rein (Die relevanten Zeilen reichen vollkommen)
Erwartest das andere deine fehler suchen
Keine hinweise was du warum in deinem script(e) tust
Keine erläuterung wie dein Netz aufgebaut sein soll / ist dafür aber jede menge unterschiedlichste IPs

VG
Peter
Bitte warten ..
Mitglied: cmoegele
03.07.2012 um 23:55 Uhr
Hallo Peter,

Du hast natürlich recht, dass ich so wenig mitgedacht habe.
Werde die Frage nochmal umgestalten.

vg

Chris
Bitte warten ..
Mitglied: cmoegele
09.07.2012 um 18:08 Uhr
keiner ne Idee wie man den Spiele Ping stabil bekommt ?
Bitte warten ..
Ähnliche Inhalte
Netzwerkmanagement
Einfacher Router mit QOS gesucht
gelöst Frage von SPAGHETTINetzwerkmanagement14 Kommentare

Hallo Zusammen, ich suche ein Router bei dem sich grafisch relativ einfach, sämtliche QOS Regeln und VLAN Einstellungen, einstellen ...

Router & Routing
Mikrotik Router und OpenVPN
Frage von Wild-WolfRouter & Routing

Hallo Leute. hänge gerade an einem Problem. Wir haben einen Mikrotik Router auf dem OpenVPN eingerichtet werden soll. Die ...

Router & Routing
Mikrotik Router hinter Firtzbox
Frage von dawdadRouter & Routing3 Kommentare

Moin, ich hätte eine Frage zur Netzwerk Konfiguration eines Mikrotik Routers. Ich nutze eine Fritz box um mich mit ...

Router & Routing
Mikrotik Router in Netzwerk einbinden
gelöst Frage von CyberurmelRouter & Routing9 Kommentare

Hi all, würde gern in bestehendes Netz ein Mikrotik Router zusätzlich für die WLAN Komponenten einbinden. (Portal Captive ggfs ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 1 TagWindows 107 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 2 TagenInternet5 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 2 TagenDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Batch & Shell
Kann man mit einer .txt Datei eine .bat Datei öffnen?
Frage von HelloWorldBatch & Shell18 Kommentare

Wie schon im Titel beschrieben würde ich gerne durch einfaches klicken auf eine Text oder Word Datei eine Batch ...

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...

Windows Server
Ping auf einen bestimmten Server nicht möglich
gelöst Frage von a.thierWindows Server7 Kommentare

Hallo, ich habe folgendes Problem. srv-dc1: Ping srv-nav > geht Ping srv-exchange > geht nicht srv-exchange: Ping srv-dc1 > ...

Windows 10
Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App
Tipp von kgbornWindows 107 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...