Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

mod disk cache unter apache 2.0.50 läuft nicht

Frage Linux Apache Server

Mitglied: MartinSchmid

MartinSchmid (Level 1) - Jetzt verbinden

12.02.2007, aktualisiert 14.02.2007, 5006 Aufrufe, 1 Kommentar

Ich habe einen Apache 2.0.50 unter Suse 9.2 am laufen, will nicht auf 2.2.x updaten, weil der Rest funktioniert gut.
Mittels ProxyPass greife ich nun auf eine externe Site zu, das funktioniert auch reibungslos. Da ich den Zugriff beschleunigen und den Datentransfer reduzieren möchte, benutze ich die Cache-Module von Apache.

Ich habe schon gesehen dass die Cache-Module bei der 2.0.x-Version sehr experimentell waren, aber es sollte ja trotzdem funktionieren.

Gleich zum Problem: Jede Anfrage an den internen Server, geht nach aussen; somit findet kein Caching statt. Der Inhalt wird aber dann richtig am Browser angezeigt.

Konfiguration: (Die Module mod_cache, mod_disk_cache und mod_mem_cache werden geladen)
<VirtualHost *:80>
DocumentRoot "/var/srv/www/htdocs"
ServerName www.server.tld:80

Verhindert das komprimieren der HTTP-Responses, falls der Client das unterstützen sollte (der Server tut das).
RequestHeader unset Accept-Encoding

ProxyPreserveHost On
ProxyPass /content http://extern.server.tld/content

CacheEnable disk /
das Verzeichnis existiert mit 770@wwwrun/www, es werden auch entsprechende Verzeichnisse/Dateien von Apache angelegt.
CacheRoot /tmp/apache_proxy_cache
</VirtualHost>

Also es werden Daten im Cache-Verzeichnis abgelegt, aber jede Anfrage wird durchgereicht. Ich habe mit wireshark die Requests geprüft, die sind immer gleich. Getestet habe ich das mit FF und IE, mit dem gleichen Ergebnis.

Ich habe auch verschiedene externe Server probiert (z.B.: ProxyPass / http://www.google.de/).
Vielleicht kennt jemand das Problem, sowie die Lösung dazu.

Mit bestem Dank im voraus.
mfg Martin
Mitglied: MartinSchmid
14.02.2007 um 09:01 Uhr
Ergänzungsfragen:

- Setzt jemand erfolgreich die caching-Module von Apache ein?
- Hat wer Erfahrung mit der Version 2.0.x?

mfg Martin
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Administrator.de Feedback

Umgangsformen auf der Seite

(7)

Information von Frank zum Thema Administrator.de Feedback ...

Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(11)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst Dir tc Befehl unter Windows 10 macht Probleme (14)

Frage von sugram zum Thema Batch & Shell ...

Windows Server
Windows Server Komplettspiegelung (13)

Frage von pdiddo zum Thema Windows Server ...

Windows Server
Windows Server 2016 RDS Remoteapp Anzeigefehler (11)

Frage von qlnGenius zum Thema Windows Server ...