Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Mod rewrite übergibt kein Parameter

Frage Entwicklung Webentwicklung

Mitglied: EvilMoe

EvilMoe (Level 2) - Jetzt verbinden

07.10.2012, aktualisiert 18:02 Uhr, 4896 Aufrufe, 4 Kommentare

Guten Tag,

ich habe eine Problem mit einer rewrite Regel. Die Funktioniert auf meinen Testsystem(Windows, XAMPP) wunderbar. Auf meinen Server (Debian 6, Apache2, PHP5.3) dagegen nicht.
Das komische, die rewrite Regel Funktioniert zwar, allerdings wird der Parameter nicht übergeben.

01.
RewriteRule   ^bild\/(.*)\.jpg$ bild.php?query=$1 [L,NC]
Rufe ich nun eine URL auf wie bild/ichbineinbild.jpg komme ich zur bild.php aber $_GET ist vollkommen leer. Woran liegt das?


Sven
Mitglied: Dani
07.10.2012 um 22:04 Uhr
Moin,
andere Regeln funktionieren?
Hast du mal die Apache-Konfiguration verglichen?


Grüße,
Dani
Bitte warten ..
Mitglied: EvilMoe
07.10.2012 um 22:09 Uhr
Moin,

die anderen Regeln funktionieren wunderbar. Sind zwar nur 3 einfache aber da gibt es keine Probleme.

Wo sollte ich bei der Konfig anfangen?


Sven
Bitte warten ..
Mitglied: Dani
07.10.2012 um 22:15 Uhr
Naja, ich würde die ganze XAMPP Konfiguration auf das Linuxsystem laden und mit "diff" schauen, wo der Unterschied ist. Unter Windows wäre das auch mit Notepad++ möglich.

Umständlicher wird's wenn die Debian Apachekonfiguration nicht in einer Datei ist sondern verteilt auf Mehrere.


Grüße,
Dani
Bitte warten ..
Mitglied: EvilMoe
07.10.2012, aktualisiert um 22:25 Uhr
Umständlicher wird's wenn die Debian Apachekonfiguration nicht in einer Datei ist sondern verteilt auf Mehrere.


Auf dem Server habe Easyscp zur Verwaltung installiert. Die wird sich schon deutlich durch mein XAMPP unterscheiden.

Aber ich konnte es eben schon eingrenzen an welcher Zeile es liegt:
01.
 Options -Indexes Includes FollowSymLinks MultiViews
Wenn ich das auskommentiere läuft es. Nur wie kommt denn so etwas? Ne Idee?


EDIT: MultiViews ist schuld. Kann ich aber noch nicht nachvollziehen warum das so ist.



EDIT2: Habe was dazu gefunden: http://www.gerd-riesselmann.net/archives/2005/04/beware-of-apaches-mult ...
Sehr interessant.
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Server 2012 rdweb .rdp Parameter (1)

Frage von bGn zum Thema Windows Server ...

VB for Applications
Daten eines einzelnen Tabellenblatt als Mail versenden (kein Dateianhang) (9)

Frage von Zentralenteufel zum Thema VB for Applications ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (25)

Frage von aschmid zum Thema Router & Routing ...

Windows 10
Windows 10 S: Nur Apps aber kein Linux (3)

Link von BassFishFox zum Thema Windows 10 ...

Neue Wissensbeiträge
Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(38)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
POS Hardware und alternativen zu Raid 1? (21)

Frage von Brotkasten zum Thema Festplatten, SSD, Raid ...

Viren und Trojaner
Verschlüsselungstrojaner simulieren (18)

Frage von AlbertMinrich zum Thema Viren und Trojaner ...

Exchange Server
Exchange Postfach leeren - nicht löschen (9)

Frage von AndreasOC zum Thema Exchange Server ...

Ubuntu
Nextcloud 12 Antivirus App for Files (8)

Frage von horstvogel zum Thema Ubuntu ...