Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Mod rewrite übergibt kein Parameter

Frage Entwicklung Webentwicklung

Mitglied: EvilMoe

EvilMoe (Level 2) - Jetzt verbinden

07.10.2012, aktualisiert 18:02 Uhr, 4917 Aufrufe, 4 Kommentare

Guten Tag,

ich habe eine Problem mit einer rewrite Regel. Die Funktioniert auf meinen Testsystem(Windows, XAMPP) wunderbar. Auf meinen Server (Debian 6, Apache2, PHP5.3) dagegen nicht.
Das komische, die rewrite Regel Funktioniert zwar, allerdings wird der Parameter nicht übergeben.

01.
RewriteRule   ^bild\/(.*)\.jpg$ bild.php?query=$1 [L,NC]
Rufe ich nun eine URL auf wie bild/ichbineinbild.jpg komme ich zur bild.php aber $_GET ist vollkommen leer. Woran liegt das?


Sven
Mitglied: Dani
07.10.2012 um 22:04 Uhr
Moin,
andere Regeln funktionieren?
Hast du mal die Apache-Konfiguration verglichen?


Grüße,
Dani
Bitte warten ..
Mitglied: EvilMoe
07.10.2012 um 22:09 Uhr
Moin,

die anderen Regeln funktionieren wunderbar. Sind zwar nur 3 einfache aber da gibt es keine Probleme.

Wo sollte ich bei der Konfig anfangen?


Sven
Bitte warten ..
Mitglied: Dani
07.10.2012 um 22:15 Uhr
Naja, ich würde die ganze XAMPP Konfiguration auf das Linuxsystem laden und mit "diff" schauen, wo der Unterschied ist. Unter Windows wäre das auch mit Notepad++ möglich.

Umständlicher wird's wenn die Debian Apachekonfiguration nicht in einer Datei ist sondern verteilt auf Mehrere.


Grüße,
Dani
Bitte warten ..
Mitglied: EvilMoe
07.10.2012, aktualisiert um 22:25 Uhr
Umständlicher wird's wenn die Debian Apachekonfiguration nicht in einer Datei ist sondern verteilt auf Mehrere.


Auf dem Server habe Easyscp zur Verwaltung installiert. Die wird sich schon deutlich durch mein XAMPP unterscheiden.

Aber ich konnte es eben schon eingrenzen an welcher Zeile es liegt:
01.
 Options -Indexes Includes FollowSymLinks MultiViews
Wenn ich das auskommentiere läuft es. Nur wie kommt denn so etwas? Ne Idee?


EDIT: MultiViews ist schuld. Kann ich aber noch nicht nachvollziehen warum das so ist.



EDIT2: Habe was dazu gefunden: http://www.gerd-riesselmann.net/archives/2005/04/beware-of-apaches-mult ...
Sehr interessant.
Bitte warten ..
Ähnliche Inhalte
Windows Update
WPP übergibt keine Updates an WSUS (4)

Frage von FFSephiroth zum Thema Windows Update ...

Apache Server
gelöst Rewrite mit falschem Ordner (1)

Frage von rawb1t zum Thema Apache Server ...

XML
gelöst XSLT Datei übergibt mir keine Dateninhalte (4)

Frage von usenussi zum Thema XML ...

Batch & Shell
gelöst New-ADUser (optional Parameter) (13)

Frage von mc-doubleyou zum Thema Batch & Shell ...

Neue Wissensbeiträge
Sicherheit

Millionen Euro in den Sand gesetzt?

Information von transocean zum Thema Sicherheit ...

Sicherheit

How I hacked hundreds of companies through their helpdesk

Information von SeaStorm zum Thema Sicherheit ...

Erkennung und -Abwehr

Ccleaner-Angriff war nur auf große Unternehmen gemünzt

(10)

Information von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Heiß diskutierte Inhalte
Humor (lol)
gelöst Freidach Beitrag (40)

Frage von Penny.Cilin zum Thema Humor (lol) ...

Windows 7
gelöst SSD - Win7 Lags (20)

Frage von ph5555 zum Thema Windows 7 ...

Firewall
gelöst Firewall Firmeneimsatz (19)

Frage von wiesi200 zum Thema Firewall ...