Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Mounten einer Partition unter Xen nicht möglich?

Frage Linux

Mitglied: gutitm

gutitm (Level 1) - Jetzt verbinden

24.08.2009, aktualisiert 13:48 Uhr, 4074 Aufrufe, 1 Kommentar

Hi,

wir besitzen hier eine exteren Fesplatte die in eine DomU eingebunden ist. Sie ist in der

domu.cfg physikalisch eingebunden:

"phy:/dev/disk/by-uuid/e1212324-4756-aaf0-8890be9606c0,sda4,w"

und die DomU ist gestartet. Gleichzeitig ist sie in der DomU gemounted.

Nun hat diese Harddisk Probleme gemacht und ich wollte sie abklemmen zwecks SMART-Fehlerdiagnose (geht ja nicht per USB). Also habe ich sie in der DomU ausgehängt und untersucht.

Nun bekomme ich sie nicht mehr eingehängt. Er meldet immer "wrong fs type" obwohl mit ext3 alles in Ordnung geht. Ohne Angabe kommt immer "you have to specify the fs type"

Kann es sein, dass man erst wieder die virtuelle DomU starten muss? Reicht ein Aushängen in der DomU nicht und ich habe das System "verwirrt" mit dem Entfernen des externen Laufwerksgehäuse?

Grüße gutitm
Mitglied: gutitm
24.08.2009 um 16:27 Uhr
Ok, habs herausgefunden....eine in einer DomU gemountete Partition muss nach dem Aushängen auch in der Domu aus der Domäne entfernt werden...dies geht mit dem Befehl.

xm block-deattach <domu> <partition auf domu>

Dann kann die Partition andersweitig genutzt werden. Hinzufügen geht wieder mit.

xm block-attach <domu> <phy://dev/XYZ sdX w>
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Heiß diskutierte Inhalte
Viren und Trojaner
gelöst Wie werde ich den Mist "fanli90" wieder los? (18)

Frage von Taumel zum Thema Viren und Trojaner ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (16)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...

Exchange Server
gelöst Exchange 2013 - Kontakte aus CSV importieren (9)

Frage von hesper zum Thema Exchange Server ...