Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

MS Outlook 2003 und Authentifizierung vor dem Senden zu Postfix

Frage Internet E-Mail

Mitglied: priez

priez (Level 1) - Jetzt verbinden

16.04.2008, aktualisiert 10.05.2008, 6712 Aufrufe, 2 Kommentare

MS Outlook 2003 sendet ein XXXX als ersten SMTP Befehl bei der Verbindung. Danach ein HELO und dann überspringt es einfach das AUTH.

Hi,

Outlook 2003 zu postfix 2.3.8. Client hinter einem 0815 Router. Postfix ist konfiguriert und erwartet ein AUTH vor dem Senden. Da das aber nicht kommt bekommt der Client einen "RELAY ACCESS denied" Fehler.

Mal die verkürzte Form des SMTP Verkehrs in eigenen Worten:
1. Outlook sendet ein XXXX <ClientPCName>
2. Postfix gibt ein 502 Befehl unbekannt.
3. Outlook sendet ein HELO <ClientPCName>
4. Postfix gibt ein 250 OK.
5. Outlook sendet ein MAIL FROM: <email>


ABER anstatt dem 5. Schritt sollte ein AUTH angefordert werden. Im Outlook ist "Postausgangsserver erfordert Authentifizierung" aktiviert mit korrekten Logindaten etc. Mich wundert, das nur ein HELO kommt und kein EHLO.

Ich schätze das Problem ist nur auf Client zu lösen, aber mich würde eine Lösung am Postfix eher reizen, da ich >1000 Emailclients im Einsatz habe und nicht allen hinterherpatchen kann falls was nicht funktioniert.

Weitere Infos:
- Postfix-config ist erprobt und funktioniert mit allen gängigen Clients normal.
- mit einer anderen Outlook2k3 Installation (anderer PC) und gleichen Logindaten funktioniert es.
- mit Thunderbird auf dem Problemclient und gleichen Daten geht es. Aber es MUSS ja outlook2k3 sein.
- Habe noch mit einer älteren Postfix Version und dem Client getestet. Es ist das gleiche Problem.
- Nach 4 Stunden alles mögliche Lesen frage ich jetzt einfach mal.


Ich habe schon alles serverseitige ausprobiert und suche hier direkt nach einer Serverlösung.
ODER
Nach einer einfachen Möglichkeit Outlook 2003 beizubringen sich mit EHLO zu melden, damit er die Servereinstellungen kennt. HAbe selbst gesucht und nichts in den Einstellungen gefunden.


Danke schon einmal für evtl. Antworten.

René
Mitglied: priez
10.05.2008 um 21:42 Uhr
hi,

das Problem war eine Filterung irgendeiner FW zwischen Client und postfix. Habe einfach postfix auch an 587 horchen lassen und den client umgestellt. Das hat die FW dann nicht umgeschrieben.

mfg

René
Bitte warten ..
Mitglied: priez
10.02.2009 um 22:15 Uhr
Hi,

noch eine Anmerkung. Das XXXX <Client-PC-Name> war durch die Firewall forciert. Die hat aus dem "EHLO" einfach "XXXX" gemacht.

Warum das passiert ist mir und dem Kunden unklar. Also sollte jemand ein ähnliches Problem haben hilft ein hochsetzen des debug levels im Postfix (setzt nebenbei soft_bounce aktiv in der main.cf) So geht keine Email verloren.

Mit hohen Debuglevel seht ihr die gesamte Session im Log. Vorsicht. Nicht bei mehr als 2000 Anfragen pro Minute einfach so den debug erhöhen..., sonst könnte Euer System etwas lahm werden. Das Debug am besten direkt am Tel einschalten, den Kunden zur Aktion auffordern und wieder den Debuglevel zurücksetzen.

mfg

René
Bitte warten ..
Ähnliche Inhalte
Outlook & Mail
Outlook 2003 druckt auf falschem Drucker (4)

Frage von achklein zum Thema Outlook & Mail ...

Outlook & Mail
gelöst Outlook 2013 automatisches Senden und Empfangen via GPO oder REGEDIT (3)

Frage von adm2015 zum Thema Outlook & Mail ...

Exchange Server
Outlook 2003 öffentlicher kalender kopieren exchange (9)

Frage von jensgebken zum Thema Exchange Server ...

Outlook & Mail
Kein Mailversand mit Outlook 2003 (15)

Frage von gjhammes zum Thema Outlook & Mail ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(1)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Router & Routing

PfSense auf Supermicro Intel Xeon D-15x8 SoC Bare Bone

Tipp von Dobby zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows 10
Windows für Privatanwender "nicht mehr handhabbar" (26)

Frage von FA-jka zum Thema Windows 10 ...

LAN, WAN, Wireless
Brauche Hilfe: Mit (schnellem) WLAN Strecke überbrücken (23)

Frage von pierrehansen zum Thema LAN, WAN, Wireless ...

Basic
Programmierung von Windows Programmen (10)

Frage von Ghost108 zum Thema Basic ...