Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

MS Server 2k12R2 Failover-Cluster node-switch Problem

Frage Microsoft Windows Server

Mitglied: meTzla

meTzla (Level 1) - Jetzt verbinden

28.01.2015, aktualisiert 16:41 Uhr, 781 Aufrufe, 10 Kommentare

Hallo zusammen,

in meinem Szenario; Failover-Cluster mit zwei nodes, habe ich folgendes Problem:

Wenn ich die sekundäre Instanz abschalte ist mein Cluster-Knoten nicht mehr erreichbar.
Wieso das nicht klappt will einfach nicht in meinen Kopf, denn wenn ich die primäre Instanz abschalte wird sauber auf die sekundäre Instanz umgelenkt.

Das Szenario ist wie folgt aufgebaut:

DC01 (AD DS)
SQL01 (Primär)
SQL02 (Secondary)
W7 (für Client-Connections)

Angebunden sind die Server jeweils über zwei bonds in zwei verschiedenen Subnetzen.

Mein Test sah wie folgt aus:
- Tracert auf den Cluster-Knoten, dann abschalten von SQL01 -> Tracert läuft weiter, ich sehe auch im Failover-Cluster-Manager, dass die Instanz als "offline" gemeldet wird und SQL02 nun als Besitzerknoten eingetragen ist.

Danach wieder alles auf "Startzustand".

- Tracert auf den Cluster-Knoten, dann abschalten von SQL02 -> Tracert endet in Zeitüberschreitungen, im Failover-Cluster-Manager steht weiterhin SQL01 als Besitzerknoten doch die Verbindung zum Knoten kann nicht aufgebaut werden und das egal von welchem der oben genannten Server.

Fällt euch irgend etwas zu dem Thema ein? Ich bin mehr als ratlos!

LG,
meTzla
Mitglied: emeriks
28.01.2015 um 19:08 Uhr
Hi,
mach mal den selben Test, während von dem SQL01 ein Dauerping auf sein Gateway läuft. Ändert das was?

Wie sind die Server überhaupt verkabelt? Logisch wie physisch? Am selben Switch?
Netzwerkkonfiguration der beiden Kisten sind analog? (u.a. auch Protokollreihenfolge, FW-Konfiguration usw.)

Das Vershieben der Instanz zwischen den Knoten geht hin wie her problemlos? Die Clients können anschließend sofort wieder verbinden?

E.
Bitte warten ..
Mitglied: Dani
28.01.2015 um 20:09 Uhr
Guten Abend,
was ich nicht verstehe, die SQL-Server stehen einzeln gesehen in zwei verschiedene Subnetze. In welchen Netz befindet sich dann die virtuelle IP-Adresse des Clusters?


Gruß,
Dani
Bitte warten ..
Mitglied: emeriks
28.01.2015 um 20:20 Uhr
Zitat von Dani:

Guten Abend,
was ich nicht verstehe, die SQL-Server stehen einzeln gesehen in zwei verschiedene Subnetze.
Kannst Du hellsehen oder woraus schlussfolgerst Du das?

E.
Bitte warten ..
Mitglied: Dani
28.01.2015 um 21:06 Uhr
@emerkis
Irgendwie falsch gelesen...
Angebunden sind die Server jeweils über zwei bonds in zwei verschiedenen Subnetzen.
Aber es könnte trotzdem daran liegen...


Gruß,
Dani
Bitte warten ..
Mitglied: meTzla
29.01.2015 um 09:39 Uhr
Hey zusammen,
danke für eure Antworten.
Ich versuche die Fragen so gut wie möglich aufzuklären, wenn nicht hakt bitte nach

Cluster: 172.22.1.110/24 & 172.22.2.110/24
DC01: 172.22.1.100/24 & 172.22.2.100/24
SQL01: 172.22.1.101/24 & 172.22.2.101/24
W7: 172.22.1.102/24
SQL01: 172.22.1.103/24 & 172.22.2.103/24

Somit stehen alle Server, außer der W7 Kiste, in zwei Subnetzen. An Protokollreihenfolgen und der gleichen habe ich nichts verändert, somit sollten sie analog konfiguriert sein. Auf was genau zielst Du ab?

Die Server sind aktuell VM's in unserer Citrix Umgebung und daher am gleichen Switch verkabelt. Somit Testumgebung bevor wir dann final die Hardware besorgen.

Könnte es sein, dass ich keine Verbindung zum Subnetz 2 bekomme, wenn ich den SQL02 abschalte? Der Cluster somit über 2.110 erreichbar ist und mein Tracert weiterhin auf 1.110 läuft? Aber das ist doch der eigentliche Grund ein Failovercluster zu haben, oder? Dass das Cluster weiterhin erreichbar ist, auch wenn die Putzfrau mit dem Staubsauger ein Kabel trennt.

LG
Bitte warten ..
Mitglied: Dani
31.01.2015 um 15:13 Uhr
Hallo,
ich würde zuerst die Konfiguration in soweit abändern, dass die Server in einem Subnetz stehen. Denn Multi-Homed bei einem Domain Controller bringt einige Probleme mit sich. Bei SQL bin ich mir gerade nicht sicher, ob in einem Cluster supportet...


Gruß,
Dani
Bitte warten ..
Mitglied: emeriks
31.01.2015 um 15:59 Uhr
Du hast den SQL01 2x aufgeführt. Versehen?

Hast Du schon mal die SQL-Instanz explizit an die eine (oder beiden) IP-Adresse gebunden? Standardmäßig wird sie ja an 0.0.0.0 gebunden, also "alle" Adressen.

E.
Bitte warten ..
Mitglied: meTzla
04.02.2015 um 15:31 Uhr
Copy + Paste Fehler - sorry!
Ich kann über das SQL Management Studio, von der W7 Kiste aus, sowohl den Cluster als auch SQL01 und SQL02 ansprechen.
Bitte warten ..
Mitglied: meTzla
04.02.2015 um 15:34 Uhr
Vermutlich wird es einfacher sein nachzuvollziehen was passiert, wenn ich für jede Rolle einen eigenen Server aufsetze, oder?
Bitte warten ..
Mitglied: meTzla
18.02.2015 um 16:27 Uhr
Habe das Problem gelöst bekommen:
Zwei Instanzen sind eine zu wenig:
Entweder man hat 3 DB-Server oder 2 DB-Server + 1 Quorumlistener. Dann läuft das System reibungslos.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Hyper-V
gelöst MS Server 2012 - Hyper-V - 2 NICs (5)

Frage von MiSt zum Thema Hyper-V ...

Windows Server
gelöst Windows Server 2012 R2 Cluster (4)

Frage von bintes zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...