Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

MS Software Distribution Service 3.0 bei Auto-Update inst. - Nichts geht mehr

Frage Microsoft Windows Systemdateien

Mitglied: webnob

webnob (Level 1) - Jetzt verbinden

22.08.2007, aktualisiert 14.10.2007, 62810 Aufrufe, 9 Kommentare

Nach dem letzten automatischen Windows-Update (Mitte August 07) wurde "Software Distribution Service 3.0" installiert. Danach sind vom Rechner keine exe mehr zu starten (iexplore, notepad, excel .... um nur ein paar zu nennen). Auch Nicht-Microsoft-Programme starten nicht mehr.

Das Problem trat an zwei von drei Rechnern auf. XP ist selbstverständlich korrekt lizenziert, ebenso Office. Nach der Installation dieses mysteriösen Updates lassen sich keine Programme mehr starten; selbst "F1" für Hilfe geht nicht mehr. Fehlermeldung:

"Sie haben keinen Zugriff auf diese Datei"

Die Berechtigungen sind allerdings korrekt gesetzt; das kann man über den noch startbaren Explorer erkennen.

Ich konnte den Arbeitsplatz nur wieder zum Leben erwecken, indem ich im abgesicherten Modus den letzten Wiederherstellungspunkt genutzt habe. Danach ist alles wieder OK. Das Update zeigt sich allerdings hartnäckig und will sich immer wieder installieren. Folge: Wieder kein Programm zu starten.

Bis auf Weiteres habe ich also erstmal die Updates komplett deaktiviert.

Fragen:
- Was ist "Software Distribution Service 3.0"?
- Was tut das Programm?
- Kann ich es deinstallieren / deaktivieren? (Kein Eintrag unter "Software", kein Dienst, kein Task gefunden...)
- Wie kann ich die Probleme vermeiden ohne den Updateservice zu deaktivieren?

Ach ja, der Befund auf Viren etc. war negativ.

____________________________________________________________________________________

NACHTRAG vom 13.10.2007:

Das Problem ist leider noch immer nicht gelöst. Inzwischen habe ich aber den Übeltäter identifiziert: Es ist das Patch KB938828. In diesem Patch wird die explorer.exe ausgetauscht.

Diese scheint -aus welchen Gründen auch immer- dann diesen Fehler zu verursachen: Kein Programm mehr startbar. Allerdings und witzigerweise ist aber der Explorer selbst zu starten. Wenn also noch jemand was weiß, bitte unbedingt posten!!

Bisher konnte ich den Fehler nur durch Deinstallation dieses einen Patches im abgesicherten Modus umgehen oder wie beschrieben den Wiederherstellungspunkt nutzen.
Mitglied: smurfyN
25.08.2007 um 18:06 Uhr
Hallo,
ich brauche ebenfalls dringend Hilfe zu diesem Problem.

Ich wollte meinen Rechner starten und er fuhr nur bis zum Windows XP Start hoch, dort wo die 3 Balken dann hin- und herfahren friert er ein. Ich habe den Rechner dann im abgesicherten Modus hochgefahren und versucht, durch Aktivierung eines vorherigen Systemwiederherstellungspunktes den Software Distribution Service 3.0 zu "umgehen", leider ohne Erfolg, es tut sich weiterhin nichts.
Da ich in den Tagen dazwischen nichts am Rechner gemacht habe (Urlaub) muss es an diesem Software Distribution Service 3.0 liegen, denn seit dem dort gesetzten Wiederherstellungspunkt geht's ja irgendwie nicht mehr ==

Wenn jemand weiterweiß, bitte dringend melden...

Gruß, smurfyN
Bitte warten ..
Mitglied: 53115
05.09.2007 um 15:25 Uhr
MS Update Kb 908531 ist der Übeltäter.
Ich habe ihn auch und habe keine Ahnung wie ich ihn los werde.
Alles gelöscht, deinstalliert, Shell durchsucht,Daten von der Software Distribution gelöscht.
Alle Fremdanbieter mit exe nicht Startet mehr.Da hat MS uns wieder einen rein gewürgt.
Ich hoffe auf HILFE.
Bitte warten ..
Mitglied: webnob
05.09.2007 um 18:00 Uhr
Los werden tust du das tolle Tool indem du den Rechner im abgesicherten Modus startest und den Wiederherstellungspunkt VOR der Installation des MS Software Distribution Service 3.0 wählst. Außerdem unbedingt das automatische Update (am besten in den Diensten) b.a.w. deaktivieren.

Nach einem Neustart ist alles wieder wie vorher.

Ich hoffe noch auf einen Beitrag, der uns eine Lösung des ursächlichen Problems näher bringt. Dann können die Updates wieder aktiviert werden. Bis dahin würde ich die nötigsten Updates manuell installieren und das KB 908531 definitiv außen vor lassen.

Bis dahin, Gruß
Webnob
Bitte warten ..
Mitglied: 53115
06.09.2007 um 06:51 Uhr
Das habe ich mir schon so vorgestellt.Vielen Dank für die Bestätigung.
Bitte warten ..
Mitglied: webnob
13.10.2007 um 21:05 Uhr
Hallo,

der Übeltäter ist von mir jetzt identifiziert: Es ist das Patch KB938828. In diesem Patch wird die explorer.exe ausgetauscht.

Diese scheint -aus welchen Gründen auch immer- dann diesen Fehler zu verursachen: Kein Programm mehr startbar. Allerdings und witzigerweise ist aber der Explorer selbst zu starten. Wenn also noch jemand was weiß, bitte unbedingt posten!!

Bisher konnte ich den Fehler durch Deinstallation dieses einen Patches im abgesicherten Modus umgehen.
Bitte warten ..
Mitglied: 53115
14.10.2007 um 11:26 Uhr
Ich habe dieses Problem jetzt gelöst.Nach dem sich diese Sache bis zum berühmten Blauen-
Bildschirm auf geschaukelt hatte musste ich alles Neu aufspielen.Habe aus Zorn alle Patch von
Windows wieder herunter geladen, und es geschehen noch Wunder,alles wieder in bester
Ordnung. Keine Probleme mehr. Alles sehr rätselhaft.
Bitte warten ..
Mitglied: Jurness
27.04.2009 um 10:54 Uhr
Guten Morgen,
auch mir ist Ähnliches geschehen: ein Windows XP SP2 Computer von HP frisch vom Händler, startete nach einem Windows Update nicht mehr.
Im abgesicherten Modus konnte man eine Reihe von Systemwiederherstellungspunkten erkennen, welche den Software Distribution Service 3.0 angaben.
Das System steckte allerdings auch nachdem Windows auf einen vorhergehenden Wiederherstellungspunkt zurückgestuft wurde, erst als ich Kaspersky Internet Security deaktivierte (immer über den abgesicherten Modus) konnte das System wieder 'normal ' starten:
Kaspersky und System teilten sich nämlich jeweils 50% der Prozessorleistung im Taskmanager...)
Nach dem Systemstart habe ich dann Kaspersky deinstalliert, mit dem CCleaner Werkzeug Festplatte und Registry überprüft und gesäubert, und habe mich dann nach und nach durch die Windowsupdates gearbeitet.
Bitte warten ..
Mitglied: Grav3
04.09.2009 um 11:04 Uhr
Hallo zusammen,
habe gerade einen Laptop gekriegt, wo vor 2 Tagen auch dieses SDS3.0 installiert wurde.
Programme die jetzt nicht mehr gehen:
-explorer.exe
-powerpoint
-outlook
-winlogon --> somit auch keine Wiederherstellung möglich

Lösung: Datensicherung, Neuinstallation, Deaktivierung von SDS3.0 Installation
Bitte warten ..
Mitglied: freder
17.05.2010 um 22:29 Uhr
Hallo, ich bin zwar neu hier, verfolge Euer Forum aber schon ein paar Jahre, gute Arbeit.

Nun zu dieser "Forumsleiche"

Habe in den letzten vier Wochen fünf Rechner mit diesem Problem gehabt, Symptome immer anders, Verursacher aber SDS3.0, bis jetzt gings immer über Sicherer Modus und Systemwiederherstellung weg.
Alle Rechner xp sp2 oder sp3. Installation zwischen 4Jahren und 3 Monaten alt!!!

WARUM JETZT ??????

Auf einem Rechner haben ein paar (drei) Java-Viren versucht einen (russischen) Trojaner zu installieren(Abhilfe Java Update 20), könnte auch Zufall gewesen sein?
Hat dass SDS3.0 irgendwas mit Java zu tun?
Hat noch jemand ähnliche Erfahrungen gemacht?
Leider sind aktuelle Threads zu diesem Thema selten, da ja alles schon vor Jahren behandelt wurde, ich glaube aber dasThema ist heisser den je.

Aufgetretene Symptome: Langsam (beim Start), Neustarts, Fehlfunktionen bei: Totalcomander, IE, Jdownloader, WGA, Phys.Laufwerken, etc
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...