Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

MSAccess-Backends via VPN über eine Delphi-Anwendung nicht erreichbar!

Frage Netzwerke

Mitglied: hapeke

hapeke (Level 1) - Jetzt verbinden

04.07.2007, aktualisiert 05.07.2007, 4592 Aufrufe, 3 Kommentare

Eine Delphi-Anwendung startet mithilfe eines OLE 4.0 Verknüpfungsstrings in einer INI-Datei ein MS-Access 2003-Backend zum Darstellen von Dateninhalten. Die Verknüpfung dorthin wird aber abgelehnt, obwohl a) der eingetragene Pfad stimmt und b) der VerbindungsTest über den eingebauten Delphi-Assistent funktioniert!

Rufe ich die Anwendung in einer normalen Netzwerk-Umgebung (LAN) auf, so funktioniert die Connection problemlos. Die gleiche Anwendung aber in einer VPN-Umgebung (mit gemappten Laufwerken) kann die Verbindung zur Datenbank nicht herstellen. Es spielt auch keine Rolle, wenn ich im Verbindungsstring statt des Laufwerkbuchstabens die IP-Adresse des Servers verwende. Die VPN-Verbindung selbst funktioniert, die Zugriffe auf die Pfade klappen tadellos. Über Citrix funktioniert die Angelegenheit ebenfalls.
Auf dem Rechner ist Access 2003 installiert. Rufe ich das Backend über Access im lokalen LAN auf, dann startet das Backend problemlos.
Rufe ich jedoch mit dem lokalen Access das gleiche Backend in einer VPN-Umgebung auf, dann wird erst mal gesagt, daß es sich um eine Anwendung eines unbekannten Herstellers (Zertifikat) handelt, und es wird gleich Access als mögliche Basisanwendung vorgeschlagen. Bestätige ich dies, startet auch das Backend.
Ich habe nun 1001 Einstellungen probiert, um diese Abfrage (an der vermutlich auch der Delphi-Connectversuch scheitert), auszzuschalten, aber nichts gefunden.

Wer hat eine Idee oder gar eine Lösung?

Vielen Dank!
Mitglied: aqui
04.07.2007 um 19:50 Uhr
Hört sich nach einem MTU Problem der VPN Verbindung an. Ggf. hilft das hier

http://support.microsoft.com/?kbid=826159

weiter ?!
Oder generell den Wert der MTU auf dem physischen Interface über das die VPN Verbindung realisiert wird anpassen. Ein Tool wie z.B. Dr. TCP hilft dabei.
http://www.dslreports.com/drtcp
Bitte warten ..
Mitglied: hapeke
05.07.2007 um 10:48 Uhr
Vielen Dank für die Antwort,

habe den TunnelMTU auch auf 1500 gestellt, das Ergebnis war das gleiche wie zuvor.

Habe dann einmal das komplette Sicherheitscenter deaktiviert - erfolglos.

Habe dann in den Gruppenrichtlichen unter Benutzereinstellungen / administrative Vorlagen die Dateiliste mit niedrigem Risiko um die Dateiendungen von Access ergänzt - ohne Erfolg.

Bin ziemlich ratlos; die Dialogbox mit 'Unbekannter Herausgeber' erscheint immer noch. Die Exer-Anwendung erhält nach wie vor keinen Connect....
Bitte warten ..
Mitglied: aqui
05.07.2007 um 17:14 Uhr
Niemals darf man die Tunnel MTU oder die Interface MTU auf 1500 stellen. Genau damit würdest du ja eine Fragmentierung erzwingen durch die hohe Paylod der VPN Frames. Geräte bzw. Interfaces mit zu hoher MTU provozieren ja diesen Fehler wenn sie keine saubere MTU Path Discovery durchführen wie es eigentlich sein sollte ! Dein Weg war also genau der Falsche !!!
Du musst...wenn dann.. MTUs unter 1400 probieren !
Bitte warten ..
Ähnliche Inhalte
Router & Routing
gelöst Firtzbox VPN nicht alle Ports erreichbar? (15)

Frage von atarjono zum Thema Router & Routing ...

Apache Server
Joomla - Aktualisierung über das Backend möglich? (3)

Frage von FA-jka zum Thema Apache Server ...

Entwicklung
OTRS mit SAP als Backend für Kunden (5)

Frage von Chonta zum Thema Entwicklung ...

Router & Routing
gelöst Standort VPN- ein einziger Rechner nicht erreichbar (11)

Frage von lienas zum Thema Router & Routing ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(2)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
gelöst Leiten "dumme" Switches VLAN-Tags mit durch? (26)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (16)

Frage von departure69 zum Thema Windows Server ...

Netzwerkgrundlagen
Kann auf Freigabe nicht Zugreifen (16)

Frage von leon123 zum Thema Netzwerkgrundlagen ...

Router & Routing
FTTH bzw FTTB Router (13)

Frage von ukulele-7 zum Thema Router & Routing ...