Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

MSI Installer taucht immer wieder im Ereignisprotokoll auf

Frage Microsoft Windows Installation

Mitglied: leclou69

leclou69 (Level 1) - Jetzt verbinden

08.01.2009, aktualisiert 01:18 Uhr, 6553 Aufrufe, 3 Kommentare

JRE 6 Update 11 Installation erscheint immer wieder im Anwendungsprotokoll

Hallo zusammen,
ich gestehe, ich weiß gar nicht, ob ich in der richtigen Kategorie gelandet bin, aber vielleicht kann mir ja jemand helfen (wie häufig wurde dieser Satz hier wohl bereits gebraucht)
Also:
Wir fahren ein Win 2k3 Netzwerk, zwei Server W2k3 Standard, ein W2k Pro.
Clients sind überwiegend WinXPPro SP2, einige SP3, einige Vista Business.
Mein Problem ist folgendes:
Wir hatten via Gruppenrichtlinie aktiviert, daß Java Runtime Environment an allen clients installiert wird, und zwar so, daß die Vorgängerversionen deinstalliert werden.
Dies hatten wir in den Gruppenrichtlinien der betreffenden RECHNER festgelegt, nicht der user.
Dies klappte auch hervorragend bis JRE 6 Update 11.
Hier hängte sich die Installation teilweise bis zu einer Stunde auf mit dem Ergebnis, daß JRE 6 Update 11 immer noch nicht installiert war.
Daher habe ich die Gruppenrichtlinie, welche die JRE-Installation verteilt, dahingehend geändert, daß ich das Update auf Version 11, welches ja ein Softwarepaket ist, gelöscht habe.
Bei der Nachfrage, ob die Software deinstalliert werden soll, oder nur neue Installationen deaktiviert werden sollen, hab ich letzteres gewählt.
Nach Neustart der betroffenen Rechner wurde die Installation nicht mehr initialisisert.
Damit das entsprechende Softwarepaket nun doch noch installiert wird, habe ich es per wpkg per Skript installieren lassen.
Dies führte zu dem gewünschten Ergebnis, daß dies Update an den gewünschten Rechnern installiert ist.
ABER:
Bei jedem Anmelden eines users aus dem ursprünglichen Geltungsbereich der GPO findet man im Anwendungsprotokoll der Ereignisanzeige den Eintrag, daß die Installation des Java Runtime Environment 6, Update 11 fehlgeschlagen sei.
Dieser Eintrag taucht immer erst bei Anmeldung eines users auf, nicht bei Anmeldung des Systems selber.
Es scheint mir so, daß diese Installationsroutine zu Verzögerungen bei der Anmeldung der user führt, was mir leider auch von diesen bestätigt wurde.
Außerdem wird der Versuch der Installation alle paar Stunden wiederholt, was dann zu Verzögerungen in aktuell ausgeführten Programmen führt.

Ist jemand einem solchen Problem schon einmal begegnet und weiß evtl. Rat?

Besten Dank im Voraus

Markus
Mitglied: DerWoWusste
10.01.2009 um 18:22 Uhr
Könnte das wpkg Schuld sein? Teste den ggleichen Ablauf nochmal auf einem Testclient.
Meine Erfahrungen: Wir verteilen JRE seit Version 1.5 per MSI-Paket (jede Unterversion als Update verteilt, wobei die alte Version automatisch deinstalliert wurde) - problemlos.
Besonderheit bei dem 1.6_11: das MSI alleine reicht nicht mehr (Installationen schlagen fehl). Im Quellpfad muss noch eine .cab Datei mit liegen. Frag mich nicht nach dem Namen, bei Interesse sag ich es Dir am Montag.
Bitte warten ..
Mitglied: leclou69
11.01.2009 um 15:42 Uhr
Hallo auch und Danke für die Antwort.
Die Besonderheit mit der cab-Datei tauchte bereits bei der Version 1.6.10 auf, soweit ich mich erinnere. Hatte es auf jeden Fall mit berücksichtigt, auch beim Versuch, die 1.6.11-er via GPO zu verteilen.
Am wpkg kann es meiner Meinung nach nicht liegen, denn ein durch wpkg initiierter erneuter Installationsversuch würde in den Protokollen von wpkg auftauchen, was es aber nicht tut.
Inzwischen habe ich auch festgestellt, daß nicht nur die JRE, sondern auch andere msi-Pakete, die nur lokal installiert wurden, immer wieder im Ereignisprotokoll auftauchen.
Vielleicht einfach eine Rechtefrage - komme aber erst morgen dazu, mehr in Erfahrung zu bringen.
Trotzdem Danke

Gruß Markus
Bitte warten ..
Mitglied: LittleFlame
26.11.2010 um 10:17 Uhr
Is zwar schon unglaublich lange her, aber ich stehe vor genau dem selben Problem und mich würde interessieren, wie du die Sache geregelt hast.
Höhere Rechte? Irgendwie das Paket entfernt?

Solltest du noch Informationen diesbezüglich haben, würde ich mich drüber freuen

Viele Grüße,

LittleFlame
Bitte warten ..
Neuester Wissensbeitrag
Windows Update

Windows Update-Suche nach Win7 Neuinstallation wieder schneller

(1)

Erfahrungsbericht von the-buccaneer zum Thema Windows Update ...

Ähnliche Inhalte
Entwicklung
MSI Dateien als Administrator von einer HTA installieren (1)

Frage von iGordon zum Thema Entwicklung ...

Windows Server
TeamViewer 11 MSI Installation schlägt fehl (13)

Frage von Ghost108 zum Thema Windows Server ...

Windows Tools
gelöst Kaufempfehlung MSI-Wrapper (4)

Frage von User1000 zum Thema Windows Tools ...

Sicherheits-Tools
gelöst Kaspersky Offline Installer (7)

Frage von Markowitsch zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Exchange Server
Bestehende eMails autoamatisch weiterleiten (21)

Frage von metal-shot zum Thema Exchange Server ...

Hyper-V
gelöst Reiner Hyper- V Server oder lieber Rolle (21)

Frage von Winuser zum Thema Hyper-V ...

SAN, NAS, DAS
gelöst Synology Version 6.1 Probleme (18)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...

Router & Routing
gelöst IP Kamera für drei unabhängige Netzwerke (16)

Frage von ProfessorZ zum Thema Router & Routing ...