Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft

MSI Paket per Gruppenrichtlinie wird nicht installiert Fehler 102

Mitglied: BennyTurbo

BennyTurbo (Level 1) - Jetzt verbinden

06.12.2011 um 09:06 Uhr, 6143 Aufrufe, 17 Kommentare

Hallo,

ich bin am verzweifeln mit der Installation von Center Tools DriveLock per MSI Paket.

Folgende Fehlermeldung erhalte ich auf Windows XP Clients:

"Die Installation der Anwendung CenterTools DriveLock Agent der Richtlinie CenterTools ist fehlgeschlagen. Fehler: Die Installationsquelle für dieses Produkt ist nicht verfügbar. Stellen Sie sicher, dass die Quelle vorhanden ist und Sie Zugriff darauf haben.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.;

Fehler 102.


Bei Windows 7 32 Bit Rechnern funktioniert die Installation des Paketes. (32 Bit ist auch hinterlegt) Sprache habe ich auf "Ignorieren" gesetzt. Die Datei liegt im NETLOGON Verzeichnis der DC's. Als Pfad ist UNC gewählt: \\DC01\NETLOGON\drivelock7.msi


Woran liegt es? Es wird beim Starten kurz auf den Clients gezeigt:

1. Netzwerkeinstellungen vorbereiten
2. Computereinstellungen werden übernommen
3. Sicherheitseinstellungen übernehmen
4. CenterTools DriveLock wird installiert (aber nur für 1-2 Sek.) dann gehts direkt zum Anmeldescreen.

Danke Euch.
Gruß, Benny
Mitglied: gsch86
06.12.2011 um 09:16 Uhr
Hallo Benny!

Für XP hast du ja ein anderes MSI oder?! Wo liegt das? Kannst du (wie die Fehlermeldung schon sagt) sicherstellen, dass du auf den richtigen Pfad verweist bzw. Rechte hast, dorthin zu gehen? Hast du mehrere DC (weil du DCs schreibst)? Wenn ja: eventuell Datei noch nicht repliziert. Wenn du mehrere DCs hast finde ich bei der Wahl des UNC Pfads %LOGONSERVER% besser, dann bist du nicht direkt auf einen Verweis gebunden, sondern er holt es sich bei seinem Anmeldeserver ab.

lg
gsch
Bitte warten ..
Mitglied: BennyTurbo
06.12.2011 um 09:25 Uhr
Zitat von gsch86:
Für XP hast du ja ein anderes MSI oder?! Wo liegt das? Kannst du (wie die Fehlermeldung schon sagt) sicherstellen, dass du
auf den richtigen Pfad verweist bzw. Rechte hast, dorthin zu gehen? Hast du mehrere DC (weil du DCs schreibst)? Wenn ja: eventuell
Datei noch nicht repliziert. Wenn du mehrere DCs hast finde ich bei der Wahl des UNC Pfads %LOGONSERVER% besser, dann bist du
nicht direkt auf einen Verweis gebunden, sondern er holt es sich bei seinem Anmeldeserver ab.

Hi,

nein, das ist das gleiche MSI Paket? Es gibt da nur 32 Bit und 64 Bit? Habe allgemein die 32 Bit verwendet. Die Datei ist bereits auf allen DC's repliziert. Habe auch schon einen anderen Pfad getestet, wo "Jeder" darauf Lesen und Ausführen darf. Die Fehlermeldung bleibt.
Bitte warten ..
Mitglied: gsch86
06.12.2011 um 09:28 Uhr
Kannst du das Paket händisch auf einen XP Client installieren oder bekommst da auch eine Fehlermeldung?
Ist jetzt nur ne Vermutung, aber wenn es eine Win7 SW ist, die unter XP nicht unterstützt wird, wäre es erklärbar, dass es auf Win7 geht und unter XP nicht....

lg
Bitte warten ..
Mitglied: BennyTurbo
06.12.2011 um 10:44 Uhr
Zitat von gsch86:
Kannst du das Paket händisch auf einen XP Client installieren oder bekommst da auch eine Fehlermeldung?
Ist jetzt nur ne Vermutung, aber wenn es eine Win7 SW ist, die unter XP nicht unterstützt wird, wäre es erklärbar,
dass es auf Win7 geht und unter XP nicht....

lg

Händisch funktioniert einwandfrei, wenn ich die MSI aufrufe. Laut CenterTools ist die auch für WinXP SP3 freigegeben. Habe jetzt mal von Adobe das Reader X 10.0 Paket getestet. Auch da habe ich den gleichen Fehler auf den XP Maschinen. Also scheint es schon mal nicht an CenterTools zu liegen.

Verstehe die Meldung nicht. Auf das Netlogon Verzeichnis hat doch jeder Zugriff? %LOGONSERVER% kann ich nicht eingeben, da ich direkt den UNC Pfad wählen muss, aber es haben eh alle DC's drauf.

Gruß, Benny
Bitte warten ..
Mitglied: DerWoWusste
06.12.2011 um 15:32 Uhr
Hi.

Das Problem ist microsoft bekannt und tritt bei Verwendung des Netlogon-Shares auf. Nimm eine andere Freigabe.
Bitte warten ..
Mitglied: BennyTurbo
06.12.2011 um 16:46 Uhr
Zitat von DerWoWusste:
Hi.

Das Problem ist microsoft bekannt und tritt bei Verwendung des Netlogon-Shares auf. Nimm eine andere Freigabe.

Habe ich nun geändert. Geht leider auch nicht
Bitte warten ..
Mitglied: DerWoWusste
06.12.2011 um 20:37 Uhr
Und der Client hat den neuen Pfad auch schon benutzt? Log mal am Client mit (procmon bootlogging), was da passiert und ob ein echter "access denied" kommt.
Bitte warten ..
Mitglied: BennyTurbo
06.12.2011 um 20:46 Uhr
Zitat von DerWoWusste:
Und der Client hat den neuen Pfad auch schon benutzt? Log mal am Client mit (procmon bootlogging), was da passiert und ob ein
echter "access denied" kommt.

Wie mache ich das? Ist das ein Tool oder einfach das Windows Boot Logging?
Bitte warten ..
Mitglied: DerWoWusste
06.12.2011 um 22:09 Uhr
Procmon runterladen bei Microsoft.
Bitte warten ..
Mitglied: DerWoWusste
07.12.2011 um 00:18 Uhr
Siehe auch http://www.administrator.de/MSI_Paket_aus_Netlogon-Verzeichnis_nicht_au ...
bzw. http://support.microsoft.com/kb/889710 (netlogon und sysvol teilen das selbe Problem, da der eine ein Unterordner des anderen ist).

Sieht genau nach Deinem Problem aus: win7 geht (so mein Test), xp nicht. Stell sicher, dass Deine Änderung des Pfades übernommen wurde. Gib auch an, ob es gelingt, wenn Du esw manuell aus diesem Pfad startest (wurde oben nicht deutlich, ob Du dabei den selben Pfad verwendest).
Bitte warten ..
Mitglied: BennyTurbo
07.12.2011 um 09:20 Uhr
Zitat von DerWoWusste:
Siehe auch http://www.administrator.de/MSI_Paket_aus_Netlogon-Verzeichnis_nicht_au ...
bzw. http://support.microsoft.com/kb/889710 (netlogon und sysvol teilen das selbe Problem, da der eine ein Unterordner des anderen
ist).

Sieht genau nach Deinem Problem aus: win7 geht (so mein Test), xp nicht. Stell sicher, dass Deine Änderung des Pfades
übernommen wurde. Gib auch an, ob es gelingt, wenn Du esw manuell aus diesem Pfad startest (wurde oben nicht deutlich, ob Du
dabei den selben Pfad verwendest).

Habe jetzt per MSIEXEC das mal testweise in den Anmeldescript der Benutzer eingebaut, da installiert er es von der Freigabe (nicht NETLOGON).... aber per GPO immer noch nicht bei XP. Werde das jetzt mal mit dem Monitoring Tool testen.
Bitte warten ..
Mitglied: BennyTurbo
07.12.2011 um 16:31 Uhr
Wie finde ich jetzt in dem Log am besten die Stelle, wo der Fehler auftritt?
Bitte warten ..
Mitglied: DerWoWusste
07.12.2011 um 21:27 Uhr
Moin.

Ich schrieb: "...ob ein echter "access denied" kommt" ->danach musst Du im Log suchen, eine Suchfunktion ist drin.
Beantworte aber bitte meine Rückfragen.
1) Gib auch an, ob es gelingt, wenn Du esw manuell aus diesem Pfad startest (wurde oben nicht deutlich, ob Du dabei den selben Pfad verwendest).
2) Stell sicher, dass Deine Änderung des Pfades übernommen wurde
Bitte warten ..
Mitglied: BennyTurbo
07.12.2011 um 21:33 Uhr
Zitat von DerWoWusste:
Moin.

Ich schrieb: "...ob ein echter "access denied" kommt" ->danach musst Du im Log suchen, eine Suchfunktion
ist drin.
Beantworte aber bitte meine Rückfragen.
1) Gib auch an, ob es gelingt, wenn Du esw manuell aus diesem Pfad startest (wurde oben nicht deutlich, ob Du dabei den selben
Pfad verwendest).
2) Stell sicher, dass Deine Änderung des Pfades übernommen wurde

Ok, suche ich morgen nochmal...

Sorry, zu Deinen Fragen:

Ja, der Pfad ist \\DATEISERVER\MSI\paket1.msi

Habe jetzt per Logon Script vorrübergehend den Befehl "msiexec /i \\DATEISERVER\MSI\paket1.msi /qn" eingetragen und so können die Clients wunderbar auf die Installation zugreifen. Nur ist das ja nicht SInn der Sache und eher ein Hotfix, damit es überhaupt geht. Der Pfad ist an "Jeder" und an "Domänencomputer" freigegeben, da vor der Anmeldung doch der Computer an sich Zugriff haben muss oder? SYSTEM steht auch noch drin. Freigabe UND Sicherheit....
Bitte warten ..
Mitglied: DerWoWusste
07.12.2011 um 21:43 Uhr
Hi.

Du beantwortest weder 1 noch 2, kann das sein ;) ?
Bitte warten ..
Mitglied: BennyTurbo
07.12.2011 um 21:49 Uhr
Zitat von DerWoWusste:
Hi.

Du beantwortest weder 1 noch 2, kann das sein ;) ?

Hmm, sorry. 1: Ja, ist der gleiche Pfad und starten aus dem Pfad geht...

2. Ja, wurde übernommen, sowohl beim MSI Paket als auch bei der Standardeinstellung für den Standard Ordner.... wenn ich das MSI Paket hinzufüge öffnet er auch direkt den MSI Ordner auf dem Dateiserver....
Bitte warten ..
Mitglied: DerWoWusste
07.12.2011 um 22:20 Uhr
Zu 2)
Es ist doch entscheidend, ob es beim Client ankommt. Mach rsop.msc am Client und schau, ob der Pfad des Paketes auf den neuen Ort zeigt.
Bitte warten ..
Ähnliche Inhalte
Windows Tools
MSI Pakete erstellen
gelöst Frage von M.MarzWindows Tools2 Kommentare

Hallo zusammen, kennt ihr vielleicht ein gutes und Kostenloses Tool, womit man sich MSI Pakete für die Netzwerkverteilung erstellen ...

Windows Netzwerk
Installation von MSI Paket über GPO nicht möglich: Fehler 1602
Frage von patriwagWindows Netzwerk1 Kommentar

Ich versuche den TrendMicro OfficeScan Client per GPO in unserer Domäne auszurollen. Jedoch scheitert das mit der Fehlermeldung in ...

Windows Tools
MSI Paket verteilen
Frage von uLmiWindows Tools4 Kommentare

Hallo Zusammen, ich habe einen 2012 R2 Server und möchte einer Gruppenrichtlinie (Computer -> Software Installation) eine MSI-Datei hinzufügen. ...

Windows Server
MSI Paket via Skript installieren
Frage von r00t-1337Windows Server7 Kommentare

Moin zusammen, ich habe ein Problem ein MSI Paket via GPO zu installieren. Es sieht wie folgt aus: 1. ...

Neue Wissensbeiträge
Router & Routing

PfSense als Addon auf QNAP

Information von magicteddy vor 2 StundenRouter & Routing

Moin, für Spielereien eine ganz nette Idee aber ich fürchte das soetwas auch als echte Firewall genutzt wird: In ...

Datenschutz

Teamviewer kommt für IoT-Geräte wie den Raspberry Pi

Information von magicteddy vor 9 StundenDatenschutz

Moin, jetzt werden IoT Geräte endgültig zur Wanze? Anscheinend kann man auf einem Dashboard seine Geräte visualisieren Ich stelle ...

Microsoft

Letzte Updates für Win10 und Server2016 müssen bei Bedarf über den Update catalogue in den WSUS importiert werden!

Tipp von DerWoWusste vor 14 StundenMicrosoft1 Kommentar

automatisch kommt da nichts an im WSUS und auch nicht im SCCM. Siehe Hinweise zum Bezug der jeweils neuesten ...

Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 3 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Preis für Wartungsvertrag ok?
gelöst Frage von a-za-zNetzwerkmanagement22 Kommentare

Hallo! Mal ne Frage, weil ich mich mit dem akzeptablen Preis für einen Reaktionszeitvertrag nicht auskenne. Meine Firma hat ...

Windows Netzwerk
Ist ein Portforwarding auf einen PC ohne lauschendes Programm ein (großes) Sicherheitsproblem?
Frage von PluwimWindows Netzwerk13 Kommentare

Hallo zusammen, zur Fernwartung eines Rechners an einem anderen Ort nutze ich VNC. Da dieser Rechner einfach nur eine ...

SAN, NAS, DAS
Wer kennt sich mit QNAP und CISCO aus ?
gelöst Frage von MachelloSAN, NAS, DAS10 Kommentare

Hallo Zusammen hier im Forum, Ich habe ein QNas 451+ und dieses NAS hat zwei GBit Lan Adapter die ...

Windows Server
Terminal Server 2016 erkennt Berechtigungen nicht
gelöst Frage von Thomas2Windows Server10 Kommentare

Hallo Administratoren, folgendes Problem stellt sich dar: Es gibt zwei Windows Server 2016, die als Terminal Server fungieren. Jetzt ...