Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

MSI Paket per Gruppenrichtlinie wird nicht installiert Fehler 102

Frage Microsoft

Mitglied: BennyTurbo

BennyTurbo (Level 1) - Jetzt verbinden

06.12.2011 um 09:06 Uhr, 5854 Aufrufe, 17 Kommentare

Hallo,

ich bin am verzweifeln mit der Installation von Center Tools DriveLock per MSI Paket.

Folgende Fehlermeldung erhalte ich auf Windows XP Clients:

"Die Installation der Anwendung CenterTools DriveLock Agent der Richtlinie CenterTools ist fehlgeschlagen. Fehler: Die Installationsquelle für dieses Produkt ist nicht verfügbar. Stellen Sie sicher, dass die Quelle vorhanden ist und Sie Zugriff darauf haben.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.;

Fehler 102.


Bei Windows 7 32 Bit Rechnern funktioniert die Installation des Paketes. (32 Bit ist auch hinterlegt) Sprache habe ich auf "Ignorieren" gesetzt. Die Datei liegt im NETLOGON Verzeichnis der DC's. Als Pfad ist UNC gewählt: \\DC01\NETLOGON\drivelock7.msi


Woran liegt es? Es wird beim Starten kurz auf den Clients gezeigt:

1. Netzwerkeinstellungen vorbereiten
2. Computereinstellungen werden übernommen
3. Sicherheitseinstellungen übernehmen
4. CenterTools DriveLock wird installiert (aber nur für 1-2 Sek.) dann gehts direkt zum Anmeldescreen.

Danke Euch.
Gruß, Benny
Mitglied: gsch86
06.12.2011 um 09:16 Uhr
Hallo Benny!

Für XP hast du ja ein anderes MSI oder?! Wo liegt das? Kannst du (wie die Fehlermeldung schon sagt) sicherstellen, dass du auf den richtigen Pfad verweist bzw. Rechte hast, dorthin zu gehen? Hast du mehrere DC (weil du DCs schreibst)? Wenn ja: eventuell Datei noch nicht repliziert. Wenn du mehrere DCs hast finde ich bei der Wahl des UNC Pfads %LOGONSERVER% besser, dann bist du nicht direkt auf einen Verweis gebunden, sondern er holt es sich bei seinem Anmeldeserver ab.

lg
gsch
Bitte warten ..
Mitglied: BennyTurbo
06.12.2011 um 09:25 Uhr
Zitat von gsch86:
Für XP hast du ja ein anderes MSI oder?! Wo liegt das? Kannst du (wie die Fehlermeldung schon sagt) sicherstellen, dass du
auf den richtigen Pfad verweist bzw. Rechte hast, dorthin zu gehen? Hast du mehrere DC (weil du DCs schreibst)? Wenn ja: eventuell
Datei noch nicht repliziert. Wenn du mehrere DCs hast finde ich bei der Wahl des UNC Pfads %LOGONSERVER% besser, dann bist du
nicht direkt auf einen Verweis gebunden, sondern er holt es sich bei seinem Anmeldeserver ab.

Hi,

nein, das ist das gleiche MSI Paket? Es gibt da nur 32 Bit und 64 Bit? Habe allgemein die 32 Bit verwendet. Die Datei ist bereits auf allen DC's repliziert. Habe auch schon einen anderen Pfad getestet, wo "Jeder" darauf Lesen und Ausführen darf. Die Fehlermeldung bleibt.
Bitte warten ..
Mitglied: gsch86
06.12.2011 um 09:28 Uhr
Kannst du das Paket händisch auf einen XP Client installieren oder bekommst da auch eine Fehlermeldung?
Ist jetzt nur ne Vermutung, aber wenn es eine Win7 SW ist, die unter XP nicht unterstützt wird, wäre es erklärbar, dass es auf Win7 geht und unter XP nicht....

lg
Bitte warten ..
Mitglied: BennyTurbo
06.12.2011 um 10:44 Uhr
Zitat von gsch86:
Kannst du das Paket händisch auf einen XP Client installieren oder bekommst da auch eine Fehlermeldung?
Ist jetzt nur ne Vermutung, aber wenn es eine Win7 SW ist, die unter XP nicht unterstützt wird, wäre es erklärbar,
dass es auf Win7 geht und unter XP nicht....

lg

Händisch funktioniert einwandfrei, wenn ich die MSI aufrufe. Laut CenterTools ist die auch für WinXP SP3 freigegeben. Habe jetzt mal von Adobe das Reader X 10.0 Paket getestet. Auch da habe ich den gleichen Fehler auf den XP Maschinen. Also scheint es schon mal nicht an CenterTools zu liegen.

Verstehe die Meldung nicht. Auf das Netlogon Verzeichnis hat doch jeder Zugriff? %LOGONSERVER% kann ich nicht eingeben, da ich direkt den UNC Pfad wählen muss, aber es haben eh alle DC's drauf.

Gruß, Benny
Bitte warten ..
Mitglied: DerWoWusste
06.12.2011 um 15:32 Uhr
Hi.

Das Problem ist microsoft bekannt und tritt bei Verwendung des Netlogon-Shares auf. Nimm eine andere Freigabe.
Bitte warten ..
Mitglied: BennyTurbo
06.12.2011 um 16:46 Uhr
Zitat von DerWoWusste:
Hi.

Das Problem ist microsoft bekannt und tritt bei Verwendung des Netlogon-Shares auf. Nimm eine andere Freigabe.

Habe ich nun geändert. Geht leider auch nicht
Bitte warten ..
Mitglied: DerWoWusste
06.12.2011 um 20:37 Uhr
Und der Client hat den neuen Pfad auch schon benutzt? Log mal am Client mit (procmon bootlogging), was da passiert und ob ein echter "access denied" kommt.
Bitte warten ..
Mitglied: BennyTurbo
06.12.2011 um 20:46 Uhr
Zitat von DerWoWusste:
Und der Client hat den neuen Pfad auch schon benutzt? Log mal am Client mit (procmon bootlogging), was da passiert und ob ein
echter "access denied" kommt.

Wie mache ich das? Ist das ein Tool oder einfach das Windows Boot Logging?
Bitte warten ..
Mitglied: DerWoWusste
06.12.2011 um 22:09 Uhr
Procmon runterladen bei Microsoft.
Bitte warten ..
Mitglied: DerWoWusste
07.12.2011 um 00:18 Uhr
Siehe auch http://www.administrator.de/MSI_Paket_aus_Netlogon-Verzeichnis_nicht_au ...
bzw. http://support.microsoft.com/kb/889710 (netlogon und sysvol teilen das selbe Problem, da der eine ein Unterordner des anderen ist).

Sieht genau nach Deinem Problem aus: win7 geht (so mein Test), xp nicht. Stell sicher, dass Deine Änderung des Pfades übernommen wurde. Gib auch an, ob es gelingt, wenn Du esw manuell aus diesem Pfad startest (wurde oben nicht deutlich, ob Du dabei den selben Pfad verwendest).
Bitte warten ..
Mitglied: BennyTurbo
07.12.2011 um 09:20 Uhr
Zitat von DerWoWusste:
Siehe auch http://www.administrator.de/MSI_Paket_aus_Netlogon-Verzeichnis_nicht_au ...
bzw. http://support.microsoft.com/kb/889710 (netlogon und sysvol teilen das selbe Problem, da der eine ein Unterordner des anderen
ist).

Sieht genau nach Deinem Problem aus: win7 geht (so mein Test), xp nicht. Stell sicher, dass Deine Änderung des Pfades
übernommen wurde. Gib auch an, ob es gelingt, wenn Du esw manuell aus diesem Pfad startest (wurde oben nicht deutlich, ob Du
dabei den selben Pfad verwendest).

Habe jetzt per MSIEXEC das mal testweise in den Anmeldescript der Benutzer eingebaut, da installiert er es von der Freigabe (nicht NETLOGON).... aber per GPO immer noch nicht bei XP. Werde das jetzt mal mit dem Monitoring Tool testen.
Bitte warten ..
Mitglied: BennyTurbo
07.12.2011 um 16:31 Uhr
Wie finde ich jetzt in dem Log am besten die Stelle, wo der Fehler auftritt?
Bitte warten ..
Mitglied: DerWoWusste
07.12.2011 um 21:27 Uhr
Moin.

Ich schrieb: "...ob ein echter "access denied" kommt" ->danach musst Du im Log suchen, eine Suchfunktion ist drin.
Beantworte aber bitte meine Rückfragen.
1) Gib auch an, ob es gelingt, wenn Du esw manuell aus diesem Pfad startest (wurde oben nicht deutlich, ob Du dabei den selben Pfad verwendest).
2) Stell sicher, dass Deine Änderung des Pfades übernommen wurde
Bitte warten ..
Mitglied: BennyTurbo
07.12.2011 um 21:33 Uhr
Zitat von DerWoWusste:
Moin.

Ich schrieb: "...ob ein echter "access denied" kommt" ->danach musst Du im Log suchen, eine Suchfunktion
ist drin.
Beantworte aber bitte meine Rückfragen.
1) Gib auch an, ob es gelingt, wenn Du esw manuell aus diesem Pfad startest (wurde oben nicht deutlich, ob Du dabei den selben
Pfad verwendest).
2) Stell sicher, dass Deine Änderung des Pfades übernommen wurde

Ok, suche ich morgen nochmal...

Sorry, zu Deinen Fragen:

Ja, der Pfad ist \\DATEISERVER\MSI\paket1.msi

Habe jetzt per Logon Script vorrübergehend den Befehl "msiexec /i \\DATEISERVER\MSI\paket1.msi /qn" eingetragen und so können die Clients wunderbar auf die Installation zugreifen. Nur ist das ja nicht SInn der Sache und eher ein Hotfix, damit es überhaupt geht. Der Pfad ist an "Jeder" und an "Domänencomputer" freigegeben, da vor der Anmeldung doch der Computer an sich Zugriff haben muss oder? SYSTEM steht auch noch drin. Freigabe UND Sicherheit....
Bitte warten ..
Mitglied: DerWoWusste
07.12.2011 um 21:43 Uhr
Hi.

Du beantwortest weder 1 noch 2, kann das sein ;) ?
Bitte warten ..
Mitglied: BennyTurbo
07.12.2011 um 21:49 Uhr
Zitat von DerWoWusste:
Hi.

Du beantwortest weder 1 noch 2, kann das sein ;) ?

Hmm, sorry. 1: Ja, ist der gleiche Pfad und starten aus dem Pfad geht...

2. Ja, wurde übernommen, sowohl beim MSI Paket als auch bei der Standardeinstellung für den Standard Ordner.... wenn ich das MSI Paket hinzufüge öffnet er auch direkt den MSI Ordner auf dem Dateiserver....
Bitte warten ..
Mitglied: DerWoWusste
07.12.2011 um 22:20 Uhr
Zu 2)
Es ist doch entscheidend, ob es beim Client ankommt. Mach rsop.msc am Client und schau, ob der Pfad des Paketes auf den neuen Ort zeigt.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Netzwerk
Installation von MSI Paket über GPO nicht möglich: Fehler 1602 (1)

Frage von patriwag zum Thema Windows Netzwerk ...

Windows Userverwaltung
Neue Version (msi Paket) lässt sich nicht über GPO ausrollen? (5)

Frage von ordi303 zum Thema Windows Userverwaltung ...

Windows Server
gelöst Fehler bei Verarbeitung der Gruppenrichtlinie (6)

Frage von Halbgott zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...