Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

MSI Paket via Skript installieren

Frage Microsoft Windows Server

Mitglied: r00t-1337

r00t-1337 (Level 1) - Jetzt verbinden

24.11.2014 um 08:40 Uhr, 1651 Aufrufe, 7 Kommentare

Moin zusammen,

ich habe ein Problem ein MSI Paket via GPO zu installieren.

Es sieht wie folgt aus:

1. Eine GPO kopiert das MSI-Paket lokal unter C:\ -> funtioniert
2. Eine GPO welche in der Reihenfolge danach kommt ist mit einem Skript hinterlegt welches das MSI-Paket unter C:\ instalieren solll -> funtioniert nicht

Das Skript sieht wie folgt aus:

msiexec /i c:\trend-micro-v11_install.msi /qn

Wenn ich das Skript manuell aufrufe funnktioniet die Installation.

Das Skript wird in der GPO unter Computerkonfig / Skripts / Starten aufgerufen.

Jemand eine Idee hierzu?

Server = Srv. 2008 r2
Clients = Win 7 x64 Prof.

Schonmal Danke an alle.
Mitglied: Borob14
24.11.2014 um 09:03 Uhr
Moin,

funktioniert nicht? -> Fehlermeldung

Ansonsten Ansatzpunkte:
auf was wirkt die GPO? Computer und nicht Benutzer hoffe ich
Script liegt auf einer Freigabe die Domaincomputer lesen und ausführen dürfen?

Alternativ eine Benutzer GPO draus machen allerdings benötigt der User dazu lokale ADM Rechte.

mfg Rob
Bitte warten ..
Mitglied: colinardo
24.11.2014, aktualisiert um 12:17 Uhr
Hallo r00t-1337,
du kannst bei den GPOs nicht auf die Reihenfolge vertrauen, vor allem warten die einzelnen GPOs nicht aufeinander. Außerdem werden Startscripte vor der Anwendung des GPO-Userteils ausgeführt.
Kopiere die MSI-Datei auf ein Share gebe den Computerkonten Lesezugriff darauf(inkl. NTFS ACLs) und verteile nur die Installations GPO welche die MSI von dem Share installiert, fertig ! Das ist gängige Praxis und funktioniert problemlos, wenn man nicht vergisst die richtigen Rechte auf dem Share und den ACLs zu setzen (Computerkonten benötigen Zugriff, da zu dem Zeitpunkt noch kein User am Rechner angemeldet ist! Ich vermute das kanntest du nicht und hast deswegen diesen Umweg gewählt)

Außerdem gibt es in den GPOs einen Extra Abschnitt für das Softwaredeployment, dann brauchst du nicht mit extra Scripten zu hantieren !!

Grüße Uwe
Bitte warten ..
Mitglied: r00t-1337
24.11.2014 um 14:59 Uhr
Mahlzeit, und danke für eure Antworten.

Ich habe es jetzt nochmals neu erstellt bzw. die alten GPO gelöscht und eine komplett neue sowie einen neuen share des Installationsfiles erstellt.

Die Zugriffe hierauf passen (habe es auch mit Vollzugriff für Domänencomputer und Authentifizierten Benutzern probiert).

Die GPO wird gezogen, jedoch sehe ich im rsop unter Computerkonfig -> Softwareinstallation ein "Ausrufezeichen" ...

Die Ereignisanzeige sagt hierzu folgendes:

"Die Installation der Anwendung Trend Micro OfficeScan Agent der Richtlinie trend-micro-install-msi-v11 ist fehlgeschlagen. Fehler: %%1602"

Danke und VG
Bitte warten ..
Mitglied: colinardo
24.11.2014 um 15:13 Uhr
Zitat von r00t-1337:
Die Ereignisanzeige sagt hierzu folgendes:

"Die Installation der Anwendung Trend Micro OfficeScan Agent der Richtlinie trend-micro-install-msi-v11 ist fehlgeschlagen.
Fehler: %%1602"

MSI Beschreibung zum Fehler ...
ERROR_INSTALL_USEREXIT   1602   Die Installation wurde vom Benutzer abgebrochen.
http://esupport.trendmicro.com/solution/en-us/1095690.aspx
http://www.windowsnetworking.com/articles-tutorials/netgeneral/Group-Po ...

Hast du denn überhaupt den Client-Packager für das MSI benutzt?
http://clintboessen.blogspot.de/2010/01/trend-micro-client-packager.htm ...

Ansonsten das Windows Installer Logging aktivieren und die Logs studieren:
http://support.microsoft.com/kb/223300/de
Bitte warten ..
Mitglied: Borob14
24.11.2014, aktualisiert um 15:22 Uhr
Kann es sein das da schon eine alte Version drauf installiert ist? 1602 ist User-Abbruch
Kann aber auch Systembedingt sein (weil z.b. eine aktive Instanz davon läuft)

versuch mal die reine MSI in der GPO ohne "Hebel" ob du dann was an Fehlermeldungen bekommst.

Mit freundlichen Grüßen Rob

EDIT: da war einer schneller ^^
Bitte warten ..
Mitglied: r00t-1337
25.11.2014 um 09:27 Uhr
Moin zusammen,

ich habe es nochmals mit dem Client-Packer probiert.

MSI-Paket erstellt, in die GPO eingebunden, am Client nen gpupdate /force durchgeführt -> Neustart wurde verlangt, dieser wurde geamacht ..

--> Problem der Rechner bleibt bei ... Bitte warten hängen ... deaktiviere ich die Richtlinie und starte den Rechner erneut funktioniert alles.
Bitte warten ..
Mitglied: colinardo
25.11.2014, aktualisiert um 17:33 Uhr
Zitat von r00t-1337:

--> Problem der Rechner bleibt bei ... Bitte warten hängen ... deaktiviere ich die Richtlinie und starte den Rechner
erneut funktioniert alles.
Siehe Link oben, Installer-Logging aktivieren und Log nach Ursache durchforsten !
Bitte warten ..
Ähnliche Inhalte
Windows Userverwaltung
Neue Version (msi Paket) lässt sich nicht über GPO ausrollen? (5)

Frage von ordi303 zum Thema Windows Userverwaltung ...

Windows Netzwerk
Installation von MSI Paket über GPO nicht möglich: Fehler 1602 (1)

Frage von patriwag zum Thema Windows Netzwerk ...

Entwicklung
MSI Dateien als Administrator von einer HTA installieren (1)

Frage von iGordon zum Thema Entwicklung ...

Netzwerkmanagement
gelöst Via cmd MSI im hintergrund und als admin bei usern installieren (9)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(6)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(5)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Batch & Shell
gelöst Batch um Benutzer aus Sitzung abzumelden (15)

Frage von zeroblue2005 zum Thema Batch & Shell ...

LAN, WAN, Wireless
IP Sec Client legt Netzwerkkarte lahm (12)

Frage von mario87 zum Thema LAN, WAN, Wireless ...