Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Multicast IGMP Problem

Frage Netzwerke Netzwerkprotokolle

Mitglied: UnbekannterNR1

UnbekannterNR1 (Level 1) - Jetzt verbinden

16.02.2017, aktualisiert 11:04 Uhr, 715 Aufrufe, 7 Kommentare

Hallo zusammen,
Ich gerade ein Profi Problem und komme so nicht weiter. Es geht um Zwei arten von Switches, und Multicast zwischen diesen. Auf der Zeichnung sieht den aktuellen Aufbau. Wir haben die Enterasys S4 quasi durch die HP 5700 ersetzt. Das war auch das Ziel. Auf den Switches laufen natürlich diverse VLANs bei mir geht es aber nur um Vlan3. Das Routing übernimmt eine extra Firewall.

Zum Problem, die Server bilden eine Art Cluster das sich in alle Richtungen über Multicast unterhält (Nur die Server untereinander). Diese Software ist vom Hersteller vorgegeben und daran kann ich auch nichts ändern. Es funktioniert auch soweit Problemlos, nur sobald man die S4 (Switch10) aus dem Netzwerk entfernt bricht das Cluster komplett zusammen.
Logischerweise, denn auf dem Switch10 ist der IGMP-querier aktiviert, Sonst nirgends. Ich habe natürlich versucht diesen durch die HP zu ersetzen und folgendes eingegeben.
01.
 vlan 3  
02.
 igmp-snooping querier
Führt zum Ergebnis:
01.
  
02.
 display igmp-snooping 
03.
IGMP snooping information: Global 
04.
 IGMP snooping: Enabled 
05.
 Host-aging-time: 260s 
06.
 Router-aging-time: 260s 
07.
 Max-response-time: 10s 
08.
 Last-member-query-interval: 1s 
09.
 Report-aggregation: Enabled 
10.
 Dot1p-priority: -- 
11.
 
12.
IGMP snooping information: VLAN 3 
13.
 IGMP snooping: Enabled 
14.
 Drop-unknown: Disabled 
15.
 Version: 2 
16.
 Host-aging-time: 260s 
17.
 Router-aging-time: 260s 
18.
 Max-response-time: 10s 
19.
 Last-member-query-interval: 1s 
20.
 Querier: Enabled 
21.
 Query-interval: 125s 
22.
 General-query source IP: 0.0.0.0 
23.
 Special-query source IP: 0.0.0.0 
24.
 Report source IP: 0.0.0.0 
25.
 Leave source IP: 0.0.0.0 
26.
 Dot1p-priority: --
Danach habe ich sofort den Uplink zum Switch10 getrennt, und alle Dienste an den Servern neu gestartet. Aber leider ist dann offensichtlich irgendetwas anders, und der Cluster kommt nicht wieder hoch.

Nach einem "undo igmp-snooping querier" und dem wiederherstellen den Links ging es sofort wieder.


Hier die Konfigs (die Betreffenden Einträge) sonst stehen nur Benutzer und VLAN Zuweisungen drin.

Switch 10 Enterasys S4
01.
S4 Konfig  
02.
 
03.
# boot high-availability 
04.
set boot high-availability default-mode always 
05.
 
06.
# cdp 
07.
set cdp state disable 
08.
 
09.
# ciscodp 
10.
set ciscodp status disable 
11.
 
12.
# forcelinkdown 
13.
set forcelinkdown enable 
14.
 
15.
 
16.
# igmp 
17.
set igmp enable 3 
18.
set igmp query-enable 3

Switch 3-6
01.
set cdp state disable 
02.
set ciscodp status disable 
03.
 
04.
set igmpsnooping interfacemode *.*.* enable 
05.
set igmpsnooping adminmode enable
Die HP Switches
01.
 irf mode normal 
02.
03.
igmp-snooping 
04.
05.
 lldp global enable 
06.
07.
 interface range name bueros interface Ten-GigabitEthernet1/0/34 Ten-GigabitEthernet1/0/35 Ten-GigabitEthernet2/0/34 Ten-GigabitEthernet2/0/35 
08.
09.
 system-working-mode StandardBridge 
10.
 fan prefer-direction slot 1 port-to-power  
11.
 fan prefer-direction slot 2 port-to-power  
12.
 password-recovery enable 
13.
14.
vlan 1 
15.
16.
vlan 2 
17.
 name ELS 
18.
19.
vlan 3 
20.
 igmp-snooping enable



Die gelbe Linie ist ein Gebäudetrennung

switche - Klicke auf das Bild, um es zu vergrößern



Ich habe natürlich schon einiges dazu gelesen und bin der Meinung es hätte funktionieren müssen. Ich hoffe einer hat hier noch die rettende Idee für mich.
Ansonsten bin ich bei meinen Recherchen darauf hingewiesen worden, das es auch funktioniert wenn ich den Plain Multicast einfach zulasse. bzw. es nicht Filtere oder sonstiges das was man im Netzwerk eigentlich nicht haben will. Das wäre eine Option das im VLAN3 einfach zuzulassen. Die Frage ist halt nur wie?



Mitglied: michi1983
16.02.2017 um 10:54 Uhr
Hallo,

auch wenn ich jetzt vielleicht von Einigen nieder gemacht werde für meinen destruktiven Kommentar, aber dennoch:

Kannst du uns bitte allen den Gefallen tun und deinen Text noch einmal korrektur lesen?!
Da fehlen so viele Wörter, dass ich bei jedem 2. Satz rausfliege und 3 mal darüber lesen muss bis ich verstehe was du meinst.
Von den Rechtschreibfehlern mal abgesehen.

Gruß
Bitte warten ..
Mitglied: UnbekannterNR1
16.02.2017 um 11:05 Uhr
Ja, hast auf jeden Fall recht. Habe nochmal einiges korrigiert... Rechtschreibung wird aber weiterhin ein Problem bleiben
Bitte warten ..
Mitglied: holli.zimmi
16.02.2017 um 11:13 Uhr
Hi,

eine dumme Frage und Du bist Dir sicher das die HP 5700 das auch kann?
Version überprüft?

Gruß

Holli
Bitte warten ..
Mitglied: UnbekannterNR1
16.02.2017, aktualisiert um 11:32 Uhr
Sollte eigentlich oder? Lässt sich ja auch Konfigurieren. Und ist beides Version 2
Aber ich lasse mich auch gern eines besseren belehren.

Hier nochmal der Output aus dem Switch10
Dabei fällt mir QuerierIP auf, aber die liegt nicht im VLAN3 und ist eigentlich die Management IP.

01.
->show igmp config 
02.
 
03.
IGMP config for vlan 3 
04.
----------------------------------- 
05.
QueryInterval(sec.)         - 125 
06.
Status                      - Active 
07.
Version                     - 2 
08.
QueryMaxResponseTime(sec.)  - 10 
09.
Robustness                  - 2 
10.
LastMemberQueryIntvl        - 10 
11.
FastLeaveState              - Disabled 
12.
RouterAlert Required        - True 
13.
Filter Id                   - 0 
14.
Filter Status               - Disabled 
15.
Flow Age Time               - 0 (default - 2 x group age time) 
16.
QuerierUpTime               - 0 D  22 H  49 M  14 S 
17.
QuerierExpiryTime           - 0 D  0 H  0 M  0 S 
18.
QuerierIP                   - 10.10.22.1 
19.
 
20.
su)->show igmp groups 
21.
================================================================== 
22.
Group IP Address     224.5.6.7 
23.
VLAN                 3 
24.
 
25.
   Ports In Filter Mode Exclude   lag.0.104 
26.
   Ports In Filter Mode Include   none. 
27.
 
28.
   0.   Source IP Address         Any 
29.
        Forwarding Ports          lag.0.104 
30.
        Non-Forwarding Ports      none. 
31.
   --------------------------------------------------------------- 
32.
   1.   Source IP Address         10.10.3.9 
33.
        Source Port               lag.0.104 
34.
        Forwarding Ports          none. 
35.
        Non-Forwarding Ports      none. 
36.
   --------------------------------------------------------------- 
37.
   2.   Source IP Address         10.10.3.192 
38.
        Source Port               lag.0.104 
39.
        Forwarding Ports          none. 
40.
        Non-Forwarding Ports      none. 
41.
   --------------------------------------------------------------- 
42.
... gekürzt ---  
43.
 
44.
        Non-Forwarding Ports      none. 
45.
   --------------------------------------------------------------- 
46.
  17.   Source IP Address         10.10.3.246 
47.
        Source Port               lag.0.104 
48.
        Forwarding Ports          none. 
49.
        Non-Forwarding Ports      none. 
50.
   --------------------------------------------------------------- 
51.
================================================================== 
52.
Group IP Address     231.2.8.74 
53.
VLAN                 3 
54.
 
55.
   Ports In Filter Mode Exclude   lag.0.104 
56.
   Ports In Filter Mode Include   none. 
57.
 
58.
   0.   Source IP Address         Any 
59.
        Forwarding Ports          lag.0.104 
60.
        Non-Forwarding Ports      none. 
61.
   --------------------------------------------------------------- 
62.
================================================================== 
63.
Group IP Address     232.44.44.233 
64.
VLAN                 3 
65.
 
66.
   Ports In Filter Mode Exclude   lag.0.104 
67.
   Ports In Filter Mode Include   none. 
68.
 
69.
   0.   Source IP Address         Any 
70.
        Forwarding Ports          lag.0.104 
71.
        Non-Forwarding Ports      none. 
72.
   --------------------------------------------------------------- 
73.
================================================================== 
74.
Group IP Address     239.255.255.250 
75.
VLAN                 3 
76.
 
77.
   Ports In Filter Mode Exclude   lag.0.104 
78.
   Ports In Filter Mode Include   none. 
79.
 
80.
   0.   Source IP Address         Any 
81.
        Forwarding Ports          lag.0.104 
82.
        Non-Forwarding Ports      none. 
83.
   --------------------------------------------------------------- 
84.
================================================================== 
85.
Group IP Address     239.255.255.254 
86.
VLAN                 3 
87.
 
88.
   Ports In Filter Mode Exclude   lag.0.104 
89.
   Ports In Filter Mode Include   none. 
90.
 
91.
   0.   Source IP Address         Any 
92.
        Forwarding Ports          lag.0.104 
93.
        Non-Forwarding Ports      none. 
94.
   --------------------------------------------------------------- 
95.
================================================================== 
96.
 
97.
22 entries displayed (17 S,G, 5 *,G)
Bitte warten ..
Mitglied: aqui
LÖSUNG 16.02.2017, aktualisiert um 12:13 Uhr
Enterasys S4 quasi durch die HP 5700 ersetzt
Du Armer...vom Regen in die Traufe...
Wenn du auf beiden Switches einen Querrier konfigurierst sollte das das Problem im Handumdrehen fixen.
Klar, wenn wenn du einen singulären Querrier mit einmal entfernst muss das MC einen neuen auskaspern bzw. das schlägt fehl wenn es nur einen gibt und keinen Backup Querier im VLAN Segment.
Mit aktivem IGMP Snooping kann der Switch MC Frames nicht mehr fluten (was er dann ja auch gar nicht soll) und dann schmiert das Cluster ab. Works as designed...
Ein ideales Test Tool unter Windows für solche Umgebungen ist der Klassiker MC Hammer von Nortel:
http://www.michaelfmcnamara.com/files/avaya/mchammer_installer_for_wind ...
Bitte warten ..
Mitglied: UnbekannterNR1
27.02.2017 um 08:21 Uhr
Ich wollte nochmal eine Rückmeldung geben vor allem falls jemand mal das gleiche Problem haben sollte.

1. Es geht jetzt
2. Die HP Comware Geräte brauchen so wie es aussieht zwingend eine IP Adresse aus dem Vlan. (Bei der S4 nicht erforderlich)
3. Die Konfiguration auf der HP Seite sieht wie folgt aus.


01.
  
02.
#IP Vergeben   
03.
interface Vlan-interface x   
04.
ip address <vlan interface ip-adresse>  <Vlan Subnetzmaske> 
05.
vlan x 
06.
Igmp-snooping enable 
07.
Igmp-snooping querier 
08.
Igmp-snooping general-query source-ip <vlan interface ip-adresse> 
09.
Igmp-snooping special-query source-ip <vlan interface ip-adresse>
Bitte warten ..
Mitglied: aqui
27.02.2017 um 10:48 Uhr
Na ja wenn die HP Gurke selber Querrier sein soll geht das ja auch nicht ohne IP Adresse, das ist ja logisch und bei allen so.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
SG300 - Multicast-Problem (T-Entertain) (9)

Frage von fkerber zum Thema Router & Routing ...

Router & Routing
IGMP-Proxy auf Mikrotik RB3011 (8)

Frage von Sparki2002 zum Thema Router & Routing ...

Switche und Hubs
gelöst Cisco SG350 - Multicast TV VLAN - EntertainTV - Draytek Vigor2860 (15)

Frage von joshi04 zum Thema Switche und Hubs ...

LAN, WAN, Wireless
gelöst Multicast Routing in andere VLANs (6)

Frage von geforce28 zum Thema LAN, WAN, Wireless ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Windows Server
Kennwort vergessen bei Hyper vserver 2012r (12)

Frage von jensgebken zum Thema Windows Server ...

Linux Desktop
Bildschirmauflösung unter Linux festlegen (12)

Frage von itebob zum Thema Linux Desktop ...

Windows Userverwaltung
gelöst Administrator hat alle Rechte verloren (10)

Frage von mrdead zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Gebäude mit WLAN ausstatten (9)

Frage von udobec zum Thema LAN, WAN, Wireless ...