Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Musik abspielen (mittels emff) scheitert an ActiveX vom IE

Frage Entwicklung Webentwicklung

Mitglied: bigiana

bigiana (Level 1) - Jetzt verbinden

22.08.2011, aktualisiert 18:44 Uhr, 4074 Aufrufe, 2 Kommentare

Hallo,

ich möchte auf meiner Webseite dem Besucher das Abspielen einer kleinen Musik ermöglichen. Dazu verwende ich eine emff.swf, und beim Drücken des Start-Buttons gehts los. Das klappt im Firefox. Aber im Internet-Explorer erscheint (schon beim Aufbau der Seite) "Das Ausführen von Skripts bzw. ActiveX-Steuerelementen ... aus Sicherheitsgründen eingeschränkt."
Meine Codes sind:

<object type="application/x-shockwave-flash" data="emff_silk_button.swf" width="110" height="34">
<param name="movie" value="emff_silk_button.swf">
<param name="FlashVars" value="src=test.mp3">
</object>

bzw.

<!--[if IE]>
<object classid="CLSID:D27CDB6E-AE6D-11cf-96B8-444553540000" width="200" height="55">
<param name="movie" value="emff_silk_button.swf?src=test.mp3">
<![endif]-->
<!--[if !IE]><!-->
<object type="application/x-shockwave-flash"
data="emff_silk_button.swf?src=test.mp3" width="200" height="55">
<!--<![endif]-->
</object>

bzw.

<object classid="CLSID:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#v ..."
width="100" height="29">
<param name="movie" value="../bilder/emff.swf">
<param name="FlashVars" value="src=../bilder/test.mp3&amp;autostart=yes">
<param name="bgcolor" value="#ffaa22">
<embed type="application/x-shockwave-flash" width="100" height="30"
pluginspage="http://www.macromedia.com/go/getflashplayer"
src="../bilder/emff.swf"
FlashVars="src=../bilder/test.mp3&amp;autostart=yes"
bgcolor="#ffaa22">
</embed>
</object>

Ich könnte bei meinem IE die Sicherheitseinstellungen für ActiveX-Elemente runtersetzen, das hilft aber den Seitenbesuchern nichts, und außerdem kommen dann andere Warnungen. Muss denn die .swf-Datei bestimmte Sicherheitsvoraussetzungen erfüllen, oder was gibts da für Lösungen?
Für Hinweise bin ich sehr dankbar.

Bigiana
Mitglied: Luckyguy
22.08.2011 um 20:16 Uhr
also zunächst einmal wenn im firefox was gut läuft sei dir gewiss im IE geht es nicht. und zweitens würd ich dir empfehlen dir den youtube player einzubinden ist die einfachste lösung und auch valide. und auf flash würde ich verzichten wenn es irgend geht.
Bitte warten ..
Mitglied: bigiana
23.08.2011 um 17:47 Uhr
... war alles ein Irrtum von mir!
emff und der FlashPlayer funktionieren auch im IE, aber eben nicht dann, wenn ich die html-Datei lokal mit dem IE aufrufe.
bigiana
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Microsoft
gelöst Lokale Intranet Site im IE wird nicht über GPO hinzugefügt (1)

Frage von Hanuta zum Thema Microsoft ...

Exchange Server
gelöst OWA funktioniert nur im IE (18)

Frage von ketanest112 zum Thema Exchange Server ...

Administrator.de Feedback
gelöst IE Fehlermeldung und Fehldarstellung des Forums (3)

Frage von H41mSh1C0R zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (18)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...

Grafikkarten & Monitore
Neue Graifkkarte - kein Bild (10)

Frage von bestelitt zum Thema Grafikkarten & Monitore ...

Exchange Server
gelöst Exchange 2013 - Kontakte aus CSV importieren (9)

Frage von hesper zum Thema Exchange Server ...