Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Trotz MX Record und Erreichbarkeit des Exchange 2010 Versand an den Hostingprovider

Frage Microsoft Exchange Server

Mitglied: DarkLevi

DarkLevi (Level 1) - Jetzt verbinden

08.03.2014 um 03:29 Uhr, 1612 Aufrufe, 8 Kommentare, 3 Danke

Hi Leute,

ich bin gerade etwas verwirrt, und hoffe dass ihr mir helfen könnt:

ich habe heute bei einem Kunden einen Domainumzug vorgenommen, bei dem neuen Hoster bin ich seit längerer Zeit Reseller, weswegen ich deren NS in mein System eingetragen habe.
Dadurch werden die Änderungen der DNS-Einträge innerhalb von Sekunden umgesetzt. Zur Theorie:

MX-Record weist auf den Exchange 2010 Server welcher die Mails empfangen und verteilen soll.

(Aus Datenschutzrechtlichen Gründen werde ich die Domänennamen ändern!)

MX Einträge wie folgt:
contoso.com        MX preference = 10, mail exchanger = remote.contoso.com 
contoso.com        MX preference = 50, mail exchanger = mail2.bytecamp.net
Dementsprechen der nslookup:

nslookup -q=MX contoso.com 
Server:  ns1.bytecamp.net 
Address:  212.204.60.4 
 
contoso.com        MX preference = 10, mail exchanger = remote.contoso.com 
contoso.com        MX preference = 50, mail exchanger = mail2.bytecamp.net 
contoso.com        nameserver = ns1.bytecamp.net 
contoso.com        nameserver = ns2.bytecamp.net 
remote.contoso.com    internet address = XXX.153.XXX.173 
mail2.bytecamp.net      internet address = 212.204.60.30 
ns1.bytecamp.net        internet address = 212.204.60.4 
ns2.bytecamp.net        internet address = 212.204.49.83
Also Ausgabe und IP sind korrekt.
Im nächsten Schritt eine Telnet-Session auf remote.contoso.com über Port 25:

Microsoft Telnet> o remote.contoso.com 25 
 
220 remote.contoso.com Microsoft ESMTP MAIL Service ready at Sat, 8 Mar 2014 03:08:29 
+0100 
EHLO localhost 
250-remote.contoso.com Hello [93.135.50.91] 
250-SIZE 10485760 
250-PIPELINING 
250-DSN 
250-ENHANCEDSTATUSCODES 
250-STARTTLS 
250-AUTH 
250-8BITMIME 
250-BINARYMIME 
250 CHUNKING 
MAIL FROM:info@aus.spambot.schutz.gründen.entfernt 
250 2.1.0 Sender OK 
RCPT TO:mein.empfänger@contoso.com 
250 2.1.5 Recipient OK 
DATA 
354 Start mail input; end with <CRLF>.<CRLF> 
Betreff: Dies ist eine Testmail 
 
Hier ist eine Testmail an unsere Exchange 2010 Server. 
Diese Mail wird direkt und ohne Fehler durchgestellt! 
 
250 2.6.0 <3455eb32-8ca0-4dd3-87a9-5f9edf645cc6@MSEX-01.contoso.local> [Internal 
Id=1775] Queued mail for delivery
Diese Mail kommt sekunden später bei mir an.
So weit so gut... ABER wenn ich nun aus Outlook (Privatrechner NICHT am Exchange) oder auch über den Webmailer von bytecamp (unserem neuen Hoster) eine Testmail verschicke kommt diese *trommelwirbel* bei bytecamp an?????

Ich verstehe dass momentan überhaupt nicht... Um eine weitere Fehlerquelle auszuschließen hier der nslookup über den Google-Public-DNS:

nslookup -q=MX contoso.com 8.8.8.8 
Server:  google-public-dns-a.google.com 
Address:  8.8.8.8 
 
Nicht autorisierende Antwort: 
contoso.com        MX preference = 10, mail exchanger = remote.contoso.com 
contoso.com        MX preference = 50, mail exchanger = mail2.bytecamp.net
Also hat es sich schon teilweise verteilt, auf jeden Fall sind auf BEIDEN DNS-Servern die in meinem System (auch im Router) eingestellt sind die richtigen einträge.

Ich weiß im Moment leider nicht weiter da ich keine Idee mehr habe woran das liegen kann.
Ich hoffe einer von euch hat noch eine Idee

Vielen Dank im Voraus
Euer Levi
Mitglied: colinardo
08.03.2014, aktualisiert um 11:57 Uhr
Hallo Levi,
vermutlich verwenden die Mailserver von Bytecamp noch DNS-Einträge aus deren Cache die noch nicht abgelaufen sind. Mal etwas warten, dann behebt sich das Problem vermutlich von selbst.

Grüße Uwe
Bitte warten ..
Mitglied: DarkLevi
08.03.2014, aktualisiert um 12:03 Uhr
*kopf* *tisch* *kopf* *tisch* *kopf* *tisch*

War gstern wohl einfach schon zu spät, auf die Idee bin ich depp gar nicht mehr gekommen....
Hab ja selber noch TTL auf 86400(24h) gesetzt xD

Danke dir Uwe, wenns morgen noch nicht geht, schrei ich nochmal ;)
Bitte warten ..
Mitglied: DarkLevi
09.03.2014, aktualisiert um 13:06 Uhr
So nun am Freitag habe ich es eingerichtet, und heute am Sonntag geht es immer noch nicht.

Jetzt weiß ich endgültig nicht mehr weiter. Zwischenzeitlich behelfe ich mir jetzt mit POPCon.

Ich werde morgen mal bei bytecamp anrufen und fragen ob die noch eine Idee haben.

Falls euch noch etwas einfällt, ich habe im moment für jede noch so abwegige Idee ein offenes Ohr.

btw: hier nochmal die direkte Abfrage der bytecamp-Nameserver
nslookup -q=MX contoso.com ns1.bytecamp.net 
Server:  ns1.bytecamp.net 
Address:  212.204.60.4 
 
contoso.com        MX preference = 50, mail exchanger = mail2.bytecamp.net 
contoso.com        MX preference = 10, mail exchanger = remote.contoso.com 
contoso.com        nameserver = ns2.bytecamp.net 
contoso.com        nameserver = ns1.bytecamp.net 
rwa.contoso.com    internet address = XXX.153.XXX.173 
mail2.bytecamp.net      internet address = 212.204.60.30 
ns1.bytecamp.net        internet address = 212.204.60.4 
ns2.bytecamp.net        internet address = 212.204.49.83
nslookup -q=MX contoso.com ns2.bytecamp.net 
Server:  ns2.bytecamp.net 
Address:  212.204.49.83 
 
contoso.com        MX preference = 10, mail exchanger = remote.contoso.com 
contoso.com        MX preference = 50, mail exchanger = mail2.bytecamp.net 
contoso.com        nameserver = ns1.bytecamp.net 
contoso.com        nameserver = ns2.bytecamp.net 
rwa.contoso.com    internet address = XXX.153.XXX.173 
mail2.bytecamp.net      internet address = 212.204.60.30 
ns1.bytecamp.net        internet address = 212.204.60.4 
ns2.bytecamp.net        internet address = 212.204.49.83
Bitte warten ..
Mitglied: TobiasNYC
09.03.2014 um 18:56 Uhr
... existieren bei "bytecamp" online Postfächer der selben Domain, wenn ja dann entfernen die mal alle!
Oder verwenden einen mailaccount für die testmail die nicht über bytecamp geroutet wird z.B. google, gmx. usw.
Bitte warten ..
Mitglied: DarkLevi
10.03.2014, aktualisiert 11.03.2014
Zitat von TobiasNYC:

... existieren bei "bytecamp" online Postfächer der selben Domain, wenn ja dann entfernen die mal alle!

Ja natürlich, bei bytecamp sind die meisten Postfächer als Fallback angelegt. Ich habe aber ganz bewusst für die Testmail ein Postfach genommen dass bei bytecamp nicht existiert, und die Mail kam dennoch im Catch-All Postfach an.

Oder verwenden einen mailaccount für die testmail die nicht über bytecamp geroutet wird z.B. google, gmx. usw.

Die Testmails von mir wurden von allen möglichen Providern versandt, von daher....
EDIT: Dieses Statement von mir stimmt nicht, habe nicht aufgepasst und dachte ich hätte es getan!!!
Bitte warten ..
Mitglied: TobiasNYC
10.03.2014 um 10:39 Uhr
Zitat von DarkLevi:

Ja natürlich, bei bytecamp sind die meisten Postfächer als Fallback angelegt. Ich habe aber ganz bewusst für die
Testmail ein Postfach genommen dass bei bytecamp nicht existiert, und die Mail kam dennoch im Catch-All Postfach an.

... ich weiß z.B. von allinkl das es hierbei Probleme gibt, mails die von allinkl stammen würden in diesem Fall immer intern geroutet werden..

Ja. und wenn du den MX Eintrag von bytecamp entfernst zu Testzwecken, was ist das Ergebnis? Gibt es SMTP Logs der Sendeserver?
Bitte warten ..
Mitglied: DarkLevi
11.03.2014 um 00:58 Uhr
Jetzt muss ich zu meiner Schande eingestehen dass ich vor lauter Hektik und Streß wegen der extrem frühen Deadline scheinbar doch nur Testmails von anderen bytecamp-Domänen gesendet habe. Ich habe wohl einfach zu viele Domains dort =D

Ich habe heute früh mit dem wirklich exzellenten Support von bytecamp telefoniert. Keine 5 Minuten später kam der Rückruf in welchem mir erklärt wurde dass meine Testmail-Domäne erkannt hat dass die betreffende Domäne auch bei bytecamp ist und somit den DNS gar nicht mehr angefragt hat. Im selben Atemzug wurde mir versichert dass sich die Administratoren von bytecamp (welche auch gleichzeitig die Supportleitung bedienen) sich des Problems annehmen.

Es hat keine 10 Minuten gedauert und es war umgestellt. Nun funktioniert endlich alles wie es soll. *grins*

Vielen Dank für eure wertvollen Tipps, und wieder einmal vielen Dank an den ausgezeichneten und schnellen Support von bytecamp
Bitte warten ..
Mitglied: TobiasNYC
11.03.2014 um 13:24 Uhr
Zitat von DarkLevi:
Vielen Dank für eure wertvollen Tipps, und wieder einmal vielen Dank an den ausgezeichneten und schnellen Support von
bytecamp

Über ein "Zur Lösung beigetragen" würden sich alle Helfer freuen - der Thread gilt damit auch als gelöst

MfG
Bitte warten ..
Ähnliche Inhalte
Exchange Server
MX records und problem mit domain mit chinesischer tld (4)

Frage von kal10bach zum Thema Exchange Server ...

LAN, WAN, Wireless
Externe Erreichbarkeit sicherstellen (9)

Frage von Mr.Error zum Thema LAN, WAN, Wireless ...

Exchange Server
Exchange 2010 Migration zu Exchange Online (10)

Frage von mastersp zum Thema Exchange Server ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
gelöst Raid-Controller (Areca) Datenverlust trotz R5 (16)

Frage von sebastian2608 zum Thema Festplatten, SSD, Raid ...

Server-Hardware
HP ProLiant DL380 G7, POST Error: 1785-Drive Array not Configured (10)

Frage von Paderman zum Thema Server-Hardware ...

Windows Server
Drucker per GPO auf Userebene freigeben (9)

Frage von Stefan007 zum Thema Windows Server ...

Microsoft Office
gelöst Office 365 Pro Domäne einrichten OHNE Webseite (9)

Frage von thklemm zum Thema Microsoft Office ...