Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

mysqldump misslingt...

Frage Entwicklung Datenbanken

Mitglied: gijoe

gijoe (Level 2) - Jetzt verbinden

23.04.2007, aktualisiert 30.04.2007, 3450 Aufrufe, 5 Kommentare

Hallo, ich möchte einen simples Backup von allen Mysql-DB's machen. Dazu gab ich folgendes ein:
mysqldump --opt -u root -p --all-databases > backup.sql

Irgendwie gibts immer Probleme mit dem "mdl_cache_text.MYD", was immer auch das ist. Ich benutze Mysql 3.23. Hat jemand einen Ansatz?

Änderung (01.05.2007 1:29):
- Ich habe den Beitrag als "GELÖST" markiert.

Dani (Moderator)
Mitglied: ghofmann
23.04.2007 um 16:46 Uhr
Ich weiß nicht, ob Du das Passwort jetzt nur aus Gründen der Sicherheit weggelassen hast...

Es muss jedenfalls nach dem -p gleich (ohne Leerzeichen!) das Passwort folgen.

Probier doch zuerstmal, eine einzelne DB zu sichern statt alle. Klappt das?
Bitte warten ..
Mitglied: Dani
23.04.2007 um 18:54 Uhr
G' Abend,
ansonsten mal so probieren:
01.
... 
02.
"mysqldump.exe" --user=root --password=test --all-databases > "%dir_src%\databases.sql" 
03.
....
Gruß
Dani
Bitte warten ..
Mitglied: gijoe
24.04.2007 um 11:06 Uhr
Ja, das Passwort wird dann separat abgefragt. Das ganze läuft unter unix, eine einzelne Database lässt sich ohne Probleme dumpen.
Bitte warten ..
Mitglied: Dani
24.04.2007 um 17:19 Uhr
Hi,
also ich habe mal bei uns in Nürnberg aufm Scriptserver folgende Zeile gefunden:
01.
mysqldump -u admin -test --database tennis > /tennis-`date --universal +%d.%m.%Y`.sql
Funktioniert bei uns prima unter Suse und Debian!!


Gruß
Dani
Bitte warten ..
Mitglied: gijoe
30.04.2007 um 21:08 Uhr
Hab jetzt alle DB's einzeln gedumpt, mit einem Script. thx
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (19)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...