Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Mysteriös - regsvr32 meldet LoadLibrary fehlgeschlagen - Das angegebene Modul wurde nicht gefunden - Obwohl Datei vorhanden

Frage Microsoft

Mitglied: SueImWeb

SueImWeb (Level 1) - Jetzt verbinden

24.11.2009 um 14:59 Uhr, 23432 Aufrufe, 3 Kommentare

ActiveX Dll im Verzeichnis vorhanden, war auch schon mal registriert, jetzt behauptet Windows felsenfest, die Datei sei nicht vorhanden.

Hallo an alle,

diesmal konnte ich zu meinem Problem über die Suchfunktion leider nichts finden, deshalb bitte ich euch mal aktiv um Hilfe.
Ich hoffe, es verstößt nicht gegen irgendwelche Regeln, wenn mein folgendes Problem mit meiner Tätigkeit am Arbeitsplatz zu tun hat und nicht privater Natur ist.

Die Fa. in der ich arbeite vertreibt seit über 3 Jahren ein kleines Schnittstellentool aus Eigenentwicklung, für ein USB Multifunktionsgerät.
Bei der Installation des Tools (durch mich oder einen Kollegen) muss eine vom Hersteller des Geräts gelieferte ActiveX Dll registriert werden.

Letzte Woche habe ich wieder eine solche Installation bei einem Kunden durchgeführt. Zunächst lief alles problemlos wie immer, dies war am Donnerstag.
Am Montag rief der Kunde dann an und erzählte mir, dass beim Start der Anwendung eine Fehlermeldung erscheint.
Der Text der Meldung wies eindeutig darauf hin, dass diese Dll nicht geladen werden konnte.

Ich versuchte deshalb, die Dll einfach noch mal zu registrieren - keine Chance, Windows meldete ständig, es könne die Datei nicht finden.
Auch deregistrieren war natürlich nicht möglich.

Um auszuschließen, dass die Datei eine Macke hat, schickte ich dem Kunden eine Kopie der Dll, die ich unmittelbar zuvor auch meinem und einem weiteren Rechner getestet hatte.
Aber Pustekuchen, auch diese lässt sich nicht registrieren - völlig unabhängig davon, in welchem Verzeichnis sie liegt.

Der angemeldete Benutzer ist selbstverständlich Administrator.
Auf den beiden betroffenenen PCs läuft Windows XP Pro.

Leider ist der Kunde sehr weit von uns entfernt und hat kein Internet, daher keine Fernwartung möglich.
Die EDV Fa., von der dieser Kunde hardwaretechnisch betreut wird, hat allerdings einen Zugang per ISDN und war so nett, sich die Sache mal anzusehen - mit exakt demselben Ergebnis.
Auch diese Techniker sind ratlos.

Hat irgend jemand eine Idee, was die Ursache sein könnte?

Grüße
und vielen Dank für's Lesen

Sue
Mitglied: Tommy70
24.11.2009 um 15:22 Uhr
Schau dir mal das an. Dort sind die Fehlermeldungen von regsvr32 beschrieben. Vielleicht ist ja was dabei.
Edit: Noch was. Ist im Pfadnamen der DLL ein Leerzeichen? Dann musst du den Pfad beim Registrieren mit " " versehen. Soweit ich mich erinnere hat regsvr Probleme mit Leerzeichen im Pfad.
Bitte warten ..
Mitglied: SueImWeb
24.11.2009 um 15:28 Uhr
Danke für die schnelle Antwort, leider gab der Artikel auch keinen hilfreichen Hinweis.
Beim Registrierungsversuch erscheint auch kein Fehlercode, sondern nur "Das angegebene Modul wurde nicht gefunden."
Bitte warten ..
Mitglied: Tommy70
24.11.2009 um 15:30 Uhr
Noch was ist mir eingefallen. Das Problem muss ja nicht an deiner activeX-Dll liegen. Eher fehlt eine DLL die von deiner DLL verwendet wird.
Mit dem Dependencywalker sollte es dir möglich sein zu überprüfen ob alle notwendigen Dateien vorhanden sind.
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Heiß diskutierte Inhalte
Festplatten, SSD, Raid
PC stellt nach dem Bios ab (20)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

Server-Hardware
Einem Stromausfall entgegen wirken (19)

Frage von OIOOIOOIOIIOOOIIOIIOIOOO zum Thema Server-Hardware ...

Windows 7
Freeware MSI Tool (13)

Frage von uridium69 zum Thema Windows 7 ...

Microsoft Office
gelöst VBA Excel Problem mit UserForm, ListBox und TextBox (12)

Frage von abuelito zum Thema Microsoft Office ...