Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Nachbarzelle ausgeben!Excel 2003

Frage Microsoft Microsoft Office

Mitglied: Dudelidude

Dudelidude (Level 1) - Jetzt verbinden

17.08.2011 um 13:53 Uhr, 7457 Aufrufe, 6 Kommentare

Hallo liebe Leute mal wieder qualmt der Kopf und ich brauche eure Hilfe.

Ich habe eine Matrix, und jede Spalte der Matrix enthält eine PersonenID oder deren Status. Also Spalte A=DID(als Bsp.für die PersonenID) und B= R+W (read and write) diese Logik setzt fort bis Zelle AR. Jede Spalte hat eine Überschrift,die für eine Region steht. Spalte A trägt z.B. die Überschrift EU.

Nun habe ich im 1. Schritt mir den Namen PersonenID ausgeben lass über eine wenn-funktion, da ich gleich geprüft haben wollte ob auch die richtige PersonenID eingetragen war.
Im 2.Schritt möchte ich nun den Status ausgegeben haben der in der rechten Nachbarzelle steht. Sverweis geht dazu nicht,aufgrund der Martixstruktur.
Hat jemand eine Ahung wie ich das machen kann?
Mitglied: Metzger-MCP
17.08.2011 um 16:02 Uhr
Sverweis geht dazu nicht,aufgrund der Martixstruktur. ?? Was meinst du mit Matrixstrucktur ?

kannst du mal ein Beispiel Screeny einbinden oder mir schicken ? komme gerade nicht hinter was du genau benötigst.

Mit freundlichen Grüßen Uwe
Bitte warten ..
Mitglied: Dudelidude
18.08.2011 um 11:52 Uhr
Hallo Uwe,

vielen Dank für deine mühe. Wie kann ich denn ein Bild von meiner Festplatte hier reinladen?
Bitte warten ..
Mitglied: Dudelidude
18.08.2011 um 15:59 Uhr
Bei einem Sverweis muss das Suchkriterium immer in der 1. Spalte stehen und ich kann dann eine weitere Spalte wählen, die mir ausgegeben werden soll. Nun steht aber das Suchkriterium mal in der 5ten,7ten oder 27ten Spalte und das was ausgegeben werden soll immer in der nächsten Spalte: also in der 8ten, 9ten oder 28ten. Spalte

Ich bräuchte eine Wenn-Funktion, die mir die Zellkoordinat ausgibt.Geht sowas?
=wenn(Id=Id;Koordinate der Zelle;"Fehler") oder sowas!Jemand eine Idee?
Bitte warten ..
Mitglied: Metzger-MCP
18.08.2011 um 17:51 Uhr
Hm ja nein vllt zusammengebaut

du hast die Möglichkeit den Matrixbereich A1:B11 dynamisch zu verschieben.=SVERWEIS(M2;A1:B11;2;FALSCH)
der Befehl lautet dabei BEREICH.VERSCHIEBEN(A1:B11;Zeilenrunter;Spaltenrechts;;)
Zusammengebaut -> =SVERWEIS(M2;BEREICH.VERSCHIEBEN(A1:B11;0;M3;;);2;FALSCH)
Dann brauchst du 2 Formeln. und 2 Abfrage Felder

  • Spalten ID Herrausfinden =WVERWEIS(M1;A1:J2;2;FALSCH)
  • Wert herrausfinden =SVERWEIS(M2;BEREICH.VERSCHIEBEN(A1:B11;0;M3;;);2;FALSCH)

Zelle M1 -> ID WERT -> suchen nach dem ID bezogenen Matrixanfang
Zelle M2 -> Efektivsuchewert -> suchen dem Wert der aus der verschobenen Matrix gesucht wird

Zelle M3 -> Formel zur Spaltenfindung -> =WVERWEIS(M1;A1:J2;2;FALSCH)
suche ID ( Zelle M1 ) aus Matrix ( Zelle A1:J2 ) und gebe den Inhalt Spalte 2 ( Spaltenverschiebung )

Zelle M4 -> Formel zum Sverweis - Ergebnis -> =SVERWEIS(M2;BEREICH.VERSCHIEBEN(A1:B11;0;M3;;);2;FALSCH)
suche Efektivsuchewert ( Zelle M2 ) in der Suchmatrix ( Zelle A1:B11 ) mit der Verschiebung um ( Zelle M3 ) Spalten nach rechts in der 2 Spalte


Gesamtmatrix ( Zelle A1:J11 )

A B C D E F G H I J ( Überschrift / ID )
1 2 3 4 5 6 7 8 9 10 ( Spaltenverschiebung / neue Hilfszeile )
2 4 7 11 16 22 29 37 46 56
3 5 8 12 17 23 30 38 47 57
4 6 9 13 18 24 31 39 48 58
5 7 10 14 19 25 32 40 49 59
6 8 11 15 20 26 33 41 50 60
7 9 12 16 21 27 34 42 51 61
8 10 13 17 22 28 35 43 52 62
9 11 14 18 23 29 36 44 53 63
10 12 15 19 24 30 37 45 54 64

Mit freundlichen Grüßen Uwe

p.s. ich kann notfalls auch eine zip schicken ...
Bitte warten ..
Mitglied: Dudelidude
19.08.2011 um 10:45 Uhr
Hallo Uwe,

ich hab das Problem jetzt anders gelöst. Ich habe mir eine Hilfsspalte erzeugt und diese mit einer vergleich Funktion beschrieben. Diese Funktion gibt mir ja die Spaltennummer aus, in der das Vergleichswort(Perso-ID) steht aus. Im zweiten Schritt hab ich dann einen Sverweis genutzt , der sich auf die Hilfsspalte bezieht, die Spaltennummer +1 nutzt und mir so den Status in der folgenden Zelle ausgibt. Das Funktioniert soweit auch sehr gut.
Das Problem ist nun, dass die Datenmatrix so groß ist und ich doch so viele Formeln benutze, dass es Excel 2003 nicht mehr schafft. Kann das sein?Jedenfalls kann ich die Seite nicht mehr via F9 berechnen(Autoberechnung hab ich ausgestellt, da mein PC schon etwas älter ist)

Ich werd mich jetzt mal mit deiner Idee oben beschäftigen und mal gucken ob ich diese zum Laufen bringe. Vielen Dank erstmal für deine Hilfe und deine Mühe.
Bitte warten ..
Mitglied: Metzger-MCP
19.08.2011 um 10:52 Uhr
Angebot steht noch, kann dir mein Muster zusenden, ich habe es zwar oben beschrieben, aber wenn man es sieht , ist es oft beser ...

PM mit Email ...

Mit freundlichen Grüßen Uwe
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Batch & Shell
gelöst Mit Batchdatei Informationen auslesen und diese strukturiert in Excel ausgeben (9)

Frage von Flodsche zum Thema Batch & Shell ...

VB for Applications
gelöst Windows Ordnerstruktur, Pfad und Dateiname in Excel ausgeben (2)

Frage von zlep01 zum Thema VB for Applications ...

Microsoft Office
Darstellung einer Produktionsmenge in einer Excel Übersicht! (4)

Frage von Magnus32x1 zum Thema Microsoft Office ...

Batch & Shell
gelöst Loginzeiten aus dem Ereignisprotokoll in Excel schreiben (1)

Frage von l-Ne0n zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...