Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Nachrichten per AS2 versenden klappt nicht immer?

Frage Internet Server

Mitglied: SiSc.81

SiSc.81 (Level 1) - Jetzt verbinden

11.06.2012 um 15:36 Uhr, 4870 Aufrufe, 15 Kommentare

Hallo,
ich habe in unserer Firma folgende Aufgabe: Es soll ein Datenaustausch per AS2 mit einem Partner erfolgen. Wir haben den AS2 Connect von Seeburger gekauft. Soweit habe ich alles konfiguriert, nur kommen die Nachrichten nicht beim Partner n. Bei mir steht erfolgreich versendet, aber auf der Gegenseite ohne Erfolg. Kann mir jemand etwas unter die Arme greifen?
Mitglied: Pago159
11.06.2012 um 16:45 Uhr
Hallo SiSc.81,

könntest du mal bitte die Konfiguration Posten? mit abgeänderten Daten (Datenschutz).
Bitte auch die leer gelassenen Felder. vll kann dir dann der ein oder andere Helfen.
Bitte warten ..
Mitglied: SiSc.81
12.06.2012 um 08:36 Uhr
Hallo ja kann ich machen.

OK wo fängt man am besten an?!?
Als eigene Identität habe ich unseren Firmennamen verwendet und als ID unsere GLN. Signatur und Entschlüsselungszertifikate sind eigens aus der Software heraus erstellt und in beiden Fällen das Gleiche!
Als Partner habe ich konfiguriert:
Name - Firma XY
ID - vom Partner bereitgestellte ID
URL - http://xxx.xxx.xxx.xxx:80
Zertifikate - vom Partner bereitgestellt

Dann kommt die Sendekonfigurationich denke mal hier liegt der Fehler irgendwo)
Porttyp - Datei
Quellverzeichnis - eigens dafür auf dem Server angelegt
Content-Type - application/octet-stream
Signieren mit SHA-1
MDN - ??? welche URL trage ich hier ein? Unsere oder die, des Partners???

So, das ist die Konfiguration! Das komische ist - wir haben eine feste IP über die wir die Nachrichten empfangen. Wenn ich aber eine versende, dann bekomme ich im log die Nachrichten ID (z.B.abcdefghijklmnop@192.168.115.1) unseres Proxyservers, der auf dem Server ebenfalls läuft.
Gehen die Nachrichten jetzt mit der IP des Proxy raus oder mit der festen IP?
Komischerweise habe ich eine Nachricht erfolgreich versenden können. Aber alle nachfolgenden sind nie angekommen!!!
Bitte warten ..
Mitglied: Pago159
13.06.2012 um 08:02 Uhr
Hi, hat etwas gedauert.

Also für mich liest es sich erst einmal so, als würden die Nachrichten über den Proxy rausgehen.

URL, wessen IP hast du dort angegeben? Die vom Partner? Hat der auch eine Feste IP? Wenn nein, würde ein DYN-DNS helfen.
bei MDN gehe ich mal von eurer aus, da ja die Sendebestätigung zu euch kommen soll.

Filtert euer Proxy vll die Nachrichten? Schau mal in die Logs der Firewall, ob dort etwas vermerkt ist.

Lg Pago
Bitte warten ..
Mitglied: SiSc.81
13.06.2012 um 08:17 Uhr
Hi, danke für deine Antwort,

bei URL habe ich die Partner IP eingetragen. Das ist ja quasi wie die Mailadresse beim Emailversand!
Ja der Partner hat eine feste IP. Sogar 2 - eine für den Eingang und eine für den Ausgang.
In den Logs der Firewall kann ich nichts erkennen.
Vielleicht muß ich ja in den Settings eingeben, das er die Nachrichten per Proxy versenden soll.
Ich teste es mal...
Bitte warten ..
Mitglied: Pago159
13.06.2012 um 08:33 Uhr
Wenn deine Internetverbinung nur über den Proxy klappt, dann musst du diesen Natürlich auch angeben.
Wenn du allerdings von diesem Gerät ohne Proxy in´s Internet kannst, dann dürfte der Proxy auch nicht´s bekommen.

Kannst du denn Mails von deinem Partner empfangen?
Bitte warten ..
Mitglied: SiSc.81
13.06.2012 um 09:42 Uhr
Und genau da liegt das Problem. Empfangen ist kein Problem. Der Partner erhält auch eine MDN von unserem Server!
In meinem AS2-System werden die Nachrichten angeblich versendet. Es steht: "Nachricht erfolgreich übertragen, aber keinen Report erhalten!"
Bitte warten ..
Mitglied: Pago159
13.06.2012 um 10:15 Uhr
Hast du die möglichkeit, Remote mal auf das andere AS2-System zu schauen, und dann die Konfiguration bei dir entsprechend zu ändern? Oder dir mal die Konfiguration von dem anderen AS2-System schicken zu lassen?

Lg Pago
Bitte warten ..
Mitglied: SiSc.81
13.06.2012 um 10:23 Uhr
Nee, die werden mich nicht in ihr System lassen. Der Partner ist doch schon etwas größer und weltweit bekannt. Ich denke schon, das die wissen, was sie tun.
Die geben jedem neuen Partner ein sogenanntes 'Questionnaire' wo die eigenen Konfigurationen eingetragenen werden können und die Einstellungen des Partners schon vorgegeben sind.
Trotzdem klappt das nicht.
Mir bleibt ja immernoch der Support von Seeburger. Aber 125€ je angefangene halbe Stunde...
An irgendwas muß es ja liegen. Die Sache mit der MDN macht mir am meisten zu schaffen. Ich habe jetzt unsere feste IP als Empfänger eingetragen + den Port und noch /as2

Mach ich daran denn irgendwas falsch???
Bitte warten ..
Mitglied: Pago159
13.06.2012, aktualisiert um 11:04 Uhr
Hast du mal die Firewall einstellungen geschaut, dass die Ports auch offen sind.

Ansonsten frag doch mal bei der anderen Firma an, ob die nicht eine Beispielkonfiguration zusenden können?
bzw. ein HowTo, das wäre ja günstiger, als den Support zu nutzen.
Bitte warten ..
Mitglied: SiSc.81
13.06.2012 um 11:39 Uhr
Ich habe die Ports nur an der Fritzbox geöffnet. In Server2003 selbst muß ich diese nicht öffnen oder?
Bitte warten ..
Mitglied: Pago159
13.06.2012 um 11:46 Uhr
Wenn du mit dem Seeberger AS2 Connector direkt über die Fritzbox gehst, ohne dass der Proxy genutzt wird, dann reicht das (du kannst ja eine entsprechende Route eintragen, welche den Traffic des AS2 Connectors direkt über die FB in´s Netz schickt). Dann hat auch nicht´s weiter mehr dazwischen zu funken.
Bitte warten ..
Mitglied: SiSc.81
13.06.2012 um 13:39 Uhr
So, jetzt halt mich für verrückt oder was auch immer. Mein Partner mailt grad: Hallo,
es sind alle Nachrichten, die Sie heute versendet haben, erfolgreich bei uns angekommen!
Wer soll das jetzt verstehen?
Bitte warten ..
Mitglied: Pago159
14.06.2012 um 08:48 Uhr
Hast du denn etwas an den Einstellungen geändert, seid der letzte Test gelaufen ist?
Bitte warten ..
Mitglied: SiSc.81
14.06.2012 um 08:53 Uhr
Ja und zwar habe ich hinter der URL (http://xxx.xxx.xxx.xxx:80) einfach noch '/as2' gesetzt und dann hats geklappt.
Bitte warten ..
Mitglied: Pago159
14.06.2012 um 10:07 Uhr
Immerhin klappt es jetzt ;)

Könntest du dann bitte noch den Beitrag als Gelöst markieren?

Lg Pago
Bitte warten ..
Ähnliche Inhalte
Apache Server
OsTicket Email versenden klappt nicht
gelöst Frage von ClepToManixApache Server5 Kommentare

Hallo, ich habe mir auf meinem Webserver das Ticket System OsTicket installiert. Das läuft soweit auch alles Reibungslos, nur ...

Exchange Server
Exchange 2013 CU7: Versand von großen Nachrichten klappt nicht
gelöst Frage von wixmixbinExchange Server16 Kommentare

Hallo zusammen, UPDATE Das Problem wurde durch die Installation von CU8 gelöst. beim internen Versand von großen Nachrichten (z.B. ...

Microsoft
Erfahrungen und Empfehlungen für EDI AS2 Anbindung
Frage von d4shoerncheNMicrosoft1 Kommentar

Guten Morgen Kollegen, wir benötigen für unsere Firma und unsere Lieferanten eine EDI-Verbindung mit AS2. Da wir hier leider ...

E-Mail
SPAM Nachrichten
Frage von ir-systemlineE-Mail3 Kommentare

Hallo zusammen, ich würde für folgendes Thema erneut Eure Hilfe, Rat und Unterstützung benötigen. Es geht mal wieder und ...

Neue Wissensbeiträge
Verschlüsselung & Zertifikate

Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows

Information von ticuta1 vor 1 StundeVerschlüsselung & Zertifikate

Interessant SSH-Kommando in CMD.exe und PowerShell

Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server19 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement17 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...