Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Nagios: Ram auslesen Problem

Frage Netzwerke Monitoring

Mitglied: MasterBlaster88

MasterBlaster88 (Level 1) - Jetzt verbinden

22.08.2013, aktualisiert 11:30 Uhr, 2206 Aufrufe, 2 Kommentare, 1 Danke

Hi Leute,

ich hab ein funktionierendes nagios system auf debian. Nun habe ich das Problem, dass ich bei der Memory-Abfrage auf einen Windows Host immer einen Fehler bekomme.
Ich teste immer erst das Plugin selbst bevor ich es in die Host Datei einfüge.
Die Verbindung zu dem Host muss stimmen, weil ich andere Dinge wie CPU Load, Drive und Dienste schon abfrage ohne Fehlermeldung


jetzt versuch ich es hiermit. In dem Ordner wo das Plugin liegt:

./check_snmp_mem.pl -H <IP-Adresse> -C <Community_String> -w 80,20 -c 90,30 -p 161


und bekomme folgenden Fehler:

ERROR: netsnmp : Received noSuchName(2) error-status at error-index 1.


Jetzt hab ich natürlich schon gegoogelt, aber werde aus den Fehlerbeschreibungen nicht schlau.
Wo liegt hier der Fehler???
Wenn ich ein anderes Plugin aus dem Ordner teste funktioniert es einwandfrei:
z.B:

./check_snmp_win.pl -H <IP-Adresse> -C <Community_String> -p 161 -n SNMP-Dienst

Antwort:

1 services active (matching "SNMP-Dienst") : OK


Ich verzweifle hier bald
Mitglied: Cthluhu
26.08.2013 um 12:41 Uhr
Hi,

Handelt es ssich zufällig um das plugin hier: http://nagios.manubulon.com/snmp_mem.html
Da steht dass es für Windows-Hosts nicht verwendet werden soll, sondern auf check_snmp_storage auswichen werden soll.

mfg

Cthluhu
Bitte warten ..
Mitglied: MasterBlaster88
27.08.2013 um 15:10 Uhr
Dickes Dickes Dankeschön.

Hat funktioniert!!!!
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Problem Auslesen einer Internetseite mit Powershell (11)

Frage von c20082005 zum Thema Batch & Shell ...

CSS
gelöst CSS Problem (2)

Frage von michi1983 zum Thema CSS ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (16)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

CMS
Lokales Wordpress im LAN - wie aufsetzen? (16)

Frage von Static zum Thema CMS ...

LAN, WAN, Wireless
IP im privaten Netz nicht erreichbar (14)

Frage von guntis zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
Devolo DLAN 500 pro Wireless+ (13)

Frage von IceAge zum Thema LAN, WAN, Wireless ...