Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Namensauflösung im Netz bricht regelmäßig nach wenigen Minuten ab

Frage Netzwerke DNS

Mitglied: Malachit

Malachit (Level 1) - Jetzt verbinden

29.09.2006, aktualisiert 12.10.2006, 8122 Aufrufe, 4 Kommentare

Im Windows-Netzwerk bricht regelmäßig nach wenigen Minuten die Namensauflösung vom internet zum internen Netzwerk ab, ohne explizite Fehlermeldung

Hallo in die Runde,

ich habe ein, wie ich finde, recht interessantes Problem beim DNS unter Windows.

Bei meiner ererbten Domäne besteht das Problem dass die Namensauflösung vom Internet zum internen Netzwerk nicht funktioniert.
Von einem Client aus kann man über die Eingabe einer IP-Adresse Webseiten aufrufen, bei Eingabe des Namens der Seite kommt die Fehlermeldung:
"Die Seite kann nicht angezeigt werden
...
Fehler: Server oder DNS kann nicht gefunden werden".


PDC und BDC der Domäne sind WinNT4-Server, beide mit SP5.
Auf dem PDC läuft auch ein DHCP-Server.
Der DNS läuft auf einem Win2000 Advanced Server-System, auf dem gleichzeitig auch ein ISA2000-Server (alle Patches) läuft. Alle weiteren Server im System, File-, DB- usw. laufen auf Win2000.
Alle Server sind in den HOSTS-Dateien untereinander eingetragen.


Nennen wir die relevanten Rechner:
PDC "SERVER3"
BDC "SERVER4"
DNS/ISA "SERVER5"


Eine konkrete Fehlermeldung zum Problem habe ich noch nicht in den Logs gefunden.
Im DNS-Ereignis-Log des SERVER5 finden sich jedoch regelmäßig Meldungen:

"Der DNS-Server hat zurzeit keinen DNS-Domänennamen." (Ereignis-ID 414)

Also habe ich zunächst alle Server mit einem solchen nachgerüstet (bis auf die beiden NT4-Server, da habe ich keine Möglichkeit der Einstellung gefunden).
Nach Eintrag der FQDN werden die Server auch automatisch in der Forward-Zone als Hosts angezeigt, was vorher nicht der Fall war.

Soweit so gut.
Trage ich jetzt den SERVER5 als Nameserver in der DNS (egal welche) Zone ein so passiert mit der Namensauflösung gar nichts, keine Änderung.

Der Witz ist aber: entziehe ich dem SERVER5 den FQDN, verschwindet der natürlich als Host im DNS (nach Neustart). Wenn ich den nun manuell als Host nachtrage (nur als "SERVER5" – nicht als "server5.domäne") und anschließend als Nameserver im DNS eintrage dann taucht nach einem Rechner-Neustart der Eintrag "Unbekannt" bei der IP-Adresse (zuvor korrekt eingegeben) bei dem Nameserver auf.
Wenn ich jetzt die richtige IP-Adresse des "SERVER5" dort eingebe funktioniert ab dem Moment die Namensauflösung und alle Clients im Netz haben Zugang zu Webseiten über deren Namen. Ein paar Minuten später ist der Traum vorbei und der Zugang zu alles Seiten die bis dahin nicht im Namenscache stehen wird mit der o.g. Fehlermeldung verwehrt.

Trage ich den FQDN des SERVER5 bei dem wieder ein so erscheinen (nach Neustart) die beiden IP-Adressen (intern und extern) des Rechners beim Eintrag des Nameservers im DNS. Damit funktioniert die Namensauflösung aber nicht.

D.h. wenn jemand ins Netz will muss ich dem SERVER5 den FQDN "server5.domäne" entziehen, aus dem DNS als Nameserver rauswerfen, als Nameserver "server5" eintragen, den Rechner neu starten, beim Nameserver "server5" im DNS die interne IP angeben und bestätigen.

Die Kurzform ist:
- Im DNS den Namensserver austragen
- SERVER5 neustarten
- Im DNS, in dem den SERVER5 inzwischen wieder mit der IP-Adresse "Unbekannt" drinsteht die richtige, interne Ip-Adresse eintragen
- Übernehmen
Dann läuft es für ein paar Minuten, mal länger, mal kürzer.


Zu den Einstellungen des DNS:
- Zonenübertragung ist in allen Zonen an alle Server erlaubt
- Dynamische Aktualisierung ist aktiviert


Weitere Beobachtungen:

1) Wenn der SERVER5 neugestartet wurde und der DNS-Eintrag wird nicht sofort geändert so funktioniert nach einiger Zeit die Namensauflösung auch nicht wenn wie oben vorgegangen wurde. Es könnte sich also um irgendein "Abgleichproblem" im Netz handeln – wozu mir aber nichts einfällt, da in der Domäne nur ein DNS-Server läuft.

2) Der DNS-Dienst an sich bricht nicht ab; auch wenn die Namensauflösung nicht funktioniert so meldet doch der DNS-Dienst keinen Fehler und der steht auch weiterhin auf "aktiv".

3) Alle Server haben im Netz eine feste IP-Adresse, bräuchten also keine vom DHCP-Server. Beim SERVER5 ist der DHCP-Client-Dienst definitiv deaktiviert. Trotzdem besorgt er sich dort jedoch gleich 10 Leases, alle mit 3 Tagen Gültigkeit. Ist der SERVER5 jedoch grad mal unten so verschwinden die Leases aus der DHCP-Verwaltung obwohl die lt. Gültigkeitsregel noch drinstehen müssten.
Ich bin nicht sicher ob hier ein Zusammenhang bestehen mag und habe dies der Vollständigkeit halber mit erwähnt.

4) Das Anwendungsprotokoll des SERVER5 ist voll von Meldungen:
"Die ISA Server-Dienste konnten Paketfilter <IP-ADRESSE> nicht erstellen. Dieses Ereignis tritt bei einem Konflikt zwischen der LAT-Konfiguration und der Windows 2000-Routingtabelle auf. Überprüfen Sie die Routingtabelle und die LAT (Local Address Table), um die Ursache des Konflikts zu ermitteln." (EREIGNIS_ID 14120).
Diese Meldungen erscheinen, wenn mich nicht alles täuscht, zu JEDEM Aufruf einer Webseite.
Ich habe die LAT-Einträge schon vervollständigt, so dachte ich, aber irgendwas scheint da immer noch nicht zu stimmen.


Habt Ihr dazu Lösungsansätze, gute Ideen?


Besten Dank im Voraus für Eure Mithilfe.
Malachit
Mitglied: DigitalKeeper
29.09.2006 um 20:25 Uhr
Guckst Du hier: http://msdn2.microsoft.com/de-de/library/ms151743.aspx

MSSQL_ENG014120

Dieses Thema enthält Informationen zur Problembehandlung für den Microsoft SQL Server-Replikationsfehler MSSQL_ENG014120.
Bitte warten ..
Mitglied: Malachit
05.10.2006 um 22:18 Uhr
Hallo DigitalKeeper,

vielen Dank für Deinen Beitrag.
Ich hatte es allerdings versäumt die komplette Fehlermeldung zu posten, da mir nicht bewusst war dass die gleiche Fehler-ID offenbar von mehreren Quellen kommen kann und anscheinend müssen die nichts miteinander zu tun haben - ich bitte um Korrektur falls ich falsch liege.

Die Fehlermeldung in meinem Fall kommt vom "Microsoft Webproxy" und hat mit SQL erstmal nichts zu tun - Dein Link ist zugegebenermaßen der Einzige der auftaucht wenn man auf der MS-Seite nach der Fehler-ID sucht.

Meine Recherchen haben ergeben dass der Fehler (ID 14120, "Microsoft Webproxy") in genau der Form auftritt wenn ein ISA Server mit nur einer Netzwerkkarte konfiguriert wurde - das ist beim SERVER5 aber nicht der Fall.
Ebenfalls tritt der Fehler auf wenn man in der LAT die externe IP-Adresse des Servers mit angibt. In meinem Fall MUSS ich das aber, da eine weitere Domäne via VPN mit unserer verbunden ist - beide sind korrekt in der Forward-Zone eingetragen - und von dort kommen die User zunächst auf den ISA (SERVER5) und gehen von dort erst wieder in die weite Netzwelt. Ich habe auf der externen IP-Adresse also auch eingehenden Traffic, der dort auch wieder rausgeht. Würde ich die externe IP-Adresse aus der LAT austragen so wären zwar dir Fehlermeldungen weg aber ebenfalls wäre die zweite Domäne sofort abgehängt - in der gegenwärtigen Konstellation muss ich mit dieser Fehlermeldung also erstmal leben.

Es bleibt jedoch bei dem Problem dass die Namensauflösung regelmäßig abbricht - hier bin ich bisher nicht weitergekommen und bitte nachwievor um Eure Beiträge.


Mit bestem Dank und freundlichen Grüßen,
Malachit
Bitte warten ..
Mitglied: DigitalKeeper
06.10.2006 um 20:25 Uhr
Hallo Malachit,

hmmm, komisch, komisch....bei MS wird zwar von SQL gesprochen, aber auch in der KLB bzw. im Technet beziehen sich die Anfragen auf die Replikationsfehler im Allgemeinen. Das scheint ein Caching-Problem zu sein. Werd' noch mal schnüffeln...

Zur Namensauflösung: auch hier tippe ich auf caching für/mit ungültigen Einträgen. Andererseits hatte schon mal eine "Schnatter" NIC, die mir fast das ganze Netz platt gemacht hat. Auf die Spur bin ich der nur mit dem Netzwerkmonitor gekommen.

Ich würde in Bezug auf die Namensauflösung mittels dem NW-Monitor mal die Pakete prüfen, um da genaueres zu erfahren. Könnte ein Hardwareproblem sein, dem man nicht so leicht auf die Spur kommt; zu sehen anhand der Logfiles, wie die Pakete übertragen werden.

Frage:

Wo bricht die Namensauflösung ab? Am Server? Bei bestimmten Anfragen? Werden die Anfragen durchgereicht, und "nur" nicht beantwortet? Wie weit kommt die Anfrage? Wird bei der Anfrage vielleicht das IP-Paket "geschreddert", sodass er er nix mehr damit anfangen kann? WIE bricht die Namensauflösung ab? (zB. "diese.domain.de" kann er auflösen, aber "sub.diese.domain.de" oder "domain.de" nicht?) Ach, soooo viele Fragen und keine Antworten....

Schönes Wochenende...

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: Malachit
12.10.2006 um 12:41 Uhr
Problem ist gelöst - es war tatsächlich KEIN Konfigurations- sondern ein Hardwareproblem.

Vielen Dank an alle, die sich Gedanken dazu gemacht haben und besonders an DigitalKeeper: Du hast eine Nachricht mit ein, zwei weiteren Details von mir bekommen.


Angenehmen Tag noch,
Malachit
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Informationsdienste
NSA-Ausschuss: Wikileaks stellt 90 Gigabyte an Akten ins Netz (3)

Link von Frank zum Thema Informationsdienste ...

DSL, VDSL
DSL-Störung im Telekom-Netz (6)

Link von sabines zum Thema DSL, VDSL ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...