Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NAS Firmware bzw. Software anpassen

Frage Hardware SAN, NAS, DAS

Mitglied: Xaero1982

Xaero1982 (Level 3) - Jetzt verbinden

25.11.2012, aktualisiert 20:26 Uhr, 6202 Aufrufe, 15 Kommentare

Hallo Zusammen,

ich habe hier ein Allnet All6400Pro rumstehen und wollte den eigentlich als Medienserver benutzen.

Offenbar kommt der aber mit keinem einzigen Format außer mp3 klar (wav sicher auch, aber hab ich nicht getestet).

Die letzte FW von Allnet lässt sich nicht installieren.

Laut Board ist es ein Thecus 4100 Pro ii - leider lässt sich auch diese Firmware nicht so einfach drüber bügeln.

Nun stellt sich mir die Frage: kann ich da ein komplett anderes System drauf spielen wie z.b. Freenas oder aber zumindest den Medienserver ändern?

Kann ich vielleicht die Thecus-FW die wohl weit aus umfangreicher sein soll irgendwie erzwingen zu installieren?

Hat da vielleicht jemand einen Rat?

Gruß
PS: bitte keine Kommentare wie neues kaufen, oder allnet is schrott etc. diese sind nicht konstruktiv und helfen nicht bei der Beantwortung der Frage - danke!
Mitglied: brammer
25.11.2012, aktualisiert um 21:05 Uhr
Hallo,

laut Datenblatt Hat das Ding auch einen iTunes Server sowie

Media server • Supports uPnP AV streaming protocol
• Works with DLNA-certified players


Als DLNA Player sollte der Player mit folgenden Formaten umgehen können:


Medien Vorgeschriebene Formate Optionale Formate
Bilder JPEG GIF, TIFF, PNG
Audio LPCM (zweikanalig) MP3, WMA9, AC-3, AAC, ATRAC3plus
Video MPEG2 MPEG1, MPEG4, WMV9


brammer
Bitte warten ..
Mitglied: ChrisIO
25.11.2012, aktualisiert um 21:09 Uhr
Hey,

hier ist die aktuelle Factory-Reset-Anweisung, diese flashed die aktuelle Firmware gleich mit auf das Gerät.
Versuch Das doch mal zuerst und guck Dir die Funktionen dann mal an.
Ich beschäftige mich derweil mal mit der FreeNas-Möglichkeit.

---

1. Bereiten Sie einen USB Stick im FAT Format vor
2. Laden Sie die aktuelle Firmware von unserer Homepage herunter
3. Entpacken Sie die Firmware
4. Kopieren Sie beide Dateien (factory_test.sh und die Firmware ROM Datei) auf den Flash Stick
5. Schalten Sie das NAS aus.
6. Stecken Sie den USB Stick in das NAS ein und starten das es.
7. Nach dem Beep Ton können Sie den Stick entfernen.
8. Der Resetprozess dauert 4~6 Minuten. Das NAS rebootet anschließend automatisch.

Download: ftp://212.18.29.48/ftp/pub/allnet/nas/all6400pro/ALL6400pro_factory_re ...

Firmware: ftp://212.18.29.48/ftp/pub/allnet/nas/all6400pro/ALL6400Pro_fW_5_02_02 ...

---

Gruß,
Chris
Bitte warten ..
Mitglied: Xaero1982
25.11.2012 um 21:16 Uhr
Hi ChrislO,

danke, das hab ich natürlich schon gemacht und wie gesagt die Version 5.02.02 bricht ab mit einem Fehler (Fehlgeschlagen - ohne Aussage).

Ich habe nun aktuell die 3.00.05 am laufen.

Bei Thecus ist noch eine bin-Datei um von v.3 auf v.5 updaten zu können. Die gibt es von Allnet nicht.

Was ich noch herausbekommen habe ist, dass die Angabe des Gerätes in der Manifest.txt steht. Leider ist die letzte die ich finde nur noch mit FW 2.1.09 kompatibel und ein Downgrade funktioniert nicht.

Da ich auch keinen SSH Zugriff habe geht auch eine Anpassung der Manifest Datei nicht. Sonst könnte man auch die Thecus Firmware installieren.

@brammer: Wie gesagt geht leider nichts -selbst mp4 nicht. Nicht mal Avi ...
Und nen Itunesserver bringt mir leider nichts.

Gruß
Bitte warten ..
Mitglied: ChrisIO
25.11.2012 um 22:15 Uhr
Hey,

also ich hab noch folgende Infos herausgefunden:

The NAS' own operating system is stored on a solid state memory module and is attached via the IDE connector on the motherboard.

Bild: http://www.overclockersonline.net/images/articles/Thecus/N4100Pro/Large ...

Es wird bestimmt die Möglichkeit geben da ein FreeNas drauf zu bekommen, aber bitte frag mich nicht wie.

Wohl über die USB- oder Netzwerk-Schnittstelle.

Kleiner Tip: Mal bei Thecus schlaue Fragen stellen, die normale Mitarbeiter überfordern und nach einem Techniker fragen. ;)

Die sind meist locker drauf und geben auch mal Tips.

Gruß,
Chris
Bitte warten ..
Mitglied: Xaero1982
25.11.2012 um 22:33 Uhr
Hi,

danke erst mal...

Wie bist du zu dem Artikel gekommen?
Ich find den nämlich nicht ...

Es würde ja schon helfen die andere Firmware von Thecus drauspielen zu können, weil da zumindest die Erweiterungsmodule funktionieren.

Die kann ich auch nicht installieren.

Werd ich mal versuchen - danke!

Gruß
Bitte warten ..
Mitglied: ChrisIO
25.11.2012, aktualisiert um 22:43 Uhr
Bitte warten ..
Mitglied: Xaero1982
25.11.2012 um 23:10 Uhr
Thx

Ich glaube das kann ich eh vergessen ... nach kA 12 Stunden Raiderstellung hab ich nun ein Raid mit einer Größe von 1 GB bei 2x2tb hdds - cool.

Gruß
Bitte warten ..
Mitglied: goscho
26.11.2012 um 08:24 Uhr
Moin,

ich weiß nicht, ob es mit deinem Allnet-Teil geht aber, auf
NAS-Central.org sind viele ALternativen zu den installierten System aufgelistet.
Dadurch habe ich auf Buffalo Linkstations Debian installieren können.
Bitte warten ..
Mitglied: ChrisIO
26.11.2012, aktualisiert um 13:02 Uhr
Hey,

mir kam da gestern noch eine ganz simple Idee.
Wie wäre es denn damit, den Flash-Speicher vom IDE-Port zu entfernen und an einen anderen Rechner zu hängen?
Mal raufgucken könnte interessant sein, dann würde ich mir nen USB-Stick mit FreeNas fertig machen, ein Image vom FlashSpeicher anlegen und danach alle Partitionen kicken.
Mit ein wenig Glück ist der USB-Stick in der Boot-Sequenz hinterlegt und dein System bootet nachdem es Nichts auf der Festplatte gefunden hat vom USB-Stick.

---

Zitat:

Yes you can boot off a usb stick and run linux as a NAS

With the 4100pro if you add a VGA header you can change the boot order to usb 1st or just backup the DOM and load linux on it then if you wish to back out then you have a dd of the DOM.

FYI this may help
http://thecususergroup.proboards.com...0modifications

Quelle: http://forums.smallnetbuilder.com/showthread.php?t=2188

---

Gruß,
Chris
Bitte warten ..
Mitglied: Xaero1982
26.11.2012 um 19:01 Uhr
Hi,

das mit dem abklemmen werd ich mal testen - aber was ist mit Strom? Reicht das wohl übern IDE Port?


Habe nach der Anleitung:
https://wiki.ex23.de/dokuwiki/doku.php/it:linux:allnet_6700_in_thecus_n5 ...

die Firmware von Thecus bearbeitet und die Manifest.txt umgeschrieben, aber leider ohne erfolg. Bekomme wieder nur eine Fehlermeldung beim Updaten.

Gruß
Bitte warten ..
Mitglied: Xaero1982
26.11.2012 um 22:25 Uhr
Habe nun alle Firmwareversionen von Thecus probiert und die manifest.txt angepasst... alles erfolglos.

kA woran es liegt.

Gruß
Bitte warten ..
Mitglied: ChrisIO
30.11.2012 um 21:41 Uhr
Hey,

konntest Du überhaupt schon ein mal eine Firmware erfolgreich aufspielen?
Wenn nicht, liegt wahrscheinlich ein Hardwaredefekt vor.

Gruß,
Chris
Bitte warten ..
Mitglied: Xaero1982
30.11.2012 um 21:49 Uhr
Hi,

ja die originalen haben funktioniert bis 3.04.04 oder was das aktuell war.

Aber selbst die letzte von ALLNET bereitgestellte geht nicht.

Gruß
Bitte warten ..
Mitglied: ChrisIO
01.12.2012 um 17:42 Uhr
Hey,

was sagt ALLNET dazu, ist Denen Dieses Verhalten bekannt?

Gruß,
Chris
Bitte warten ..
Mitglied: Xaero1982
02.12.2012 um 00:48 Uhr
Hey,

hab ich noch nicht kontaktiert. Werde ich mal tun ...

Gruß
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

SAN, NAS, DAS
gelöst NAS RAID5 - RAID0 und Backup (7)

Frage von easy4breezy zum Thema SAN, NAS, DAS ...

LAN, WAN, Wireless
Software für Backup oder Datensynchronisation über WAN gesucht (3)

Frage von Rubiks zum Thema LAN, WAN, Wireless ...

Datenschutz
NAS aufräumen (1)

Frage von Kizuko zum Thema Datenschutz ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (12)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...