Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

NAT auf DC, FTP reagiert, aber keine Antwort.

Frage Microsoft Windows Server

Mitglied: format

format (Level 1) - Jetzt verbinden

25.02.2010 um 11:09 Uhr, 3230 Aufrufe, 5 Kommentare

Hallo,


irgendwo habe ich einen Denk- und Einstellungsfehler. Folgendes Szenario läuft virtualisiert.

Ich habe für eine Testumgebung einen DC aufgesetzt. Dort läuft auch ein DNS Server, der die Testdomain verwaltet.

Es gibt einen weiteren Server der nur den FTP Dienst zur Verfügung stellt. Bisher habe ich nur diesen FTP Server ans Internet gebunden.
Dafür haben wir eine separate Leitung - nur für diese Zwecke.

Heute wollte ich den DomainControler (DC) als Gateway einsetzen, so das darüber mein Internet (das von der separaten Leitung) an alle meine anderen Server in der Testumgebung verteilt werden kann. Insbesondere nat. der FTP Server.
Okay. NAT für Port eingerichtet und auf die IP des FTP Server gelenkt, nach dem ich dem DC die Gateway Rolle bekannt gegeben habe.

Als nächstes habe ich direkt getestet. Von extern eine FTP Verbindung aufgebaut, auf dem FTP Server sehe ich, dass die Anfrage ankommt und ich "drin" bin. Allerdings bekomme ich in sofern keine "Antwort" vom FTP Server zu meinem Client zurück, als das er mir nicht die entsprechenden Ordner und Dateien listet die meinem FTP Account zugeordnet sein müssten.
Komisch.

Das FTP Programm versucht immer weiter diese Info abzufragen. Breche ich das ab, sehe ich einen leeren Ordner. In diesem Ordner kann ich Dateien und Ordner anlegen und sehe diese dann, frisch erstellt, auf dem FTP Server.

Mir scheint, als ob der Hinweg über Port 21 im Translation Prozess funktioniert. Aber der Rückweg nicht.
Der FTP Server hat eine statische IP. DNS ist vorwärts und rückwärts eingerichtet auf dem DC und funktioniert für alle anderen Clients.

Was habe ich vergessen?
Mitglied: aqui
25.02.2010 um 11:43 Uhr
Du musst einen FTP Client benutzen der den sog. "passive" Mode supportet, sonst kommst du nicht über den NAT Prozess mit FTP !!
Warum das so ist kannst du hier nachlesen:
http://slacksite.com/other/ftp.html
Bitte warten ..
Mitglied: format
25.02.2010 um 13:20 Uhr
Hallo,

danke für die Antwort.
Das habe ich gemacht. Wie geschrieben, ich kann ja auch bspw. nen Ordner erstellen. Nur wird er mir nicht zurück gegeben im FTP Client. Ich seh diesen aber im Folder auf dem FTP Server
Bitte warten ..
Mitglied: aqui
25.02.2010 um 16:37 Uhr
Was für einen Client verwendest du denn ?? Schon mal Filezilla probiert ??
http://filezilla-project.org/
Was sagt sonst der FTP Zugriff direkt über die Eingabeaufforderung ala ftp meinserver.de oder direkt z.B. mit dem Firefox wenn du ftp://meinserver.de im URL eingibst ?
Bitte warten ..
Mitglied: format
25.02.2010 um 17:55 Uhr
Hi,

habs gelöst.
Im filezilla Server stimmte das Network Interface im passiven Modus nicht. Mit der default Einstellung gings.

Danke
Bitte warten ..
Mitglied: aqui
26.02.2010 um 20:07 Uhr
Alles wird gut...!

Bitte dann auch
http://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Ähnliche Inhalte
Outlook & Mail
Keine Antwort senden möglich, Outlook Termineinladung

Frage von killtec zum Thema Outlook & Mail ...

Windows Netzwerk
DC baut nach Umzug keine Internetverbindung mehr auf (6)

Frage von MrArrows zum Thema Windows Netzwerk ...

Netzwerkgrundlagen
IPSEC VPN mit pfSense und Lancom - keine verbindung wenn Client offline (5)

Frage von DanyCode zum Thema Netzwerkgrundlagen ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(4)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (41)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (18)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...