Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

NAT Fehler mit Cisco 1941 Router

Frage Netzwerke Router & Routing

Mitglied: keksdieb

keksdieb (Level 1) - Jetzt verbinden

08.05.2013, aktualisiert 11:52 Uhr, 1799 Aufrufe, 2 Kommentare

Moin moin zusammen,
ich hab ein 3 Netzwerke, die mit zwei Routern verbunden sind. Eigentlich funktioniert auch alles, allerdings bin ich per Zufall auf folgenden Fehler gestoßen:IP: s=10.xxx.xxx.xxx (local), d=10.xxx.yyy.yyy (GigabitEthernet0/0/0), len 600, output feature, NAT ALG proxy(59), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE

Zur Ausgangslage (IP Adressen geändert):

Router 1
#Gateway zur großen weiten Welt
#direkte Verbindung zum Router 2 via GigabitEthernet0/0/0 - 1.1.1.2
#direkte Verbindung zum Netzwerk 1.2.3.0 - 1.2.3.1

Router 2
#direkte Verbindung zum Router 1 - 1.1.1.3
#direkte Verbindung zum Netzwerk 9.8.7.0 - 9.8.7.1

Die Verbindung und die Routen passen

Auszug Config Router1:

01.
Interface GigabitEthernet0/0 
02.
 description outside Interface 
03.
 ip address 123.456.789.12 255.255.255.0 
04.
 ip nat outside 
05.
 ip virtual-reassembly in 
06.
 duplex auto 
07.
 speed auto 
08.
09.
interface GigabitEthernet0/1 
10.
 description Netz 1 
11.
 ip address 1.2.3.1 255.255.255.0 
12.
 ip nat inside 
13.
 ip virtual-reassembly in 
14.
 duplex auto 
15.
 speed auto 
16.
17.
interface GigabitEthernet0/1/0 
18.
 ip address 1.1.1.2 255.255.255.0 
19.
 ip nat inside 
20.
 ip virtual-reassembly in 
21.
22.
 
23.
! NAT Einstellungen 
24.
ip nat translation tcp-timeout 3600 
25.
ip nat translation udp-timeout 3600 
26.
ip nat inside source list 101 interface GigabitEthernet0/0 overload
Auszug Config Router2:

01.
interface GigabitEthernet0/0/0 
02.
 ip address 1.1.1.3 255.255.255.0 
03.
 ip nat outside 
04.
 ip virtual-reassembly in 
05.
06.
interface GigabitEthernet0/1/0 
07.
 ip address 9.8.7.1 
08.
 ip nat inside 
09.
 ip virtual-reassembly in 
10.
11.
 
12.
 
13.
! NAT Einstellungenp nat translation tcp-timeout 3600 
14.
ip nat translation udp-timeout 3600 
15.
ip nat inside source list 101 interface GigabitEthernet0/0/0 overload
Hier noch mal ein paar Logeinträge:
01.
W-02#[A26 MET: IP: s=1.1.1.3 (local), d=1.1.1.2, len 600, local feature, NAT(2), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE 
02.
003691: *May  8 11:41:05.726 MET: IP: s=1.1.1.3 (local), d=1.1.1.2 (GigabitEthernet0/0/0), len 600, output feature, Post-routing NAT Outside(27), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE 
03.
003692: *May  8 11:41:05.726 MET: IP: s=1.1.1.3 (local), d=1.1.1.2 (GigabitEthernet0/0/0), len 600, output feature, Common Flow Table(29), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE 
04.
003693: *May  8 11:41:05.726 MET: IP: s=1.1.1.3 (local), d=1.1.1.2 (GigabitEthernet0/0/0), len 600, output feature, Stateful Inspection(30), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE 
05.
003694: *May  8 11:41:05.726 MET: IP: s=1.1.1.3 (local), d=1.1.1.2 (GigabitEthernet0/0/0), len 600, output feature, NAT ALG proxy(59), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE 
06.
003695: *May  8 11:41:05.726 MET: IP: s=1.1.1.3 (local), d=1.1.1.2, len 600, local feature, NAT(2), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE 
07.
003696: *May  8 11:41:05.726 MET: IP: s=1.1.1.3 (local), d=1.1.1.2 (GigabitEthernet0/0/0), len 600, output feature, Post-routing NAT Outside(27), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE 
08.
003697: *May  8 11:41:05.726 MET: IP: s=1.1.1.3(local), d=1.1.1.2 (GigabitEthernet0/0/0), len 600, output feature, Common Flow Table(29), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE 
09.
003698: *May  8 11:41:05.726 MET: IP: s=1.1.1.3 (local), d=1.1.1.2 (GigabitEthernet0/0/0), len 600, output feature, Stateful Inspection(30), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE 
10.
003699: *May  8 11:41:05.726 MET: IP: s=1.1.1.3 (local), d=1.1.1.2 (GigabitEthernet0/0/0), len 600, output feature, NAT ALG proxy(59), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE 
11.
003700: *May  8 11:41:05.726 MET: IP: s=1.1.1.3 (local), d=1.1.1.2, len 600, local feature, NAT(2), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Eigentlich funktioniert alles, allerdings möchte ich den Fehler gerne verstehen und beheben...
Die Netzwerke sind in den ACL 101 Listen eingetragen.

Gruß
Keksdieb
Mitglied: keksdieb
08.05.2013, aktualisiert um 17:40 Uhr
Moin moin,

Mit "debug ip nat error" hab ich das Problem finden können...

Die IP Verbindung zwischen den Routern braucht natürlich nur einmal nat inside (in diesem Fall auf interface GigabitEthernet0/1).
Auf dem 2. Router (interface GigabitEthernet0/0/0) hatte ich ip nat outside stehen. Wird in dem Fall aber nicht benötigt, da die beiden Router Interfaces sich im gleichen Netzwerk befinden (in meinem Fall im 1.1.1.0 )

Vielen Dank an Aqui (schon vor langer zeit) der mir immer wieder nahe legt, die debug Befehle im IOS zu nutzen

Vielen Dank an alle, die sich für das Thema interessiert haben und mir helfen wollten.

Gruß
Keksdieb
Bitte warten ..
Mitglied: aqui
10.05.2013, aktualisiert um 23:49 Uhr
Immer gerne wieder
Ansonsten bietet wie immer diese Beispielkonfig:
http://www.administrator.de/wissen/konfiguration-cisco-886va-mit-adsl-o ...
eine gute Allround Hilfestellung...
Und: Hauptsache du hast am Ende des Debuggens nicht undebug all vergessen einzugeben, denn sonst rennt dein Router nur im 3ten Gang !
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Lancom Router NAT (7)

Frage von Brian85 zum Thema Router & Routing ...

Router & Routing
VoIP hinter Cisco Router (23)

Frage von PharIT zum Thema Router & Routing ...

LAN, WAN, Wireless
Fritz Box als Telefonanlage an Cisco Router (5)

Frage von DaHuber zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
Aus Cisco Router ausgespeert (13)

Frage von Herbrich19 zum Thema LAN, WAN, Wireless ...

Neue Wissensbeiträge
Sicherheit

How I hacked hundreds of companies through their helpdesk

Information von SeaStorm zum Thema Sicherheit ...

Erkennung und -Abwehr

Ccleaner-Angriff war nur auf große Unternehmen gemünzt

(10)

Information von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Sicherheit

Eventuell neue Lücke in Intels ME

Information von sabines zum Thema Sicherheit ...

Heiß diskutierte Inhalte
Humor (lol)
Freidach Beitrag (33)

Frage von Penny.Cilin zum Thema Humor (lol) ...

Lizenzierung
Programm soll in verschiedenen Versionen lizenziert sein (20)

Frage von Yanmai zum Thema Lizenzierung ...

Windows 7
SSD - Win7 Lags (19)

Frage von ph5555 zum Thema Windows 7 ...