Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NAT-Konfiguration mit 2 Dialerinterfaces auf Cisco 801

Frage Netzwerke Router & Routing

Mitglied: Cruzito

Cruzito (Level 1) - Jetzt verbinden

24.02.2006, aktualisiert 25.02.2006, 5773 Aufrufe, 1 Kommentar

Hallo

Hab einen Cisco 801 Router konfiguriert mit 2 Dialer-Interfaces.
Beim 1. Interface funktioniert die Einwahl und NAT ohne Probleme, jedoch bei 2. Interface funktioniert nur die Einwahl, aber kein NAT.

kurz zur Config:
<font class="code">
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
dialer pool-member 2
isdn switch-type basic-net3
no cdp enable
!
interface Dialer0
description
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 2
dialer idle-timeout 60
dialer string
dialer hold-queue 10
dialer load-threshold 10 outbound
dialer-group 2
ppp authentication chap callin
ppp chap hostname *
ppp chap password *
!
interface Dialer1
description
ip address negotiated
ip nat outside
encapsulation ppp
no keepalive
dialer pool 1
dialer idle-timeout 60
dialer string *
dialer hold-queue 10
dialer load-threshold 10 outbound
dialer-group 1
ppp authentication chap callin
ppp chap hostname *
ppp chap password *
!
ip nat inside source list 101 interface Dialer1 overload
ip nat inside source list 102 interface Dialer0 overload
ip http server
ip classless
ip route ipaddress subnetmask Dialer1
ip route ipaddress subnetmask Ethernet0
ip route ipaddress subnetmask Dialer0
!
access-list 101 permit ip any any
access-list 102 permit ip any any
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
</font>

Die Einwahl erfolgt sobald aus dem LAN ein Packet an eine bestimmte IP-Adresse geht. So wird unterscheiden, welches Dialerinterface angewählt wird.

Mein eigentliches Problem sind die Zeilen:

ip nat inside source list 101 interface Dialer1 overload
ip nat inside source list 102 interface Dialer0 overload

von dieser NAT-Konfiguration nimmt er immer nur die 1. Zeile.
Sobald ich mich über Dialer0 einwähle, bekomme ich den NAT-Fehler, dass das Interface Dialer1 nicht hochgefahren ist.

Hat jemand eine Idee, da bei Cisco nur Konfigurationsbeispiele mit einem Dialerinterface sind.
Mitglied: aqui
25.02.2006 um 13:56 Uhr
Eigentlich sollte das so einwandfrei funktionieren, allerdings würde ich die Dialerlisten die den Dialer triggern nicht so weit auflassen bzw. auf dem Ethernet Interface einen Filter setzen um Windows UDP Broadcasts zu filtern. Bei dir wichtig da du generell alles den Dialer triggern lässt. Das würd ich eingrenzen auf die IP Range deines Ethernet Interfaces.
Wenn du das "ip nat inside" auf dem Ethernet nicht vergessen hast würd ich erstmal nicht verstehen warum es nicht geht.
Ein Problem kann sein da du Load Sharing fährst auf den B-Kanälen das beide B-Kanaäle oben sind und dann kann der 2. Dialer nicht aktiv werden. Evtl. solltest du das mal temporär zum Testen aus der Konfig nehmen. Mit "sh int bri 0:1 bzw. sh int bri o:2" kannst du dir den Status der beiden B-Kanäle einzeln ansehen.
Du solltest auch mal ein "debug dialer packet" machen um zu sehen was und was nicht den Dialer triggert bzw. welchen Dialer. Denk dran die Debug Funktion unbedingt wieder mit "u all" auszuschalten ! Wenn du eine Telnet Sitzung auf den Router ausführst zudem noch "term mon" sonst siehst du den redirecteten Consolen Output nicht !
Hier ein Beispiel für etwas sicherer Dialer ACLs:

interface Ethernet0
description Local Ethernet
ip address 192.168.7.254 255.255.255.0
ip access-group 102 in
ip nat inside

interface Dialer1
description ISDN Dialout Verbindung
bandwidth 64
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer idle-timeout 118
dialer string 12345
dialer hold-queue 15
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username 1234567 password Geheim
ppp timeout idle 118

ip nat inside source list 101 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
access-list 101 permit ip 192.168.7.0 0.0.0.255 any
access-list 102 deny udp any range netbios-ns netbios-ss any
access-list 102 deny tcp any eq 139 any
access-list 102 permit ip any any
Bitte warten ..
Ähnliche Inhalte
Firewall
Verständnisfrage zur NAT Konfiguration auf meinem Router
gelöst Frage von warbyrdFirewall7 Kommentare

Hallo zusammen, ich habe eine Verständnisfrage zu Portweiterleitungen auf meinem Router. Hier der Screenshot, um den es geht: Gehe ...

LAN, WAN, Wireless
Cisco ASA hinter Router mit NAT
gelöst Frage von maxmaxLAN, WAN, Wireless2 Kommentare

Hallo, ich habe eine Cisco ASA welche hinter einem privaten ADSL-Anschluss steht, der Anschluss terminiert auf einem Cisco 867-K9, ...

Router & Routing
Doppeltes NAT mit Cisco 851
gelöst Frage von maxmaxRouter & Routing3 Kommentare

Hallo, ich versuche gerade aus Testzwecken ein zweites NAT für einen Client zu schalten. Zurzeit ist der Aufbau folgender: ...

Router & Routing
Cisco NAT (VoiP)
gelöst Frage von Bernhard-BRouter & Routing10 Kommentare

Hallo, ich habe ein kleines Problem mit dem Betrieb eines Asterisk VoiP Servers hinter meiner Cisco Hardware. Zum Aufbau: ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 1 TagWindows 106 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 2 TagenInternet5 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 2 TagenDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Batch & Shell
Kann man mit einer .txt Datei eine .bat Datei öffnen?
Frage von HelloWorldBatch & Shell16 Kommentare

Wie schon im Titel beschrieben würde ich gerne durch einfaches klicken auf eine Text oder Word Datei eine Batch ...

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...

Windows Server
Ping auf einen bestimmten Server nicht möglich
gelöst Frage von a.thierWindows Server7 Kommentare

Hallo, ich habe folgendes Problem. srv-dc1: Ping srv-nav > geht Ping srv-exchange > geht nicht srv-exchange: Ping srv-dc1 > ...

Hardware
Fujitsu Workstation mit K80 und Quadro P5000, Fehlermeldung: Connect Power Adapter
Frage von MachelloHardware7 Kommentare

Hallo Zusammen, ich benötige euren Rat da ich ratlos bin. Folgende Konfiguration im Büro: Fujitsu Workstation Celcius R940 Power ...