Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NAT Regel funktioniert im Cisco PT, aber nicht im Router

Frage Netzwerke Router & Routing

Mitglied: ef8619

ef8619 (Level 1) - Jetzt verbinden

23.12.2013 um 14:40 Uhr, 1842 Aufrufe, 2 Kommentare

Hallo,

ich muss auf unserem Router (1921 ISR G2) ein NAT-Forwarding einrichten, das es ermöglicht auf einen Webserver mittels Port 80 von Außen zuzugreifen.

Habe das Szenario testweise im Cisco PT nachgebaut und die Regeln eingetragen:

interface GigabitEthernet0/0 
description LAN Interface 
 ip address 10.80.1.254 255.255.255.0 
 ip nat inside 
 duplex auto 
 speed auto 
interface GigabitEthernet0/1 
description WAN Interface 
 ip address 192.168.0.2 255.255.255.0 
 ip nat outside 
 duplex auto 
 speed auto 
interface Vlan1 
 no ip address 
 shutdown 
ip nat pool NAT_POOL 192.168.0.2 192.168.0.2 netmask 255.255.255.0 
ip nat inside source list 10 pool NAT_POOL overload 
ip nat inside source static tcp 10.80.1.250 80 192.168.0.2 80  
ip classless
Hier kann ich mit einem PTLaptop über einen 2. Router einen Webserver mit der Adresse 10.80.1.250 erreichen.

Das Gleiche habe ich nun auf unserem Router eigetragen. Wir haben dort auch keine weiteren NAT-Regeln konfiguriert:

interface GigabitEthernet0/0 
 description Lokales LAN 
 ip address 10.80.1.254 255.255.255.0 
 ip flow ingress 
 ip flow egress 
 ip nat inside 
 ip virtual-reassembly in 
 ip tcp adjust-mss 1452 
 duplex auto 
 speed auto 
interface GigabitEthernet0/1 
 description VDSL Internet Verbindung 
 ip address dhcp 
 no ip redirects 
 no ip proxy-arp 
 ip nat outside 
 ip virtual-reassembly in 
 duplex auto 
 speed auto 
interface Virtual-Template1 
 ip unnumbered GigabitEthernet0/0 
 peer default ip address pool PPTP 
 no keepalive 
 ppp encrypt mppe 128 required 
 ppp authentication ms-chap-v2 
no ip http server 
no ip http secure-server 
ip dns server 
ip nat pool NAT_POOL <unsere Public IP> <unsere Public IP> netmask 255.255.255.0 
ip nat inside source list 10 pool NAT_POOL overload 
ip nat inside source static tcp 10.80.1.250 80 <unsere Public IP> 80  
access-list 101 permit ip 10.80.1.0 0.0.0.255 any
Allerdings funktioniert es hier nicht.

Weiß vielleicht jemand Rat?
Mitglied: 108012
23.12.2013 um 18:38 Uhr
Hallo,

ich würde eine DMZ einrichten und in diese dann den Server stellen.
Danach kann man dann ein so genanntes Port forwarding einrichten.

YouTube Port forwarding

Anleitung Cisco NAT Port forwarding

Oder warten bis der @aqui hier vorbei schlittert der kann Dir sicher auch gleich helfen.

Gruß
Dobby
Bitte warten ..
Mitglied: aqui
24.12.2013 um 14:29 Uhr
Der Knackpunkt ist der Pool bzw. die Pool Adress Range !!
Du musst sicherstellen das die IP der festen statischen NAT Zuweisung NICHT gleichzeitig mit im NAT Pool ist !
Diese muss davon ausgenommen werden und nur für das statische NAT verwendet bzw. reserviert sein.
Damit funktioniert es fehlerfrei.
Die Kombination des Pool mit dem Overload Statement ist so oder so ziemlich unglücklich in der Konfig und auch kontraproduktiv, denn das "overload" ist ja gerade ein PAT (Port Address Translation). Hier wird NAT über eine einzige feste IP gemacht. Ein Pool ist dabei eigentlich überflüssig und sollte man besser so nicht konfigurieren, da auch nicht verwendet.
Eine grundlegende Konfig (allerdings ohne das statische NAT) kannst du z.B. hier sehen.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Cisco ASA hinter Router mit NAT
gelöst Frage von maxmaxLAN, WAN, Wireless2 Kommentare

Hallo, ich habe eine Cisco ASA welche hinter einem privaten ADSL-Anschluss steht, der Anschluss terminiert auf einem Cisco 867-K9, ...

Router & Routing
Doppeltes NAT mit Cisco 851
gelöst Frage von maxmaxRouter & Routing3 Kommentare

Hallo, ich versuche gerade aus Testzwecken ein zweites NAT für einen Client zu schalten. Zurzeit ist der Aufbau folgender: ...

Router & Routing
Cisco NAT (VoiP)
gelöst Frage von Bernhard-BRouter & Routing10 Kommentare

Hallo, ich habe ein kleines Problem mit dem Betrieb eines Asterisk VoiP Servers hinter meiner Cisco Hardware. Zum Aufbau: ...

Firewall
SMTP Regel Cisco ASA Firewal
gelöst Frage von YannoschFirewall10 Kommentare

Hallo all, nachdem ich nun durch die Hilfe von Aqui die ASA in den Betrieb nehmen konnte habe ich ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Sicherheitslücke Spectre und Meltdown: Status prüfen

Anleitung von Frank vor 5 StundenErkennung und -Abwehr1 Kommentar

Nach all den Updates der letzten Woche sollte man unbedingt auch den Status prüfen, ob die Sicherheitslücke Spectre und ...

Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 1 TagMicrosoft Office9 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 1 TagDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 1 TagSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Drucker und Scanner
Gesucht DIN A3 Drucker
Frage von NebellichtDrucker und Scanner15 Kommentare

Hallo, ich möchte einen neuen DIN A3 Drucker kaufen. Um ab und zu, ca. 1 mal die Woche Farbausdrucke ...

iOS
Einladung vom iphone kalender
Frage von jensgebkeniOS15 Kommentare

Hallo Gemeinschaft, folgendes Problem - immer wenn ich von meinem Iphone einen Termin einztrage und diesem Termin Teilnehmer zuweise, ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...