Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Native vlan missmatch und Trunk Port

Frage Netzwerke LAN, WAN, Wireless

Mitglied: brammer

brammer (Level 4) - Jetzt verbinden

26.09.2012, aktualisiert 17:57 Uhr, 4637 Aufrufe, 13 Kommentare

Hallo,

folgende Situation:

Bei einem Kunden steht ein Cisco 2960.
Dieser ist mit 2 LWL Verbindungen (Port 23 und 24) an einem Cisco 3750
Beide Ports sind als Trunk Konfiguriert.
Spanning Tree sorgt dafür das einer der Ports deaktiviert ist.
Soweit so gut.
Seit heute gibt es das Problem das die aktive Verbindung über Port 24 funktioniert, aber sobald das Kabel in Port 23 steckt Gibt es Kommunikationsprobleme, icmp geht, clients hinter dem Switch könne andere Clients in anderen Segmenten anpingen.
Zugriffe per VNC oder RDP sind nicht möglich. Bei dem Versuch eine VNC Verbindung aufzubauen brincht die gesamte Kommunikation im Netz zusammen, wird das Kabel am Port 23 abgesteckt geht die Kommuikation wieder und auch eine Kommunikation per VNC ist möglich.
Der Tausch gegen eine anderen Switch hat keinen Erfolg gehabt.
Es gibt keine relevanten Log Einträge

01.
  
02.
//Config auf dem 2960 und dem 3750:// 
03.
sh run  
04.
vlan 4094 
05.
 name native 
06.
07.
08.
//config auf dem Port 2960, die auf dem 3750 ist analog dazu// 
09.
interface FastEthernet0/23 
10.
 description Uplink zu Layer3 
11.
 switchport trunk native vlan 4094 
12.
 switchport mode trunk 
13.
 switchport nonegotiate 
14.
15.
interface FastEthernet0/24 
16.
 description Uplink zu Layer3 
17.
 switchport trunk native vlan 4094 
18.
 switchport mode trunk 
19.
 switchport nonegotiate 
20.
21.
22.
//Config auf dem 2960 und dem 3750:// 
23.
sh vlan 
24.
1    default                          active    Fa0/23 
25.
26.
4094 native                           active     
27.
 
28.
000007: *Mar  1 01:00:26.496: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 4094 on FastEthernet0/24 VLAN1. 
29.
000008: *Mar  1 01:00:26.496: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/24 on VLAN4094. Inconsistent peer vlan. 
30.
000009: *Mar  1 01:00:26.496: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/24 on VLAN0001. Inconsistent local vlan. 
31.
000027: Sep 26 14:09:29.480: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/24 on VLAN4094. Port consistency restored. 
32.
000028: Sep 26 14:09:29.480: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/24 on VLAN0001. Port consistency restored. 
33.
000030: Sep 26 14:10:03.464: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to up 
34.
000031: Sep 26 14:10:24.708: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to down 
35.
000034: Sep 26 14:11:06.912: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to up 
36.
000035: Sep 26 14:11:10.713: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to down


Wieso bricht diese Kommunikation einfach zusammen?
Mitglied: MrNetman
26.09.2012 um 16:59 Uhr
Hi Brammer,

Da passen wohl Konfigurationen nicht zusammen.
du schreibst von Port 23 und 24.
Im Listing steht 23 und 14
Auch ist im 2960 ein native VLAN 4094 eingerichtet und im 3750 ein native VLAN 001.
Da muss man ja schon froh sein, dass sich der Switch beschwert. Erfahren tut er dies über CDP.

Beim Switchtausch wird ja auch die Konfiguration wieder eingespielt, sonst würde er gar nicht funktionieren.

Native VLAN ist üblicherweise dasjenige, das auf den Uplinks nicht getaggt wird um den Kollegen Switchen die Verbindung zu erlauben.

Gruß
Net(works)man
Bitte warten ..
Mitglied: brammer
26.09.2012 um 17:55 Uhr
Hallo,

@MrNetman
im wesentlichen mein Fehler im Listing ist ein Fehler in de Übertragung dor Muss es auch Port 24 heißen.

Im 3750 ist eben kein native VLAN 001 sondenr auch ein native VLAN 4094 eingerichtet.

Den Text im Ursprungsthread habe ich angepasst.

brammer
Bitte warten ..
Mitglied: Deepsys
26.09.2012 um 19:23 Uhr
Hi Brammer,

Ich komme zwar aus der Nortel und Juniper Ecke, aber ich vermute das Problem eher im Spanning Tree. Der Log beginnt mit einem BPDU der dann wohl geblockt wurde. Und das deutet auf Spanning Tree hin. Was für ein STP läuft denn da? Müsste ja MLSTP sein, oder?
Hast du davon mal die Konfiguration?

Und von welchem Switch sind die Log, von beiden?
Verstehe ich wegen den Uhrzeiten nicht ganz.

Ich persönlich verwende solchen wohl Redundanzverbindung gerne LACP. Dann hast du auch eine Redundanz und sogar mehr Bandbreite.

Viele Grüße
Deepsys
Bitte warten ..
Mitglied: Deepsys
26.09.2012 um 19:26 Uhr
Noch was:
Gibt es noch mehr STP fähige Switche im Netz?
Kann es sein das sich die Rootbridge geändert hat?

Ja, ich tippe eher auf Spanning Tree
Bitte warten ..
Mitglied: brammer
26.09.2012 um 19:54 Uhr
Hallo,

@Deepsys

es gibt insgesamt 45 Switche in diesem Netz.
Core ist ein Verbund aus 3 3750 Switchen.
Die Konfiguration der Switche wurde seit Monaten nicht angefasst (überprüft...)
Eine Änderung der Routebridge ist daher auszuschließen...

Der Fehler ist ohne erkennbaren Grund heute vormittag gegen 10:00 Uhr aufgetreten.

Spanning Tree ist natürlich ein Thema. Wird morgen weiter untersucht, heute war es erstmal wichtig das Netz wieder zum laufen zu bringen.

brammer
Bitte warten ..
Mitglied: Deepsys
26.09.2012 um 20:53 Uhr
N'Abend,

Ok. Aber warum geht dann Ping und kein VNC?
Das spricht doch eher für ein Layer 3 Problem ....

Welchen Switch hast du getauscht?
Kann es sein das einfach der 3750 defekt ist und nur noch Mist macht?
Ich meine einfach sollte das ja nicht passieren ....

Ruhigen Abend noch.

Viele Grüße
Deepsys
Bitte warten ..
Mitglied: brammer
26.09.2012 um 21:08 Uhr
Hallo,

@Deepsys
Wenn der 3750 oder der 2960 Mist machen würde sollte ja was im Logfile stehen...

Ich bin mir ja noch mal sicher das es sich nicht um ein Layer 7 Problem handelt.
Das ICMP durchgeht heißt ja eigentlich bis L3 ist alles okay, erst darüber geht was schief...
Aber wieso geht es dann wieder wenn die LWL Verbindung von Port 23 gezogen wird??
Das begreife ich nicht...

brammer
Bitte warten ..
Mitglied: 108012
27.09.2012 um 01:25 Uhr
Hallo brammer,

bei den BPDU´s handelt es sich um Nachrichten, die zwischen Switchen ausgetauscht werden, hinsichtlich
der Berechnung der Spanning Tree Topologie, zur Kalkulation und Sicherung des STP´s.

Und mit der BPDU oder Nachricht in Zeile 28/29 wird auf einen Fehler hingewiesen.

Ich habe Dir einmal drei Dokumente rausgesucht und ich hoffe Du kannst den Fehler dann abstellen!

Cisco 29xx Series

Cisco 35xx Series

Cisco Native VLAN STP BPDU Trooble Shooting

Die Fehlermeldung aus Zeile 28/29 wird dort explizit behandelt, einmal global und die anderen beiden Male direkt auf die Switche bezogen.

Viel Glück und Erfolg

Gruß
Dobby
Bitte warten ..
Mitglied: virtuelleruser
27.09.2012 um 08:59 Uhr
Hallo Brammer,

wenn du an den Core und Access Switchen das VTP aktivierst dann verteilen sich die VLANs automatisch auf die Switche. Die Core laufen da als Server und die Access Switche als Client. Somit werden die VLANs nur noch am Core angelegt.
Switche
ip domain-name (deine Domäne)
vtp domain (Name frei Wählbar aber überall gleich)
vtp mode trans (Transparent Mode zum konfigurieren)
vtp version 2 (Version 3 wenn unterstützt)

vtp password (frei Wählbar aber überall gleich)
danach die Core Switche zum Server machen

VTP Mode Server

Und die Access Switche zum Client

VTP Mode client

Sh vtp status (zeigt alle Einstellungen)

Hier das entsprechende Cisco Dokument.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/rele ...

Danach noch den Spanning tree an jedem Switch Global konfigurieren:
spanning-tree mode rapid-pvst
spanning-tree portfast default
spanning-tree portfast bpduguard default
no spanning-tree extend system-id
Hier das Cisco Dokument:
http://www.cisco.com/en/US/products/hw/switches/ps708/products_configur ...

Ich hoffe das hilft dir ein wenig.

Gruß
virtuelleruser
Bitte warten ..
Mitglied: Deepsys
27.09.2012 um 11:32 Uhr
Hi,


Zitat von brammer:
Wenn der 3750 oder der 2960 Mist machen würde sollte ja was im Logfile stehen...
Och ich hatte mal so einen schönen fabrikneuen Juniper Switch der entweder einfach stehen blieb, oder sich einfach aus dem Cluster entfernte.
Im Log stand nichts, nach dem Austausch und der gleichen Konfig, läuft der seit Monaten.

Gerade wenn das RAM defekt ist, kann dir alles passieren, da der Switch ja auch nicht mehr so richtig weiß was er tut.
Und ich habe es auch nicht geglaubt, aber es gibt einen Markt für gefälschte elektronische Bauteile. Steht AMD oder so drauf, ist aber China-/sonstwas- Bude drin ....

VG
Deepsys
Bitte warten ..
Mitglied: aqui
27.09.2012, aktualisiert um 15:54 Uhr
Du solltest niemals die obersten 10 VLAN Ports in aktiven Kommunikationen verwenden. Diese werden System intern verwendet für QoS, STP Derivate und andere Funktionalitäten.
Am besten sollte alles über 4050 tabu sein.
Das du da einen interen Port benutzt zeigt die Tatsacdhe das das System kollabiert.
Bleibe am besten unter 4000 wenn du kannst, dann gibt es auch keinerlei Probleme. Vermutlich verschwinden die dann auch sofort.
Bitte warten ..
Mitglied: Deepsys
01.10.2012 um 11:06 Uhr
Hallo Brammer,

wie ist das denn hier ausgegangen?
Läuft es wieder?

VG
Deepsys
Bitte warten ..
Mitglied: brammer
02.10.2012 um 09:39 Uhr
Hallo,

ein zickender 2960 wurde getauscht, die Konfiguration wurde an ein paar Stellen angepasst.
Im Moment ist das alles in Ordnung.

@aqui
die Verwenudung von VLAN ID 4094 war die Empfehlung eines CCIE aus Halbergmoos...
Vermutlich werden wir im Rahmen des nächsten geplantne Stillstandes dort ein paar Sachen mehr ändenr müssen.
Hast du dazu eventuell ein paar Dokumente?

brammer
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
VLAN Trunk Port, ICMP nicht mehr möglich
Frage von mk1701LAN, WAN, Wireless10 Kommentare

Hallo, es geht um einen CISCO AccessSwitch 2960. Ports sind auf Access-Mode gestellt - ICMP im Netz ist möglich. ...

Netzwerkgrundlagen
Nativ Vlan per Trunkport?
gelöst Frage von MikePostNetzwerkgrundlagen10 Kommentare

Hallo zusammen Ich dachte bis letzter Woche das man pro Switch/Trunkport nur ein Native Vlan haben kann. Per default ...

Netzwerkgrundlagen
Vlan Trunk bereitet Probleme
Frage von KampfwurstNetzwerkgrundlagen3 Kommentare

Hallo Ich würde gerne um mich weiterzubilden das Netzwerk zuhause gerne einwenig umbauen. ;-) Auf Routerboard Hardware Jetzt benötige ...

LAN, WAN, Wireless
Mikrotik VLAN Trunk und Accessport
gelöst Frage von wireless-teamLAN, WAN, Wireless4 Kommentare

Hallo Leute, wir möchte ein Hotspotnetz aufbauen welches aber unser bestehendes Netzwerk nicht beeinflussen darf oder soll. Um Broadcast ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 23 StundenWindows 102 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 1 TagInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Windows Server
GPO nur für bestimmte Computer
Frage von Leo-leWindows Server13 Kommentare

Hallo Forum, gern würde ich ein Robocopy script per Bat an eine GPO hängen. Wichtig wäre aber dort der ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server13 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...

Windows Tools
Software-Tool zum Entfernen von bösartigem Windows
Frage von emeriksWindows Tools11 Kommentare

Hi, siehe Betreff hat das jemals irgendjemand schonmal sinnvoll eingesetzt? (MRT) E.

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...