Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Native Vlan über Trunk nicht erreichbar

Frage Netzwerke LAN, WAN, Wireless

Mitglied: 1x1speed

1x1speed (Level 1) - Jetzt verbinden

30.04.2013, aktualisiert 10.02.2015, 3153 Aufrufe, 5 Kommentare

Hallo,

ich habe an ein paar Switchen ein merkwürdiges Verhalten. Vorerst einmal ein par Worte zum Netzwerk.
Das Core Netz besteht aus 4 Switchen SW1-SW2-SW3-SW4 welche über Trunk Ports in einem Ring miteinander verbunden sind. SW1 und SW2 sind Cisco 3750 und machen das interne Routing der VLans per HRSP. SW1 und SW2 haben die Rolle der VTP Server.

Einen Teil der Etagenverteiler Switche EV-SW1 (Cisco2960) sind derzeit an SW3 angeschlossen. Nun ist die endgültige Verkabelung abgeschlossen und Patchfelder aufgelegt, so dass ich die Etagenverteiler EV-SW1,EV-SW2 und EV-SW3 im Ring an SW1 und SW2 patchen möchte.

Nun hab ich auf SW1 und SW 2 die Trunk Ports konfiguriert analog der alten Trunk Config auf SW3, das Native Vlan ist bei mir Vlan100 und hab EV-SW1 - auf SW1 gepatcht. Merkwürdigerweise ist das Vlan100 und damit auch das Management Interface von EV-SW1 nicht mehr erreichbar. Die Clients welche an dem Switch EV-SW1 hängen funktionieren und haben alle ihre jeweiligen VLans.

Sobald ich den Switch EV-SW1 wieder an den alten Port auf SW3 stecke ist Vlan100 auf dem EV-SW1 wieder erreichbar.

Die Trunks sind identsich konfigiuriert und ich bekomme auch keinerlei Fehlermeldungen im Log sobald ich wieder auf SW1 umstecke nur der ARP-Eintrag vom Interface Vlan100 des EV-SW1 verschwindet auf den Core Systemen SW1 und SW2.

Vlan100 ist auch in der Vlan-Database auf EV-SW1 vorhanden.

Das gleiche Verhalten haben auch alle anderen 2960er die ich in den Ring mit übernehmen möchte.

Momentan bin ich da ein wenig ratlos.

Mitglied: aqui
01.05.2013, aktualisiert um 12:38 Uhr
Generell einmal eine Anmerkungen zu einer Rindstruktur bei 2-3 Switches und mehr: Sowas ist im Ethernet Umfeld immer kontraproduktiv, da du in einem redundanten Netzwerk Szenario in die Gefahr läufst das Spanning Tree Failover Zeiten bis zu 6 bis 10 Minuten dauern können und so das Netzwerk lahmlegen.
Das gilt sowohl für Ciscos Defualt PVSTP+ und auch PVRSTP+.
Sternszenarien sind bei Ethernet Designs also wenn möglich immer zwingend vorzuziehen bei einer Redundanz.

Ein klassisches redundantes Ethernet Design sähe z.B. so aus:
e2b75ce5cbdc8294c56f44c74324ad0d-switchnetz - Klicke auf das Bild, um es zu vergrößern
Wenn möglich sollte man sich daran orientieren und Ringstrukturen immer vermeiden.

Was dein Problem anbetrifft wäre ein Konfigauszug der Trunk Konfigs sehr hilfreich hier.
Es gibt 2 Punkte die du beachten musst:
  • Die Management IP Adresse muss unter interface vlan 100 auf allen Switches definiert sein !
  • Die Uplink Konfigs der Trunks sähe so aus: switchport mode trunk, switchport trunk allow vlan all und switchport trunk native vlan 100
Letzteres muss konsequent an allen Uplink Ports und zwar beidseitig konfiguriert sein !
Wenn du das beachtest sollte das fehlerlos zum Fliegen kommen...!
Bitte warten ..
Mitglied: 1x1speed
19.05.2013 um 08:23 Uhr
Hi Aqui,

vielen Dank für Deine ausführliche Antwort. Ich habe nun die Patchung nicht als Ring, sondern nach dem klassisched Design geändert. Wenn die Access Switche an den beiden Cores hängen, dann kommt eine Verbindung auf dem Management Interfache Vlan100 nur zustande, wenn ich aus der Trunk Config das Vlan100 nicht auch als Native konfiguriere, wie es vorher der Fall war.

Hier noch mal die alten Trunk Configs bei denen Native Vlan auch das 100er ist

Trunk SW1 (keine Verbindung zum Access Switch da Vlan100 native)
01.
interface Gi1/0/24 
02.
 description Trkunk EV-SW1 Gi1 
03.
 switchport trunk encapsulation dot1q 
04.
 switchport trunk native vlan 100 
05.
 switchport trunk allowed vlan 1,10,15,20,25,30,100 
06.
 switchport mode trunk
Trunk SW2 (keine Verbindung zum Access Switch da Vlan100 native)
01.
interface Gi1/0/24 
02.
 description Trkunk EV-SW1 Gi2 
03.
 switchport trunk encapsulation dot1q 
04.
 switchport trunk native vlan 100 
05.
 switchport trunk allowed vlan 1,10,15,20,25,30,100 
06.
 switchport mode trunk

Trunk EV-SW1 (keine Verbindung zum Access Switch da Vlan100 native)
01.
interface Gi0/1 
02.
 description Trkunk SW1 Gi1/0/24 
03.
 switchport trunk encapsulation dot1q 
04.
 switchport trunk native vlan 100 
05.
 switchport trunk allowed vlan 1,10,15,20,25,30,100 
06.
 switchport mode trunk 
07.
 
08.
interface Gi0/2 
09.
 description Trkunk SW2 Gi1/0/24 
10.
 switchport trunk encapsulation dot1q 
11.
 switchport trunk native vlan 100 
12.
 switchport trunk allowed vlan 1,10,15,20,25,30,100 
13.
 switchport mode trunk 
14.
 
Bitte warten ..
Mitglied: aqui
LÖSUNG 19.05.2013, aktualisiert 10.02.2015
Ein "native VLAN" bedeutet immer nur das alle Pakete die untagged an diesem Port anliegen in das VLAN geforwardet werden was "native" ist ! Bzw. aus dem VLAN 100 untagged an diesem Trunk geforwardet werden.
Man kann also so das Verhalten normalerweise VLAN1 Traffic so zu forwarden auf andere VLANs umlenken.
Das Kommando behandelt also einzig und allen die Tatsache WIE mit untagged Traffic an Trunk Ports umgegangen wird, nicht mehr und nicht weniger !
Wenn du also an so einen konfigurierten Trunk Port einen herstellerfremden Access Switch ankorkst, dann forwardet der in der Regel untagged Traffic immer vom VLAN 1 (Defualt) !
Bei vielen Billigswitches lässt sich das auch nicht ändern. Darauf musst du also achten das du hier keinen VLAN Mismatch hast !
Und nochwas lauert im Detail:
Da du einen Cisco einsetzt macht der im Default PVSTP+ also ein proprietäres "Per VLAN" Spanning Tree Verfahren, was nur eine ganz kleine Anzahl anderer Hersteller wie z.B. Brocade, Extreme auch supporten.
Der Großteil der Hersteller speziell die Billigheimer wie HP usw. aber nicht !
Koppelst du nun solche Switches mit einem solchen Trunkport an kommt es unweigerlich zu nicht vorhersehbaren STP Problemen die in einem Blocking des native VLANs enden können. Der Grund ist das die STP Verfahren nicht kompatibel sind !
Vergiss also das auch nicht. Transparent funktioniert das nur in einer reinen Cisco Umgebung so !!
Ist das mixed muss man etwas tricksen !
Bitte warten ..
Mitglied: 1x1speed
10.02.2015 um 11:43 Uhr
Servus,

ich hatte auf einem Switch folgendes globale Config-Zeile übersehen:

01.
vlan dot1q tag native 
diese hab ich entfernt und auf allen Trunk Ports gecheckt ob das native Vlan eingetragen ist, jetzt funktioniert es.

Danke noch mal
Bitte warten ..
Mitglied: aqui
LÖSUNG 10.02.2015, aktualisiert 12.02.2015
Ja richtig, damit wird global das Native VLAN getagged was in der Regel bei 98% aller Switch Hersteller unüblich ist. Das Gros überträgt auf tagged Uplinks das native oder Default VLAN immer untagged.
Auch wenn du das Kommando oben in der globalen Konfig hast kann man oft auf dem Interface sowas wie :
interface ethernet 1/1
switchport mode trunk
switchport trunk allow vlan all
no switchport trunk tag native vlan

konfigurieren.
Damit lässt sich das dann das native VLAN Tagging bei einigen Herstellern auch portbasierend deaktivieren.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
VLAN Trunk Port, ICMP nicht mehr möglich (10)

Frage von mk1701 zum Thema LAN, WAN, Wireless ...

Netzwerkprotokolle
gelöst Problem bei VLAN Trunk mit LACP zwischen HP und Cisco (11)

Frage von markuswo zum Thema Netzwerkprotokolle ...

Netzwerkmanagement
gelöst Mehrere Switche per Trunk verbinden - korrekte VLAN-Config (8)

Frage von Stadtaffe84 zum Thema Netzwerkmanagement ...

Netzwerkgrundlagen
gelöst Vlan Routing Pfsense APU2 vs L3 (4)

Frage von TimMayer zum Thema Netzwerkgrundlagen ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...